# Cannot restore open indices in new empty cluster

**URL:** https://discuss.elastic.co/t/cannot-restore-open-indices-in-new-empty-cluster/351176
**Category:** Elasticsearch
**Created:** [January 16, 2024, 2:53pm UTC](https://discuss.elastic.co/t/cannot-restore-open-indices-in-new-empty-cluster/351176 "2024-01-16T14:53:17Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![mebaj91360](https://avatars.discourse-cdn.com/v4/letter/m/b4bc9f/32.png) [@mebaj91360](https://discuss.elastic.co/u/mebaj91360)
#### Post date: [January 16, 2024, 2:53pm UTC](https://discuss.elastic.co/t/cannot-restore-open-indices-in-new-empty-cluster/351176/1 "2024-01-16T14:53:17Z")

</div>

Hello,

I am trying to restore a snapshot on a new, empty cluster, but I get this error:

```auto
[restore-old:snapshot-2024.01.09-5ebjtwcnqksvliv3h9tcug/r4dfaUrJQXyQ0xxVa0OE8Q] cannot restore index [logstash-2023.09.02] because an open index with same name already exists in the cluster. Either close or delete the existing index or restore the index under a different name by providing a rename pattern and replacement name

```

The thing is, this is a new, empty cluster, and this index appears only after starting the restore procedure.  
I tried to remove all the indices and retry restore with different options multiple times, but nothing seems to work, could it be an issue in the snapshot itself?

The snapshot comes from a cluster running 8.3.2, and the new one is running 8.11.0

The snapshot repository is configured in the new cluster as read-only

![image](https://us1.discourse-cdn.com/elastic/original/3X/b/8/b896c5ce305bec2882387aeeea8ce360cccd8f81.png)

---

<div class="post-metadata">

### Author: ![mebaj91360](https://avatars.discourse-cdn.com/v4/letter/m/b4bc9f/32.png) [@mebaj91360](https://discuss.elastic.co/u/mebaj91360)
#### Post date: [January 16, 2024, 3:43pm UTC](https://discuss.elastic.co/t/cannot-restore-open-indices-in-new-empty-cluster/351176/2 "2024-01-16T15:43:54Z")

</div>

I realized that even if there is an error for a particular index, it does not mean the restore procedure failed for all of them. If you start the restore procedure multiple times, it will fail because some indices are still being restored from the previous attempts, even though there were errors.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 13, 2024, 3:44pm UTC](https://discuss.elastic.co/t/cannot-restore-open-indices-in-new-empty-cluster/351176/3 "2024-02-13T15:44:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
