# Cannot run kibana on centos7

**URL:** https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457
**Category:** Kibana
**Created:** [June 26, 2018, 3:05pm UTC](https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457 "2018-06-26T15:05:17Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![memery\_xmb](https://avatars.discourse-cdn.com/v4/letter/m/e274bd/32.png) [@memery\_xmb](https://discuss.elastic.co/u/memery_xmb)
#### Post date: [June 26, 2018, 3:05pm UTC](https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457/1 "2018-06-26T15:05:17Z")

</div>

```
My ElasticSearch setting:

    # Set the bind address to a specific IP (IPv4 or IPv6):
    #
    network.host: 192.168.25.133
    #
    # Set a custom port for HTTP:
    #
    http.port: 9200;

```

And it runs both on localhost and remote:

```
        {
          "name" : "p_qVGHZ",
          "cluster_name" : "elasticsearch",
          "cluster_uuid" : "iJKkHW2dTGSPD3d2yk-a-A",
          "version" : {
            "number" : "6.3.0",
            "build_flavor" : "default",
            "build_type" : "tar",
            "build_hash" : "424e937",
            "build_date" : "2018-06-11T23:38:03.357887Z",
            "build_snapshot" : false,
            "lucene_version" : "7.3.1",
            "minimum_wire_compatibility_version" : "5.6.0",
            "minimum_index_compatibility_version" : "5.0.0"
          },
          "tagline" : "You Know, for Search"
        }

```

BUT when I run kibana and my setting like :

```
    server.port: 5601
    elasticsearch.url: "http://192.168.25.133:9200"
    server.host: "0.0.0.0"

```

I get the following error which I cannot figure out what happend:

```
        [error][reporting] Failed to install browser. See kibana logs for more details.
         error [15:03:25.596] [fatal] ExtractError: Failed to extract the phantom.js archive
            at Extract.<anonymous> (/usr/local/kibana-6.3.0-linux-x86_64/node_modules/x- 
              pack/plugins/reporting/server/browsers/extract/bunzip2.js:24:16)
            at emitOne (events.js:121:20)
            at Extract.emit (events.js:211:7)
            at Extract.destroy (/usr/local/kibana-6.3.0-linux-x86_64/node_modules/tar-stream/extract.js:191:17)
            at onunlock (/usr/local/kibana-6.3.0-linux-x86_64/node_modules/tar-stream/extract.js:69:26)
            at /usr/local/kibana-6.3.0-linux-x86_64/node_modules/tar-fs/index.js:234:25
            at FSReqWrap.oncomplete (fs.js:135:15)
        FATAL { ExtractError: Failed to extract the phantom.js archive
            at Extract.<anonymous> (/usr/local/kibana-6.3.0-linux-x86_64/node_modules/x-pack/plugins/reporting/server/browsers/extract/bunzip2.js:24:16)
            at emitOne (events.js:121:20)
            at Extract.emit (events.js:211:7)
            at Extract.destroy (/usr/local/kibana-6.3.0-linux-x86_64/node_modules/tar-stream/extract.js:191:17)
            at onunlock (/usr/local/kibana-6.3.0-linux-x86_64/node_modules/tar-stream/extract.js:69:26)
            at /usr/local/kibana-6.3.0-linux-x86_64/node_modules/tar-fs/index.js:234:25
            at FSReqWrap.oncomplete (fs.js:135:15)
          name: 'ExtractError',
          cause:
           { Error: EPERM: operation not permitted, utime '/usr/local/kibana-6.3.0-linux-x86_64/data/phantomjs-2.1.1-linux-x86_64/'
             errno: -1,
             code: 'EPERM',
             syscall: 'utime',
             path: '/usr/local/kibana-6.3.0-linux-x86_64/data/phantomjs-2.1.1-linux-x86_64/' } }

```

Can you guys tell me how to fix it?Appreciate your help

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [June 26, 2018, 7:07pm UTC](https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457/2 "2018-06-26T19:07:07Z")

</div>

Hm, the error is coming from reporting. Looks like a permissions issue when trying to extract the phantom archive. Does the user you are running Kibana on have permissions to do that?

Or you can extract the archive yourself (related: [X-pack plugin:reporting - Permission Denied Ubuntu](https://discuss.elastic.co/t/x-pack-plugin-reporting-permission-denied-ubuntu/46753))

---

<div class="post-metadata">

### Author: ![memery\_xmb](https://avatars.discourse-cdn.com/v4/letter/m/e274bd/32.png) [@memery\_xmb](https://discuss.elastic.co/u/memery_xmb)
#### Post date: [June 27, 2018, 3:45am UTC](https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457/3 "2018-06-27T03:45:37Z")

</div>

I noticed that in 6.3.0 version the data dir in kibana has a lot new folders that is not appeared in earlier verion. I had granted the entire kibana dir to es user but still got above error.Did you mean the es user don't have permissions to the phantom archive?  
Also I have tried the windows version and it worked well. I really confused

---

<div class="post-metadata">

### Author: ![memery\_xmb](https://avatars.discourse-cdn.com/v4/letter/m/e274bd/32.png) [@memery\_xmb](https://discuss.elastic.co/u/memery_xmb)
#### Post date: [June 27, 2018, 11:39am UTC](https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457/4 "2018-06-27T11:39:32Z")

</div>

Ok, tonight I wana to remove all the files in kibana using 'rm -rf' , but it gived me 'Permission denied'.  
Looks like I somehow extract or run the kibana with 'root' user and cause the permission issues.  
I redownloaded the kibana package and reconfig it solved my problem.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 25, 2018, 11:39am UTC](https://discuss.elastic.co/t/cannot-run-kibana-on-centos7/137457/5 "2018-07-25T11:39:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
