# Cannot set eager in ES as by ES guide

**URL:** <https://discuss.elastic.co/t/cannot-set-eager-in-es-as-by-es-guide/97406>\
**Category:** Elasticsearch\
**Created:** [August 17, 2017, 12:07pm UTC](https://discuss.elastic.co/t/cannot-set-eager-in-es-as-by-es-guide/97406 "2017-08-17T12:07:45Z")\
**Posts on this page:** 1\
**Showing post:** 8

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [September 7, 2017, 6:46am UTC](https://discuss.elastic.co/t/cannot-set-eager-in-es-as-by-es-guide/97406/8 "2017-09-07T06:46:43Z")

</div>

I've removed the old index and created a new one with mapping predefined.

Last time 760 710 643 went through logstash without no problems. This time I've a predefined mapping and replaced kv filter with custom written filter in ruby, because kv was not working as it should.

Afer 81 711 586 I'm on a standstill. I'm getting this error:

```auto
2017-09-07T08:37:04+02:00 ERR Failed to publish events caused by: read tcp 127.0.0.1:49569->127.0.0.1:5044: i/o timeout
2017-09-07T08:37:04+02:00 INFO Error publishing events (retrying): read tcp 127.0.0.1:49569->127.0.0.1:5044: i/o timeout
2017-09-07T08:37:33+02:00 INFO Non-zero metrics in the last 30s: libbeat.logstash.publish.read_errors=1 libbeat.logstash.published_but_not_acked_events=1940
2017-09-07T08:38:03+02:00 INFO Non-zero metrics in the last 30s: libbeat.logstash.call_count.PublishEvents=1 libbeat.logstash.publish.write_bytes=550

```

As it was recomended here: [ERR Failed to publish events caused by: read tcp IP:40634-\>IP:5044: i/o timeout](https://discuss.elastic.co/t/err-failed-to-publish-events-caused-by-read-tcp-ip-40634-ip-5044-i-o-timeout/90355/6) I've raised timeout to 60s and it still didn't work.

---

_[View the full topic](https://discuss.elastic.co/t/cannot-set-eager-in-es-as-by-es-guide/97406)._
