# Cannot set password for new user Kibana ECK 7.4.2

**URL:** <https://discuss.elastic.co/t/cannot-set-password-for-new-user-kibana-eck-7-4-2/207437>\
**Category:** Kibana\
**Created:** [November 12, 2019, 4:28am UTC](https://discuss.elastic.co/t/cannot-set-password-for-new-user-kibana-eck-7-4-2/207437 "2019-11-12T04:28:23Z")\
**Posts on this page:** 1\
**Showing post:** 11

<div class="post-metadata">

**Author:** ![oaaraya](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/oaaraya/32/57509_2.png) [@oaaraya](https://discuss.elastic.co/u/oaaraya)\
**Post date:** [November 13, 2019, 9:13pm UTC](https://discuss.elastic.co/t/cannot-set-password-for-new-user-kibana-eck-7-4-2/207437/11 "2019-11-13T21:13:49Z")

</div>

Found the solution here:

> [@New user can't login kibana](https://discuss.elastic.co/t/new-user-cant-login-kibana/204810):
>
> I setup eck and login by default "elastic" account successfully.But I or logstash can't login by new account created in kibana. {"statusCode":401,"error":"Unauthorized","message":"[security\_exception] unable to authenticate user [gmt-log-logstash] for REST request [/\_security/\_authenticate], with { header={ WWW-Authenticate={ 0="Bearer realm=\"security\"" & 1="ApiKey" & 2="Basic realm=\"security\" charset=\"UTF-8\"" } } }"}

There is a bug and the realm is not set for ECK

---

_[View the full topic](https://discuss.elastic.co/t/cannot-set-password-for-new-user-kibana-eck-7-4-2/207437)._
