# Cannot start Elasticsearch after upgrade from 1.7.3

**URL:** https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825
**Category:** Elasticsearch
**Created:** [November 29, 2015, 11:05am UTC](https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825 "2015-11-29T11:05:26Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Dang\_Van\_Chuyen](https://avatars.discourse-cdn.com/v4/letter/d/e5b9ba/32.png) [@Dang\_Van\_Chuyen](https://discuss.elastic.co/u/Dang_Van_Chuyen)
#### Post date: [November 29, 2015, 11:05am UTC](https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825/1 "2015-11-29T11:05:26Z")

</div>

I checked with migration plugin and everything's ok. I upgraded with yum.  
This is the message:

> Process: 7195 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile=${PID\_DIR}/elasticsearch.pid -Des.default.path.home=${ES\_HOME} -Des.default.path.logs=${LOG\_DIR} -Des.default.path.data=${DATA\_DIR} -Des.default.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
> Process: 7192 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
> Main PID: 7195 (code=exited, status=1/FAILURE)

> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.plugins.PluginsService.(PluginsService.java:108)  
> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.node.Node.(Node.java:148)  
> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.node.Node.(Node.java:129)  
> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)  
> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)  
> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)  
> Nov 29 18:19:34 elasticsearch[7195]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
> Nov 29 18:19:34 elasticsearch[7195]: Refer to the log for complete error details.  
> Nov 29 18:19:34 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
> Nov 29 18:19:34 systemd[1]: Unit elasticsearch.service entered failed state.

I did not change the path or install anything special.  
Thanks

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [November 29, 2015, 7:35pm UTC](https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825/2 "2015-11-29T19:35:28Z")

</div>

You've upgraded from 1.7.3 to 2.0 or 2.1 or...? The stacktrace indicates that the error is related to plugins so I'd try removing any plugins (which probably need to upgraded). This looks like your syslog—have you looked in ES's own log for additional details?

---

<div class="post-metadata">

### Author: ![ebuildy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ebuildy/32/6070_2.png) [@ebuildy](https://discuss.elastic.co/u/ebuildy)
#### Post date: [November 29, 2015, 8:17pm UTC](https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825/3 "2015-11-29T20:17:21Z")

</div>

The good thing with open-source are ... sources 😉

Check at

[https://github.com/elastic/elasticsearch/blob/master/core/src/main/java/org/elasticsearch/plugins/PluginsService.java#L95](https://github.com/elastic/elasticsearch/blob/master/core/src/main/java/org/elasticsearch/plugins/PluginsService.java#L95)

From the right branch according your ES version, you should find whats going bad.

---

<div class="post-metadata">

### Author: ![Dang\_Van\_Chuyen](https://avatars.discourse-cdn.com/v4/letter/d/e5b9ba/32.png) [@Dang\_Van\_Chuyen](https://discuss.elastic.co/u/Dang_Van_Chuyen)
#### Post date: [November 30, 2015, 4:27am UTC](https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825/4 "2015-11-30T04:27:10Z")

</div>

Thank you all,  
I removed the HQ plugin then the upgrade progress worked. !

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 11:34pm UTC](https://discuss.elastic.co/t/cannot-start-elasticsearch-after-upgrade-from-1-7-3/35825/5 "2017-07-05T23:34:58Z")

</div>


