# Cannot start ES after upgrading from 7.x to 8.x

**URL:** https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494
**Category:** Elasticsearch
**Created:** [September 20, 2023, 11:24pm UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494 "2023-09-20T23:24:24Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![roman-tasi](https://avatars.discourse-cdn.com/v4/letter/r/7ea924/32.png) [@roman-tasi](https://discuss.elastic.co/u/roman-tasi)
#### Post date: [September 20, 2023, 11:24pm UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494/1 "2023-09-20T23:24:24Z")

</div>

This is the error in my journalctl:

`Sep 20 11:39:43 ELK-Stack.uhtasi.local systemd[1]: Starting Elasticsearch...`  
`Sep 20 11:39:50 ELK-Stack.uhtasi.local systemd-entrypoint[29322]: Error occurred during initialization of boot layer`  
`Sep 20 11:39:50 ELK-Stack.uhtasi.local systemd-entrypoint[29322]: java.lang.module.ResolutionException: Modules jdk.compiler and tools export package com.sun.tools.javac to module com.sun.jna`  
`Sep 20 11:39:50 ELK-Stack.uhtasi.local systemd-entrypoint[29322]: ERROR: Elasticsearch exited unexpectedly, with exit code 1`  
`Sep 20 11:39:50 ELK-Stack.uhtasi.local systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE`  
`Sep 20 11:39:50 ELK-Stack.uhtasi.local systemd[1]: Failed to start Elasticsearch.`

If anyone can help

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [September 21, 2023, 6:25am UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494/2 "2023-09-21T06:25:40Z")

</div>

Could you share Elasticsearch full logs please?

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [September 21, 2023, 6:59am UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494/3 "2023-09-21T06:59:40Z")

</div>

Did you first upgrade to version 7.17 as outlined [in the documentation](https://www.elastic.co/guide/en/elasticsearch/reference/8.9/setup-upgrade.html)?

---

<div class="post-metadata">

### Author: ![roman-tasi](https://avatars.discourse-cdn.com/v4/letter/r/7ea924/32.png) [@roman-tasi](https://discuss.elastic.co/u/roman-tasi)
#### Post date: [September 21, 2023, 5:56pm UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494/4 "2023-09-21T17:56:38Z")

</div>

Yes I resolved the issues in Upgrade Assistant prior to upgrading.

---

<div class="post-metadata">

### Author: ![roman-tasi](https://avatars.discourse-cdn.com/v4/letter/r/7ea924/32.png) [@roman-tasi](https://discuss.elastic.co/u/roman-tasi)
#### Post date: [September 21, 2023, 5:56pm UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494/5 "2023-09-21T17:56:57Z")

</div>

It seems my `elasticsearch.log` actually isn't even being updated.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 19, 2023, 5:57pm UTC](https://discuss.elastic.co/t/cannot-start-es-after-upgrading-from-7-x-to-8-x/343494/6 "2023-10-19T17:57:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
