# Cannot start filebeat because of instance/beat.go error

**URL:** https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472
**Category:** Beats
**Tags:** filebeat
**Created:** [January 18, 2021, 8:37pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472 "2021-01-18T20:37:59Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![jfasajr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jfasajr/32/82472_2.png) [@jfasajr](https://discuss.elastic.co/u/jfasajr)
#### Post date: [January 18, 2021, 8:37pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/1 "2021-01-18T20:37:59Z")

</div>

When I run `filebeat setup -e`

It runs through and it is able to get through to the point of installing dashboard for kibana, but then fails due to an error, below:

```
Index setup finished.
Loading dashboards (Kibana must be running and reachable)
2021-01-18T20:06:27.304Z INFO kibana/client.go:119 Kibana url: http://134.122.15.171:5601
2021-01-18T20:06:30.458Z INFO kibana/client.go:119 Kibana url: http://134.122.15.171:5601
2021-01-18T20:07:38.928Z INFO instance/beat.go:815 Kibana dashboards successfully loaded.
Loaded dashboards
2021-01-18T20:07:38.928Z WARN [cfgwarn] instance/beat.go:556 DEPRECATED: Setting up ML using Filebeat is going to be removed. Please use the ML app to setup jobs. Will be removed in version: 8.0.0
Setting up ML using setup --machine-learning is going to be removed in 8.0.0. Please use the ML app instead.
See more: https://www.elastic.co/guide/en/machine-learning/current/index.html
2021-01-18T20:07:38.928Z INFO eslegclient/connection.go:99 elasticsearch url: http://localhost:9200
2021-01-18T20:07:38.939Z INFO [esclientleg] eslegclient/connection.go:314 Attempting to connect to Elasticsearch version 7.10.2
2021-01-18T20:07:38.939Z INFO kibana/client.go:119 Kibana url: http://134.122.15.171:5601
2021-01-18T20:07:38.973Z WARN fileset/modules.go:421 X-Pack Machine Learning is not enabled
2021-01-18T20:07:38.975Z ERROR instance/beat.go:956 Exiting: 1 error: error loading config file: invalid config: yaml: line 21: could not find expected ':'
Exiting: 1 error: error loading config file: invalid config: yaml: line 21: could not find expected ':'

```

If I run instead `filebeat setup --modules nginx --dashboards` It works, and I get the following results. However, I only see a filebeat-\* index in either the Discover section or when adding an index, and no predefined dashboards in Kibana.

```
Loading dashboards (Kibana must be running and reachable)
Loaded dashboards

```

I'm not even aware of what config file they are referring. If I could get some assistance, please and thank you.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 18, 2021, 10:22pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/2 "2021-01-18T22:22:42Z")

</div>

Welcome to our community! 😃

> [@jfasajr](#):
>
> `invalid config: yaml: line 21: could not find expected ':'`

Can you please show us your `filebeat.yml`, making sure you code format the text (like you did for the log above - thanks!).

---

<div class="post-metadata">

### Author: ![jfasajr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jfasajr/32/82472_2.png) [@jfasajr](https://discuss.elastic.co/u/jfasajr)
#### Post date: [January 18, 2021, 10:41pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/3 "2021-01-18T22:41:16Z")

</div>

Thanks for reaching out @warkolm, sure.

I've tried with the comments and without, and have had the same results, I'll post both below.

without comments:

```
filebeat.inputs:

- type: log
  enabled: false
  paths:
    - /var/log/*.log

- type: filestream
  enabled: false
  paths:
    - /var/log/*.log

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false

setup.template.settings:
  index.number_of_shards: 1

setup.kibana:
  host: http://134.122.15.171

output.elasticsearch:
  hosts: ["localhost:9200"]

processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~ 

```

With comments (original with my edit for setup.kibana host change:

```auto
###################### Filebeat Configuration Example #########################

# This file is an example configuration file highlighting only the most common
# options. The filebeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/filebeat/index.html

# For more available modules and options, please see the filebeat.reference.yml sample
# configuration file.

# ============================== Filebeat inputs ===============================

filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input specific configurations.

- type: log

  # Change to true to enable this input configuration.
  enabled: false

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    - /var/log/*.log
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  #exclude_lines: ['^DBG']

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular expression from the list.
  #include_lines: ['^ERR', '^WARN']

  # Exclude files. A list of regular expressions to match. Filebeat drops the files that
  # are matching any regular expression from the list. By default, no files are dropped.
  #exclude_files: ['.gz$']

  # Optional additional fields. These fields can be freely picked
  # to add additional information to the crawled log files for filtering
  #fields:
  # level: debug
  # review: 1

  ### Multiline options

  # Multiline can be used for log messages spanning multiple lines. This is common
  # for Java Stack Traces or C-Line Continuation

  # The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
  #multiline.pattern: ^\[

  # Defines if the pattern set under pattern should be negated or not. Default is false.
  #multiline.negate: false

  # Match can be set to "after" or "before". It is used to define if lines should be append to a pattern
  # that was (not) matched before or after or as long as a pattern is not matched based on negate.
  # Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
  #multiline.match: after

# filestream is an experimental input. It is going to replace log input in the future.
- type: filestream

  # Change to true to enable this input configuration.
  enabled: false

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    - /var/log/*.log
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  #exclude_lines: ['^DBG']

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular expression from the list.
  #include_lines: ['^ERR', '^WARN']

  # Exclude files. A list of regular expressions to match. Filebeat drops the files that
  # are matching any regular expression from the list. By default, no files are dropped.
  #prospector.scanner.exclude_files: ['.gz$']

  # Optional additional fields. These fields can be freely picked
  # to add additional information to the crawled log files for filtering
  #fields:
  # level: debug
  # review: 1

# ============================== Filebeat modules ==============================

filebeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

# ======================= Elasticsearch template setting =======================

setup.template.settings:
  index.number_of_shards: 1
  #index.codec: best_compression
  #_source.enabled: false

# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

# ================================= Dashboards =================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: http://134.122.15.171

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  #space.id:

# =============================== Elastic Cloud ================================

# These settings simplify using Filebeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Protocol - either `http` (default) or `https`.
  #protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: "id:api_key"
  #username: "elastic"
  #password: "changeme"

# ------------------------------ Logstash Output -------------------------------
#output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================
processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

# ================================== Logging ===================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

# ============================= X-Pack Monitoring ==============================
# Filebeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Filebeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.
#monitoring.cluster_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.
#monitoring.elasticsearch:

# ============================== Instrumentation ===============================

# Instrumentation support for the filebeat.
#instrumentation:
    # Set to true to enable instrumentation of filebeat.
    #enabled: false

    # Environment in which filebeat is running on (eg: staging, production, etc.)
    #environment: ""

    # APM Server hosts to report instrumentation results to.
    #hosts:
    # - http://localhost:8200

    # API Key for the APM Server(s).
    # If api_key is set then secret_token will be ignored.
    #api_key:

    # Secret token for the APM Server(s).
    #secret_token:

# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true

```

I've tried the following formats for the setup.kibana host property  
These 3 options with http and https and then repeat all 6 variants with the `:5601` port at the end.  
`"http://134.122.15.171"`  
`'http://134.122.15.171'`  
`http://134.122.15.171`  
I've tried both the http and https version of the domain with and without the port as well. I've even tried the subdomain, but I assume that won't work as that then gets proxied by nginx.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 18, 2021, 10:43pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/4 "2021-01-18T22:43:25Z")

</div>

Side note - your Kibana, and by extension Elasticsearch, is openly available on the internet. This is not really a good thing

---

<div class="post-metadata">

### Author: ![jfasajr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jfasajr/32/82472_2.png) [@jfasajr](https://discuss.elastic.co/u/jfasajr)
#### Post date: [January 18, 2021, 10:47pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/5 "2021-01-18T22:47:30Z")

</div>

Most certainly, this stuff isn't really production environment right now with any PII or anything I'm not uncomfortable sharing really. 🙂 . Once I get my bearings on how to install, work on all of this with Elastic Stack, I'll be locking this down. I also plan on using something more secure for authentication to the kibana web UI later. Thanks for looking out though.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 18, 2021, 10:49pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/6 "2021-01-18T22:49:58Z")

</div>

Did you make any changes to the Nginx module config file?

---

<div class="post-metadata">

### Author: ![jfasajr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jfasajr/32/82472_2.png) [@jfasajr](https://discuss.elastic.co/u/jfasajr)
#### Post date: [January 18, 2021, 10:50pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/7 "2021-01-18T22:50:53Z")

</div>

I did, should I not have?

```auto
# Module: nginx
# Docs: https://www.elastic.co/guide/en/beats/filebeat/7.10/filebeat-module-nginx.html

- module: nginx
  # Access logs
  access:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.paths: ["/var/log/nginx/access.log*"]

  # Error logs
  error:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.paths:["/var/log/nginx/error.log*"]

  # Ingress-nginx controller logs. This is disabled by default. It could be used in Kubernetes environments to parse ingress-nginx logs
  ingress_controller:
    enabled: false

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    #var.paths:

```

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 18, 2021, 10:57pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/8 "2021-01-18T22:57:36Z")

</div>

Just trying to pin the error down is all! 🙂

I was able to run your main `filebeat.yml` myself without errors. Can you try disabling the nginx module and run Filebeat?

---

<div class="post-metadata">

### Author: ![jfasajr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jfasajr/32/82472_2.png) [@jfasajr](https://discuss.elastic.co/u/jfasajr)
#### Post date: [January 18, 2021, 11:15pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/9 "2021-01-18T23:15:00Z")

</div>

So as this worked by disabling the module, I then removed the custom variables for path locations within `/etc/filebeat/modules.d/nginx.yml` and ran setup again. It completed without errors.

I don't have any additional nginx logs showing or dashboards, or indices in kibana, but I think this is a different problem.

Also, as you mentioned it, is there any documentation I'm looking over in the community on how to properly secure the Elk stack so that I still have proper remote access?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 18, 2021, 11:32pm UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/10 "2021-01-18T23:32:56Z")

</div>

[https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-security.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-security.html) is the best place to start there.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 16, 2021, 1:32am UTC](https://discuss.elastic.co/t/cannot-start-filebeat-because-of-instance-beat-go-error/261472/11 "2021-02-16T01:32:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
