# Cannot start logstash in command line

**URL:** <https://discuss.elastic.co/t/cannot-start-logstash-in-command-line/236804>\
**Category:** Logstash\
**Created:** [June 12, 2020, 1:59am UTC](https://discuss.elastic.co/t/cannot-start-logstash-in-command-line/236804 "2020-06-12T01:59:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![azteker](https://avatars.discourse-cdn.com/v4/letter/a/aca169/32.png) [@azteker](https://discuss.elastic.co/u/azteker)\
**Post date:** [June 12, 2020, 1:59am UTC](https://discuss.elastic.co/t/cannot-start-logstash-in-command-line/236804/1 "2020-06-12T01:59:09Z")

</div>

I got "Logstash could not be started because there is already another instance using the configured data directory"  
"systemctl status logstash" shows "Active: failed".  
Why I still got this message?

Here is the message

```
[root@elk centos]# /usr/share/logstash/bin/logstash -e 'input { stdin { } } output { stdout {} }'
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
[2020-06-12T01:45:22,503][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2020-06-12T01:45:22,527][FATAL][logstash.runner] Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.
[2020-06-12T01:45:22,540][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit
```

---

<div class="post-metadata">

**Author:** ![wangqinghuan](https://avatars.discourse-cdn.com/v4/letter/w/d26b3c/32.png) [@wangqinghuan](https://discuss.elastic.co/u/wangqinghuan)\
**Post date:** [June 12, 2020, 2:07am UTC](https://discuss.elastic.co/t/cannot-start-logstash-in-command-line/236804/2 "2020-06-12T02:07:06Z")

</div>

check whether Logstash is running

`ps -aux |grep Logstash`

You can kill previous Logstash process by pid .

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 10, 2020, 2:07am UTC](https://discuss.elastic.co/t/cannot-start-logstash-in-command-line/236804/3 "2020-07-10T02:07:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
