# Cannot Start Logstash

**URL:** <https://discuss.elastic.co/t/cannot-start-logstash/167697>\
**Category:** Logstash\
**Created:** [February 9, 2019, 12:53am UTC](https://discuss.elastic.co/t/cannot-start-logstash/167697 "2019-02-09T00:53:28Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [February 9, 2019, 3:03pm UTC](https://discuss.elastic.co/t/cannot-start-logstash/167697/2 "2019-02-09T15:03:45Z")

</div>

The error is not logstash specific. It is a java error.

have [a read here](https://confluence.atlassian.com/bitbucketserverkb/forking-jvm-error-12-cannot-allocate-memory-or-error-12-not-enough-space-779171744.html) it might help.

---

_[View the full topic](https://discuss.elastic.co/t/cannot-start-logstash/167697)._
