# Cannot update deprecated index setting mapping.source

**URL:** <https://discuss.elastic.co/t/cannot-update-deprecated-index-setting-mapping-source/374645>\
**Category:** Elasticsearch\
**Created:** [February 17, 2025, 3:59pm UTC](https://discuss.elastic.co/t/cannot-update-deprecated-index-setting-mapping-source/374645 "2025-02-17T15:59:58Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Matt\_Field](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matt_field/32/130951_2.png) [@Matt\_Field](https://discuss.elastic.co/u/Matt_Field)\
**Post date:** [February 17, 2025, 3:59pm UTC](https://discuss.elastic.co/t/cannot-update-deprecated-index-setting-mapping-source/374645/1 "2025-02-17T15:59:58Z")

</div>

Upon upgrading elasticsearch 8.17 a number of my indices have gone red.  
This is because they have the setting

```auto
index.mapping.source.mode: "STORED"

```

I have seen that this setting is now a premium feature as described here [Elastic 8.17 and \_source](https://discuss.elastic.co/t/elastic-8-17-and-source/372181)

However i am unable to modify (or remove) this setting. (on either open or closed indices)

Is there any solution to this?

---

<div class="post-metadata">

**Author:** ![RainTown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raintown/32/140206_2.png) [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Post date:** [February 17, 2025, 4:54pm UTC](https://discuss.elastic.co/t/cannot-update-deprecated-index-setting-mapping-source/374645/2 "2025-02-17T16:54:28Z")

</div>

synthetic source is the new premium feature for 8.17+, there's another thread ongoing about it's impact on storage requirements.

You have written "gone red ... because they have this settling".

Can you elaborate why you believe that is the case? red can be caused by lots of things. Can you share output of

```auto
GET _cluster/health

```

---

<div class="post-metadata">

**Author:** ![Matt\_Field](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matt_field/32/130951_2.png) [@Matt\_Field](https://discuss.elastic.co/u/Matt_Field)\
**Post date:** [February 17, 2025, 6:19pm UTC](https://discuss.elastic.co/t/cannot-update-deprecated-index-setting-mapping-source/374645/3 "2025-02-17T18:19:28Z")

</div>

I reported the issue because of the output of

GET \_cluster/allocation/explain

```auto
{
  "index": "xxxxx",
  "shard": 0,
  "primary": true,
  "current_state": "unassigned",
  "unassigned_info": {
    "reason": "ALLOCATION_FAILED",
    "at": "2025-02-17T11:13:49.958Z",
    "failed_allocation_attempts": 5,
    "details": """failed shard on node [dxvvKFmNSGWdpkPA6UKKTg]: failed to create index, failure java.lang.IllegalArgumentException: unknown setting [index.mapping.source.mode] did you mean [index.mapping.coerce]?
	at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:563)
	at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:509)
	at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:479)
	at org.elasticsearch.indices.IndicesService.createIndexService(IndicesService.java:732)
	at org.elasticsearch.indices.IndicesService.createIndex(IndicesService.java:649)
	at org.elasticsearch.indices.IndicesService.createIndex(IndicesService.java:187)
	at org.elasticsearch.indices.cluster.IndicesClusterStateService.createIndicesAndUpdateShards(IndicesClusterStateService.java:581)

```

However the issue has now been resolved. It turns out that the cluster upgrade had not been completed, so the issue had been caused by having a mixture of 8.17 and 8.16 nodes. As soon as all the nodes had upgraded, the problem resolved itself, and the cluster is green again. Thanks anyway for your response.

---

<div class="post-metadata">

**Author:** ![RainTown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raintown/32/140206_2.png) [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Post date:** [February 17, 2025, 6:54pm UTC](https://discuss.elastic.co/t/cannot-update-deprecated-index-setting-mapping-source/374645/4 "2025-02-17T18:54:49Z")

</div>

> [@Matt\_Field](#):
>
> `index.mapping.source.mode`

Yes, indeed, as expected the issue was not the setting itself, it was the cluster upgrade was not correctly completed - the node trying to read the config likely had the old version and therefore was unable to allocate the shard.

By the way, if this was not a process error on your part (no idea if it was) then it would IMHO be a bug, There will be periods where nodes are on different versions, this is as expected. But a problem should not occur if you followed the upgrade process correctly.

> **[Upgrade Elasticsearch | Elastic Installation and Upgrade Guide \[8.17\] | Elastic](https://www.elastic.co/guide/en/elastic-stack/8.17/upgrading-elasticsearch.html)**
