# Can't Configure or Enable Security Features in Elasticsearch 8.4

**URL:** <https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [January 25, 2023, 9:44pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971 "2023-01-25T21:44:17Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Joao\_Malebo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joao_malebo/32/111764_2.png) [@Joao\_Malebo](https://discuss.elastic.co/u/Joao_Malebo)\
**Post date:** [January 25, 2023, 9:44pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/1 "2023-01-25T21:44:17Z")

</div>

Hello dears,

I'm having trouble

I'm following the tutorial below, and when I finish the configuration, when starting Kibana I get an error:

**Toturial** : https://www.elastic.co/guide/en/elasticsearch/reference/current/security-minimal-setup.html#\_enable\_elasticsearch\_security\_features

**Return Error:**

_Jan 25 19:44:32 kibana[147305]: [2023-01-25T19:44:32.546+01:00][WARN][plugins.screenshotting.config] Chromium sandbox provides an additional layer of protection, but is not supported for Linux Red Hat Linux 8.6 OS. Automatically setting 'xpack.screenshotting.browser.chromium.disableSandbox: true'._

---

<div class="post-metadata">

**Author:** ![Ayush\_Mathur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_mathur/32/77134_2.png) [@Ayush\_Mathur](https://discuss.elastic.co/u/Ayush_Mathur)\
**Post date:** [January 26, 2023, 12:19pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/2 "2023-01-26T12:19:36Z")

</div>

Hello @Joao_Malebo , the log snippet you've shared is just a warning not an error (note the tag after timestamp). If you want to avoid this warning, just explicitly set the mentioned property in kibana configuration: `xpack.screenshotting.browser.chromium.disableSandbox: true`.

For more details on reporting configuration, please refer to: [Reporting settings in Kibana | Kibana Guide [8.6] | Elastic](https://www.elastic.co/guide/en/kibana/current/reporting-settings-kb.html#reporting-chromium-settings)

---

<div class="post-metadata">

**Author:** ![Joao\_Malebo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joao_malebo/32/111764_2.png) [@Joao\_Malebo](https://discuss.elastic.co/u/Joao_Malebo)\
**Post date:** [January 30, 2023, 4:11pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/3 "2023-01-30T16:11:12Z")

</div>

I made this change, but Kibana still won't start. I am the error below on browser:

Kibana server is not ready yet

---

<div class="post-metadata">

**Author:** ![Joao\_Malebo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joao_malebo/32/111764_2.png) [@Joao\_Malebo](https://discuss.elastic.co/u/Joao_Malebo)\
**Post date:** [January 30, 2023, 4:16pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/4 "2023-01-30T16:16:03Z")

</div>

Error logs:

_**Jan 30 17:13:45 server kibana[1341485]: [2023-01-30T17:13:45.327+01:00]**_  
_**[ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 10.32.2.227:54684, Remote: 10.32.2.227:9200**_

---

<div class="post-metadata">

**Author:** ![Ayush\_Mathur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_mathur/32/77134_2.png) [@Ayush\_Mathur](https://discuss.elastic.co/u/Ayush_Mathur)\
**Post date:** [January 31, 2023, 7:17am UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/5 "2023-01-31T07:17:22Z")

</div>

Hello @Joao_Malebo , are there any other error logs in Kibana or Elasticsearch ?

---

<div class="post-metadata">

**Author:** ![Joao\_Malebo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joao_malebo/32/111764_2.png) [@Joao\_Malebo](https://discuss.elastic.co/u/Joao_Malebo)\
**Post date:** [February 1, 2023, 4:15pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/6 "2023-02-01T16:15:59Z")

</div>

No, just the one I see in the Kibana logs... By the way, only Kibana is returning an error

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 1, 2023, 4:16pm UTC](https://discuss.elastic.co/t/cant-configure-or-enable-security-features-in-elasticsearch-8-4/323971/7 "2023-03-01T16:16:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
