# Can't connect to Elasticsearch from logstash version8.2

**URL:** <https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785>\
**Category:** Logstash\
**Created:** [May 27, 2022, 9:23am UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785 "2022-05-27T09:23:16Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![oga](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@oga](https://discuss.elastic.co/u/oga)\
**Post date:** [May 27, 2022, 9:23am UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/1 "2022-05-27T09:23:16Z")

</div>

I want to use Elasticsearch and Logstash(ver 8.2).  
After installed Elasticsearch and Kibana, I installed logstash.  
But I got error.It seems logstash can't connect to Elasticsearch.  
But Elasticsearch is runnning correctly.  
（This configuration run correctly when used version 7）

Someone please teach me this reason?  
Error message and configration is below.

----ERROR when start logstash-------  
[INFO][logstash.outputs.Elasticsearch][main] Failed to perform request {:message=\>"127.0.0.1:9200 failed to respond", :exception=\>Manticore::ClientProtocolException, :cause=\>org.apache.http.NoHttpResponseException: 127.0.0.1:9200 failed to respond}  
[WARN][logstash.outputs.Elasticsearch][main] Attempted to resurrect connection to dead ES instance, but got an error {:url=\>"[http://elastic:xxxxxx@127.0.0.1:9200/](http://elastic:xxxxxx@127.0.0.1:9200/)", :exception=\>LogStash::Outputs::Elasticsearch::HttpClient::Pool::HostUnreachableError, :message=\>"Elasticsearch Unreachable: [[http://127.0.0.1:9200/](http://127.0.0.1:9200/)][Manticore::ClientProtocolException] 127.0.0.1:9200 failed to respond"}

----logstash config(only output)----

```auto
output {
  elasticsearch {
    hosts => ["http://127.0.0.1:9200"]
    index => "indexname"
    user => "elastic"
    password => "password"
  }
  stdout{
    codec => rubydebug
  }
}

```

* * *

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [May 27, 2022, 3:12pm UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/2 "2022-05-27T15:12:55Z")

</div>

> [@oga](#):
>
> Elasticsearch Unreachable: [[http://127.0.0.1:9200/](http://127.0.0.1:9200/)][Manticore::ClientProtocolException] 127.0.0.1:9200 failed to respond"

1. Firewall and port
2. Elasic interface in elasticsearch.yml  
Set `network.host: 0.0.0.0` and restart ES

---

<div class="post-metadata">

**Author:** ![oga](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@oga](https://discuss.elastic.co/u/oga)\
**Post date:** [May 28, 2022, 12:28am UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/3 "2022-05-28T00:28:11Z")

</div>

Thanks for your response!  
I tried but still can't connect to Elasticsearch form logstash.

1)Firewall and port  
--\> I set firewall , TCP 9200

2)Elastic interface in Elasticsearch.tml  
--\> I already set "network.host:0.0.0.0" in Elasticsearch.yml as below.

```auto
--------network part in elasticsearch.yml-------
network.host: 0.0.0.0
http.port: 9200
-----------------------------------------------------

```

Are there others reason?  
Can anyone help me?

---

<div class="post-metadata">

**Author:** ![Tomo\_M](https://avatars.discourse-cdn.com/v4/letter/t/848f3c/32.png) [@Tomo\_M](https://discuss.elastic.co/u/Tomo_M)\
**Post date:** [May 28, 2022, 11:46am UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/4 "2022-05-28T11:46:39Z")

</div>

What will happen when you access "[http://127.0.0.1:9200](http://127.0.0.1:9200)" using browser or curl command?

---

<div class="post-metadata">

**Author:** ![oga](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@oga](https://discuss.elastic.co/u/oga)\
**Post date:** [May 28, 2022, 5:47pm UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/5 "2022-05-28T17:47:58Z")

</div>

Thanks for your reply!

With Browser, access "[https://127.0.0.1:9200](https://127.0.0.1:9200)", I got below  
(of course I entered ID and Pass)

```auto
{
  "name" : "XXXXXX",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "XXXXXX",
  "version" : {
    "number" : "8.2.2",
    "build_flavor" : "default",
    "build_type" : "zip",
    "build_hash" : "XXXXXX",
    "build_date" : "2022-05-25T15:47:06.259735307Z",
    "build_snapshot" : false,
    "lucene_version" : "9.1.0",
    "minimum_wire_compatibility_version" : "7.17.0",
    "minimum_index_compatibility_version" : "7.0.0"
  },
  "tagline" : "You Know, for Search"
}

```

But, access "[http://127.0.0.1:9200](http://127.0.0.1:9200)", I could not get response.

Is this means that I need setting of SSL in logstash configuration?  
I saw manuarl below, but there was no comment.

> **[Configuring Logstash | Logstash Reference \[8.2\] | Elastic](https://www.elastic.co/guide/en/logstash/8.2/configuration.html)**

If this is the reason, would you tell me the configuration I have to add?

※Below in in japanese with same meaning  
https では出力が上記の通り出ましたが、httpではレスポンスがありませんでした。  
LogstashのConfigに、SSLの設定を追加する必要があるということでしょうか。  
Logstashのマニュアルで私が見たLogstashのマニュアルには8.2に伴いSSL設定を追加するような記載がなかったので気にしていませんでした。  
もしそのとおりだとしましたら、どのような記述を追加すればよいか教えていただけると大変ありがたいです。

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [May 28, 2022, 7:42pm UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/6 "2022-05-28T19:42:51Z")

</div>

Change two params:

> output {  
> elasticsearch {  
> hosts =\> ["http **s** ://127.0.0.1:9200"]  
> index =\> "indexname"  
> user =\> "elastic"  
> password =\> "password"  
> **ssl\_certificate\_verification =\> false**  
> }  
> stdout{  
> codec =\> rubydebug  
> }  
> }

---

<div class="post-metadata">

**Author:** ![oga](https://avatars.discourse-cdn.com/v4/letter/o/f19dbf/32.png) [@oga](https://discuss.elastic.co/u/oga)\
**Post date:** [May 28, 2022, 11:49pm UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/7 "2022-05-28T23:49:21Z")

</div>

Thank you for your reply!

It's exactly as you said.  
I changed logstash configuration, and logstash worked correctly!  
Thank you for your good advice!!

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [May 29, 2022, 5:08am UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/8 "2022-05-29T05:08:51Z")

</div>

This is minimum to establish SSL, however not sure will CISO accept that. Latter you can generate certificates and improve security -\> [link](https://www.elastic.co/blog/how-to-setup-tls-for-elasticsearch-kibana-logstash-filebeat-with-offline-install-in-linux)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 26, 2022, 5:09am UTC](https://discuss.elastic.co/t/cant-connect-to-elasticsearch-from-logstash-version8-2/305785/9 "2022-06-26T05:09:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
