# Cant create index-patterns in other Workspaces

**URL:** https://discuss.elastic.co/t/cant-create-index-patterns-in-other-workspaces/207604
**Category:** Kibana
**Created:** [November 13, 2019, 1:00am UTC](https://discuss.elastic.co/t/cant-create-index-patterns-in-other-workspaces/207604 "2019-11-13T01:00:45Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![CamTheMan](https://avatars.discourse-cdn.com/v4/letter/c/3ec8ea/32.png) [@CamTheMan](https://discuss.elastic.co/u/CamTheMan)
#### Post date: [November 13, 2019, 1:00am UTC](https://discuss.elastic.co/t/cant-create-index-patterns-in-other-workspaces/207604/1 "2019-11-13T01:00:46Z")

</div>

Hello, We recently upgraded Elastic and Kibana from version 6.4.2 to 6.8.3.  
Migration went fine, dashboards and searches moved across to the 'default' workspace, however when settings up NEW workspaces for other teams etc, there are no index-patterns, and when I try 'create index pattern' it returns an error saying "Couldn't find any Elasticsearch data"

 ![firefox_fgynBXfaqH](https://us1.discourse-cdn.com/elastic/original/3X/b/f/bf2097697d941a7d0b03ff5cc9800f06395d0731.png)

I definately have data in my indexes as I can see it and explore from the "Default" workspace.

Where would I start troubleshooting this error?

Incase you dont believe I have data here is a snippet from /\_cat/indices

> ```
> green open packetbeat-6.8.3-2019-10 0i_P4EBfSjWMkUzILNNBkw 3 1 50560926 0 21.7gb 10.8gb
> green open auditbeat-6.8.0-2018-07 GelRfmRgRBu8r5CiggLN3w 3 1 28 0 177.7kb 89kb
> green open syslog-2019-04 licyot9pRlKGCdaCsci-kw 5 1 311141179 0 115.4gb 57.7gb
> green open logstash-2019-05 kBefRVn_RyWs7qtYFoYbfw 5 1 219179680 0 135.3gb 67.6gb
> 
> ```

UPDATE: I cant add index-patterns even in the default workspace. I deleted an index-pattern as a test and can't re-add it due to the above error.

---

<div class="post-metadata">

### Author: ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)
#### Post date: [November 13, 2019, 3:00pm UTC](https://discuss.elastic.co/t/cant-create-index-patterns-in-other-workspaces/207604/2 "2019-11-13T15:00:38Z")

</div>

Hi @CamTheMan,

Can you enable verbose logging in Kibana and check if you see any suspicious error messages? Also do you see any errors in browser console?

Best,  
Oleg

---

<div class="post-metadata">

### Author: ![CamTheMan](https://avatars.discourse-cdn.com/v4/letter/c/3ec8ea/32.png) [@CamTheMan](https://discuss.elastic.co/u/CamTheMan)
#### Post date: [November 17, 2019, 11:30pm UTC](https://discuss.elastic.co/t/cant-create-index-patterns-in-other-workspaces/207604/3 "2019-11-17T23:30:52Z")

</div>

Hi Everyone,  
Just to post an update, what fixed it was one of two things.  
A full cluster restart of the elastic nodes - But the reason for the cluster restart was to address a Rancher v.1.6 / Docker / Java bug where Java only detects the CPU count as 1 instead of 16!

After checking 'GET /\_nodes/os' we saw: "allocated\_processors" : 1 instead of 16.

Aftering editing elasticsearch.yml and adding 'processors: 16' and performing a cluster restart I could re-add the Kibana index-patterns.

What I suspect is that the index-pattern 'search' was just timing out although nothing was being logged about that aspect.  
Thats all I can suspect.

Hopefully this helps someone.

Thanks again for the other replies.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 15, 2019, 11:30pm UTC](https://discuss.elastic.co/t/cant-create-index-patterns-in-other-workspaces/207604/4 "2019-12-15T23:30:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
