# Can't load Filebeat on Windows Server, Fails to create client

**URL:** <https://discuss.elastic.co/t/cant-load-filebeat-on-windows-server-fails-to-create-client/160420>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [December 11, 2018, 5:41pm UTC](https://discuss.elastic.co/t/cant-load-filebeat-on-windows-server-fails-to-create-client/160420 "2018-12-11T17:41:51Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ghoti](https://avatars.discourse-cdn.com/v4/letter/g/94ad74/32.png) [@Ghoti](https://discuss.elastic.co/u/Ghoti)\
**Post date:** [December 11, 2018, 5:41pm UTC](https://discuss.elastic.co/t/cant-load-filebeat-on-windows-server-fails-to-create-client/160420/1 "2018-12-11T17:41:51Z")

</div>

PS C:\Program Files\filebeat-6.5.2-windows-x86\_64\> .\filebeat.exe setup -e  
2018-12-11T12:35:07.693-0500 INFO instance/beat.go:592 Home path: [C:\Program Files\filebeat-6.5.2-windows-x86\_  
64] Config path: [C:\Program Files\filebeat-6.5.2-windows-x86\_64] Data path: [C:\Program Files\filebeat-6.5.2-windows-x8  
6\_64\data] Logs path: [C:\Program Files\filebeat-6.5.2-windows-x86\_64\logs]  
2018-12-11T12:35:07.700-0500 INFO instance/beat.go:599 Beat UUID: 15826552-e357-4e24-917f-465a2ed27083  
2018-12-11T12:35:07.701-0500 INFO [beat] instance/beat.go:825 Beat info {"system\_info": {"beat": {"path"  
: {"config": "C:\Program Files\filebeat-6.5.2-windows-x86\_64", "data": "C:\Program Files\filebeat-6.5.2-windows-x86\_  
64\data", "home": "C:\Program Files\filebeat-6.5.2-windows-x86\_64", "logs": "C:\Program Files\filebeat-6.5.2-window  
s-x86\_64\logs"}, "type": "filebeat", "uuid": "15826552-e357-4e24-917f-465a2ed27083"}}}  
2018-12-11T12:35:07.706-0500 INFO [beat] instance/beat.go:834 Build info {"system\_info": {"build": {"comm  
it": "b48d073b84e874a182c122d8ef2bad867f714a11", "libbeat": "6.5.2", "time": "2018-11-29T23:03:04.000Z", "version": "6.5  
.2"}}}  
2018-12-11T12:35:07.708-0500 INFO [beat] instance/beat.go:837 Go runtime info {"system\_info": {"go": {"os":"wi  
ndows","arch":"amd64","max\_procs":16,"version":"go1.10.3"}}}  
2018-12-11T12:35:07.750-0500 INFO [beat] instance/beat.go:841 Host info {"system\_info": {"host": {"archi  
tecture":"x86\_64","boot\_time":"2018-11-21T21:21:22.3-05:00","name":"DEV03","ip":["fe80::1c71:10c6:2623:9430/64","10.1.10  
.20/24","::1/128","127.0.0.1/8","fe80::5efe:a01:a14/128"],"kernel\_version":"6.3.9600.19179 (winblue\_ltsb\_escrow.181015-1  
847)","mac":["00:25:90:72:e3:de","00:00:00:00:00:00:00:e0"],"os":{"family":"windows","platform":"windows","name":"Window  
s Server 2012 R2 Datacenter","version":"6.3","major":3,"minor":0,"patch":0,"build":"9600.19182"},"timezone":"EST","timez  
one\_offset\_sec":-18000,"id":"74d8a794-970f-435d-a84f-8259108dde0b"}}}  
2018-12-11T12:35:07.763-0500 INFO [beat] instance/beat.go:870 Process info {"system\_info": {"process": {"cw  
d": "C:\Program Files\filebeat-6.5.2-windows-x86\_64", "exe": "C:\Program Files\filebeat-6.5.2-windows-x86\_64\filebe  
at.exe", "name": "filebeat.exe", "pid": 44136, "ppid": 27652, "start\_time": "2018-12-11T12:35:07.467-0500"}}}  
2018-12-11T12:35:07.765-0500 INFO instance/beat.go:278 Setup Beat: filebeat; Version: 6.5.2  
2018-12-11T12:35:10.787-0500 INFO add\_cloud\_metadata/add\_cloud\_metadata.go:319 add\_cloud\_metadata: hosting prov  
ider type not detected.  
2018-12-11T12:35:10.790-0500 INFO elasticsearch/client.go:163 Elasticsearch url: [http://10.10.10.164:9200](http://10.10.10.164:9200)  
2018-12-11T12:35:10.791-0500 INFO [publisher] pipeline/module.go:110 Beat name: DEV03  
2018-12-11T12:35:10.794-0500 INFO elasticsearch/client.go:163 Elasticsearch url: [http://10.10.10.164:9200](http://10.10.10.164:9200)  
2018-12-11T12:35:10.815-0500 INFO elasticsearch/client.go:712 Connected to Elasticsearch version 5.6.13  
2018-12-11T12:35:10.838-0500 INFO template/load.go:129 Template already exists and will not be overwritten.  
Loaded index template  
Loading dashboards (Kibana must be running and reachable)  
2018-12-11T12:35:10.841-0500 INFO elasticsearch/client.go:163 Elasticsearch url: [http://10.10.10.164:9200](http://10.10.10.164:9200)  
2018-12-11T12:35:10.862-0500 INFO elasticsearch/client.go:712 Connected to Elasticsearch version 5.6.13  
2018-12-11T12:35:13.374-0500 INFO instance/beat.go:717 Kibana dashboards successfully loaded.  
Loaded dashboards  
2018-12-11T12:35:13.376-0500 INFO elasticsearch/client.go:163 Elasticsearch url: [http://10.10.10.164:9200](http://10.10.10.164:9200)  
2018-12-11T12:35:13.398-0500 INFO elasticsearch/client.go:712 Connected to Elasticsearch version 5.6.13  
2018-12-11T12:35:13.399-0500 INFO kibana/client.go:118 Kibana url: [http://10.10.10.164:5601](http://10.10.10.164:5601)  
2018-12-11T12:35:13.421-0500 ERROR instance/beat.go:800 Exiting: Error creating Kibana client: fail to get the Kibana version: HTTP GET request to /api/status fails: parsing kibana response: invalid character 'K' looking for beginning of value. Response: Kibana server is not ready yet.  
Exiting: Error creating Kibana client: fail to get the Kibana version: HTTP GET request to /api/status fails: parsing kibana response: invalid character 'K' looking for beginning of value. Response: Kibana server is not ready yet.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 8, 2019, 5:56pm UTC](https://discuss.elastic.co/t/cant-load-filebeat-on-windows-server-fails-to-create-client/160420/2 "2019-01-08T17:56:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
