# Can't load kibana on 5601

**URL:** <https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886>\
**Category:** Kibana\
**Created:** [February 16, 2016, 12:55pm UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886 "2016-02-16T12:55:30Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![babeesh](https://avatars.discourse-cdn.com/v4/letter/b/e47c2d/32.png) [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Post date:** [February 16, 2016, 12:55pm UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/1 "2016-02-16T12:55:30Z")

</div>

I have installed Elasticsearch, Logstash, Kibana and Nginx following this guide,

> **[How To Install Elasticsearch, Logstash, and Kibana (ELK Stack) on Ubuntu 14.04 |...](https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-ubuntu-14-04)**
>
> In this tutorial, we will go over the installation of the Elasticsearch ELK Stack on Ubuntu 14.04—that is, Elasticsearch 2.2.x, Logstash 2.2.x, and Kibana 4.4.x. We will also show you how to configure it to gather and visualize the syslogs of your...

Elasticsearch is running on 9200  
`curl http://localhost:9200` gives the correct configuration.

But ` curl http://localhost:5601 `gives

curl: (7) Failed to connect to localhost port 5601: Connection refused

In kibana.yml file I put

**server.port: 5601**  
**server.host: "127.0.0.1"** Here I also checked with localhost and aws private ip address.

And while checking the port I am getting

`netstat -anp | grep 5601`

**(No info could be read for "-p": geteuid()=1000 but you should be root.)**

I can start kibana using `sudo service kibana start`

But while checking status using `sudo service kibana status`

**kibana is not running**

I haven't setup firewall . `sudo ufw status`

Status : Inactive

I am confused, why kibana port is not listening. Please help me to solve this.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 16, 2016, 8:51pm UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/2 "2016-02-16T20:51:42Z")

</div>

What version of KB did you install?

---

<div class="post-metadata">

**Author:** ![babeesh](https://avatars.discourse-cdn.com/v4/letter/b/e47c2d/32.png) [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Post date:** [February 17, 2016, 3:43am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/3 "2016-02-17T03:43:06Z")

</div>

Ubuntu 14.04  
Elasticsearch 2.2.x, Logstash 2.2.x, and Kibana 4.4.x

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [February 17, 2016, 4:47am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/4 "2016-02-17T04:47:26Z")

</div>

Based on the article it looks like it assumes Nginx is used as a proxy in front of Kibana, listening to port 80. Can you connect to port 80?

---

<div class="post-metadata">

**Author:** ![babeesh](https://avatars.discourse-cdn.com/v4/letter/b/e47c2d/32.png) [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Post date:** [February 17, 2016, 5:18am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/5 "2016-02-17T05:18:31Z")

</div>

Yes I can connect to Port 80.

---

<div class="post-metadata">

**Author:** ![teewhey](https://avatars.discourse-cdn.com/v4/letter/t/8797f3/32.png) [@teewhey](https://discuss.elastic.co/u/teewhey)\
**Post date:** [February 17, 2016, 7:30am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/6 "2016-02-17T07:30:56Z")

</div>

Do you mind to post the result of :

1. ps -ef | grep kibana
2. Content of your kibana.yml

---

<div class="post-metadata">

**Author:** ![babeesh](https://avatars.discourse-cdn.com/v4/letter/b/e47c2d/32.png) [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Post date:** [February 17, 2016, 7:43am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/7 "2016-02-17T07:43:25Z")

</div>

**1. ubuntu 2686 1415 0 07:40 pts/1 00:00:00 grep --color=auto kibana**

**2. server.host: "172.30.0.28:5601"**

---

<div class="post-metadata">

**Author:** ![babeesh](https://avatars.discourse-cdn.com/v4/letter/b/e47c2d/32.png) [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Post date:** [February 18, 2016, 6:38am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/8 "2016-02-18T06:38:37Z")

</div>

Its running now.  
When I checked kibana log (`vi /var/log/kibana/kibana.stderr`)

Error: EACCES, permission denied '/opt/kibana/optimize/.babelcache.json'

So I changed permission of .babelcache.json  
`sudo chown -R kibana:root /opt/kibana/optimize/.babelcache.json`

Then restarted kibana , Solved the issue.

---

<div class="post-metadata">

**Author:** ![Richard\_Vencu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/richard_vencu/32/10938_2.png) [@Richard\_Vencu](https://discuss.elastic.co/u/Richard_Vencu)\
**Post date:** [July 18, 2016, 11:24am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/9 "2016-07-18T11:24:07Z")

</div>

Hi, I am in the same situation. Kibana worked for me, then after some time while playing with indexes it started to behave strangely, finally after a reboot it refuses connection to port 5601

I tried to uninstall, deleted all /opt/kibana files, reinstalled latest version, nothing is working

I even cannot access any log, I created a log file for kibana and set it into kibana.yml but it is always zero sized.

The service starts after an initial failure but connection to the port is denied.

---

<div class="post-metadata">

**Author:** ![DEngelhardt](https://avatars.discourse-cdn.com/v4/letter/d/48db29/32.png) [@DEngelhardt](https://discuss.elastic.co/u/DEngelhardt)\
**Post date:** [November 23, 2016, 12:47am UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/10 "2016-11-23T00:47:18Z")

</div>

I searched for an answer for 7 hours. I found that that in the kibana.yml file, if you change port: 5601 to server.port: 5601, I can connect to the server and port with curl. I have another error message and Kibana is not showing me Elasticsearch yet, but that is progress. And then after rebooting it would not start. However, changing it back to port: 5601 and restarting Kibana caused it to work again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:34pm UTC](https://discuss.elastic.co/t/cant-load-kibana-on-5601/41886/11 "2017-07-06T13:34:04Z")

</div>


