# Can't Load/Save Dashboard nor find Data

**URL:** <https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357>\
**Category:** Kibana\
**Created:** [April 5, 2016, 9:00am UTC](https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357 "2016-04-05T09:00:21Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![NicoYUE](https://avatars.discourse-cdn.com/v4/letter/n/96bed5/32.png) [@NicoYUE](https://discuss.elastic.co/u/NicoYUE)\
**Post date:** [April 5, 2016, 9:00am UTC](https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357/1 "2016-04-05T09:00:21Z")

</div>

Hello,

I'm having some problem setting up Kibana, seems like it can't reach Elasticsearch.

I'm using ELS 2.3 with a modified Kibana 3.1.3 which was made to work with ELS 2.

After a while with this set up, Kibana stopped working, or more like it seemed like it couldn't reach ELS anymore, can't load or save a Dashboard, it tells me:

Failed to save to Elasticsearch

I can only try to access to the default Logstash dashboard.  
By opening Firefox's developing tool, Network says I'm connected to my ELS server and there are no errors in all the queries (\_search, \_search count etc...)

Anyway, no data are fetched, no visualisation at all though I can see the mapping of my indices in Field at the bottom.

To me, it's a problem of Kibana unable to reach ELS, but it used to work so I'm confused. Maybe some NGINX problem ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 5, 2016, 10:08am UTC](https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357/2 "2016-04-05T10:08:29Z")

</div>

You will probably need to ask the author of the modified Kibana you are running, I am not sure anyone here can help given it doesn't officially work with ES 2.0 ☹

---

<div class="post-metadata">

**Author:** ![NicoYUE](https://avatars.discourse-cdn.com/v4/letter/n/96bed5/32.png) [@NicoYUE](https://discuss.elastic.co/u/NicoYUE)\
**Post date:** [April 5, 2016, 3:00pm UTC](https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357/3 "2016-04-05T15:00:22Z")

</div>

I updated to another version of Kibana and I get

Connection Failed

I think it's the same error, but this time I have a webpage to tell me this...

Cors already set on all my ELS servers and no Memory usage problem either.

Don't know what to do at this point. My mind is telling me it's NGINX but the .conf looks correct too.

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [April 5, 2016, 6:39pm UTC](https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357/4 "2016-04-05T18:39:33Z")

</div>

Not sure but it could be this issue? [https://github.com/elastic/kibana/issues/6719](https://github.com/elastic/kibana/issues/6719)

Go down to the comments like;

```
I use cors access so I needed to keep http.cors.enabled
can confirm that adding http.cors.allow-origin resolved this error

```

and

`Removing "http.cors.enabled" from elasticsearch.yml resolved the error.`

Regards,  
Lee

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:56pm UTC](https://discuss.elastic.co/t/cant-load-save-dashboard-nor-find-data/46357/5 "2017-07-06T13:56:54Z")

</div>


