# Can't login after install x-pack

**URL:** https://discuss.elastic.co/t/cant-login-after-install-x-pack/121394
**Category:** Kibana
**Created:** [February 25, 2018, 4:05pm UTC](https://discuss.elastic.co/t/cant-login-after-install-x-pack/121394 "2018-02-25T16:05:02Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![1\_Maximys\_1](https://avatars.discourse-cdn.com/v4/letter/1/b782af/32.png) [@1\_Maximys\_1](https://discuss.elastic.co/u/1_Maximys_1)
#### Post date: [February 25, 2018, 4:05pm UTC](https://discuss.elastic.co/t/cant-login-after-install-x-pack/121394/1 "2018-02-25T16:05:02Z")

</div>

Hi.  
I've installed Elasticsearch and Kibana.  
Every thing was fine.  
But I want install X-Pack with license.  
When I did it, I saw message during login to Kibana:  
Login is currently disabled because the license could not be determined. Please check that Elasticsearch has the X-Pack plugin installed and is reachable, then refresh this page.

What should I do, to login to Kibana?

Thanks in advance.

P.S. I 've opened logs from elasticsearch and I see this:

[2018-02-24T17:44:57,069][WARN][o.e.x.s.a.AuthenticationService] [Jh10OEm] An error occurred while attempting to authenticate [kibana] against realm [reserved] - ElasticsearchSecurityException[failed to authenticate user [kibana]]  
[2018-02-24T17:44:57,260][INFO][o.e.n.Node] [Jh10OEm] stopping ...  
[2018-02-24T17:44:57,286][INFO][o.e.x.w.w.WatchStore] [Jh10OEm] stopped watch store  
[2018-02-24T17:44:57,287][INFO][o.e.x.m.j.p.l.CppLogMessageHandler] [controller/51] [Main.cc@168] Ml controller exiting  
[2018-02-24T17:44:57,342][WARN][o.e.x.s.a.AuthenticationService] [Jh10OEm] An error occurred while attempting to authenticate [kibana] against realm [reserved] - ElasticsearchSecurityException[failed to authenticate user [kibana]]  
[2018-02-24T17:44:57,343][ERROR][i.n.u.c.D.rejectedExecution] Failed to submit a listener notification task. Event loop shut down?

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [February 27, 2018, 6:50pm UTC](https://discuss.elastic.co/t/cant-login-after-install-x-pack/121394/2 "2018-02-27T18:50:20Z")

</div>

If you have a Gold or Platinum license, I would highly encourage you to contact support as they will ensure a timely response from an engineer.

You will need to update the `elasticsearch.password` in the `kibana.yml` to reflect the `kibana` user.

Here is the documenation for this process: [https://www.elastic.co/guide/en/x-pack/current/setting-up-authentication.html](https://www.elastic.co/guide/en/x-pack/current/setting-up-authentication.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 27, 2018, 6:50pm UTC](https://discuss.elastic.co/t/cant-login-after-install-x-pack/121394/3 "2018-03-27T18:50:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
