# Can't login in Kibana with any of the built-in users

**URL:** https://discuss.elastic.co/t/cant-login-in-kibana-with-any-of-the-built-in-users/295248
**Category:** Kibana
**Created:** [January 24, 2022, 3:46pm UTC](https://discuss.elastic.co/t/cant-login-in-kibana-with-any-of-the-built-in-users/295248 "2022-01-24T15:46:17Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)
#### Post date: [January 24, 2022, 3:46pm UTC](https://discuss.elastic.co/t/cant-login-in-kibana-with-any-of-the-built-in-users/295248/1 "2022-01-24T15:46:17Z")

</div>

Hi folks,

I've just recently updated from 6.8.22 to 7.14.2.  
I configured the username and password of Kibana in the kibana keystore.  
My Elasticsearch cluster is up and running I can send requests via curl.  
I try to authenticate with the built-in user elastic.

The error I get is: "Oops! Error. Try again."

`curl -XGET 'https://localhost:port/_xpack/security/_authenticate?pretty'`

```auto
{ "username" : "elastic",
  "roles" : [
    "superuser" ],
  "full_name" : null,
  "email" : null,
  "metadata" : {
    "_reserved" : true },
  "enabled" : true,
  "authentication_realm" : {
    "name" : "reserved",
    "type" : "reserved" },
  "lookup_realm" : {
    "name" : "reserved",
    "type" : "reserved" },
  "authentication_type" : "realm"}

```

---

<div class="post-metadata">

### Author: ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)
#### Post date: [January 25, 2022, 6:27pm UTC](https://discuss.elastic.co/t/cant-login-in-kibana-with-any-of-the-built-in-users/295248/2 "2022-01-25T18:27:47Z")

</div>

Do you see any error messages in the Elasticsearch logs when you attempt a failed login?

> [@Penchev](#):
>
> 7.14.2

Something funny is going on. In 7.14.2, the error message for failed login is not "Oops! Error. Try again"

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/f/cfa1495274690e9c99f113a81b03ab3eeb076aa1.png)

I suspect the login screen is being served from a Kibana 6.8 instance. The "Oops" message appears in the 6.8 branch but not the 7.14 branch:  
`https://github.com/elastic/kibana/blob/6.8/x-pack/plugins/security/public/views/login/components/basic_login_form/basic_login_form.tsx#L207`

---

<div class="post-metadata">

### Author: ![Penchev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/penchev/32/100328_2.png) [@Penchev](https://discuss.elastic.co/u/Penchev)
#### Post date: [January 26, 2022, 7:07am UTC](https://discuss.elastic.co/t/cant-login-in-kibana-with-any-of-the-built-in-users/295248/3 "2022-01-26T07:07:50Z")

</div>

Actually this was the exact error message of my 7.14.2 instance - "Oops! Error. Try again".  
Problem solved, I was missing the native realm configuration in the Elasticsearch.yml.  
Here is a link to the related documentation:

`https://www.elastic.co/guide/en/elasticsearch/reference/current/native-realm.htmlhttps://www.elastic.co/guide/en/elasticsearch/reference/current/native-realm.html`

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 23, 2022, 7:08am UTC](https://discuss.elastic.co/t/cant-login-in-kibana-with-any-of-the-built-in-users/295248/4 "2022-02-23T07:08:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
