# Cant see my services inside APM with elastic user login

**URL:** <https://discuss.elastic.co/t/cant-see-my-services-inside-apm-with-elastic-user-login/365112>\
**Category:** Kibana\
**Tags:** elastic-stack-security, elastic-stack-alerting, ilm-index-lifecycle-management\
**Created:** [August 19, 2024, 7:37am UTC](https://discuss.elastic.co/t/cant-see-my-services-inside-apm-with-elastic-user-login/365112 "2024-08-19T07:37:11Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amol\_Nagotkar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amol_nagotkar/32/124188_2.png) [@Amol\_Nagotkar](https://discuss.elastic.co/u/Amol_Nagotkar)\
**Post date:** [August 19, 2024, 7:37am UTC](https://discuss.elastic.co/t/cant-see-my-services-inside-apm-with-elastic-user-login/365112/1 "2024-08-19T07:37:11Z")

</div>

hi all,

10.40.12.20 is my local IP

----------apm-server.yml--------  
apm-server:  
host: "0.0.0.0:8200"  
kibana:  
enabled: true  
host: "[http://10.40.12.20:5601](http://10.40.12.20:5601)" # Replace with your Kibana URL  
username: "kibana\_system" # If authentication is required  
password: "password" # If authentication is required  
rum:  
enabled: true  
ssl:  
enabled: false # Set to true if using SSL  
verification\_mode: none

setup:  
kibana:  
host: "[http://10.40.12.20:5601](http://10.40.12.20:5601)" # Replace with your Kibana URL

output.elasticsearch:  
hosts: ["[http://10.40.12.20:9200](http://10.40.12.20:9200)"]  
username: "elastic"  
password: "password"  
ssl:  
enabled: false # Set to true if using SSL  
verification\_mode: none

-----------elasticsearch.yml --------------  
xpack.security.enabled: true

discovery.type: single-node

network.host: 127.0.0.1

http.port: 9200

----------------kibana.yml------------  
server.name: "kibana"

server.host: "0.0.0.0" # Bind to all network interfaces

server.port: "5601"

elasticsearch.hosts: ["[http://127.0.0.1:9200](http://127.0.0.1:9200)"]

elasticsearch.username: "elastic"

elasticsearch.password: "password"

server.publicBaseUrl: "[http://localhost:5601](http://localhost:5601)"

xpack.security.encryptionKey: "VtG9FgY8JQ8CZW4eZbL2rHw8u9wT1mXy"

xpack.encryptedSavedObjects.encryptionKey: "VtG9FgY8JQ8CZW4eZbL2rHw8u9wT1mXy"  
xpack.reporting.encryptionKey : "VtG9FgY8JQ8CZW4eZbL2rHw8u9wT1mXy"  
xpack.security.session.idleTimeout: "1h"  
xpack.security.session.lifespan: "30d"  
elasticsearch.ssl.verificationMode: none

---------code in application----------  
import apm from 'elastic-apm-node'  
apm.start({  
serviceName: 'application-1',

secretToken: '',

serverUrl: '[http://elastic:password@10.40.12.20:8200](http://elastic:password@10.40.12.20:8200)',

environment: process.env.NODE\_ENV,

logLevel: 'debug',  
active: true,  
instrument: true  
})

getting error in application code:-  
`{"log.level":"error","@timestamp":"2024-08-19T07:36:06.598Z","log.logger":"elastic-apm-node","ecs.version":"8.10.0","message":"APM Server transport error (503): Unexpected APM Server response when polling config\n{\"statusCode\":403,\"error\":\"Forbidden\",\"message\":\"Forbidden\"}"}`

Thanks in advance.

---

<div class="post-metadata">

**Author:** ![Amol\_Nagotkar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amol_nagotkar/32/124188_2.png) [@Amol\_Nagotkar](https://discuss.elastic.co/u/Amol_Nagotkar)\
**Post date:** [August 19, 2024, 11:23am UTC](https://discuss.elastic.co/t/cant-see-my-services-inside-apm-with-elastic-user-login/365112/2 "2024-08-19T11:23:03Z")

</div>

I am able to resolved this issue by using elastic as username.  
but cant see my services inside APM

 ![Screenshot from 2024-08-19 16-50-52](https://us1.discourse-cdn.com/elastic/original/3X/d/1/d1e9809d1caecb4f711d3017c8c32e35fd036202.png)

BUT i am able to see expected services if i don't use username and password in kibana and apm-server .yml config

i checked result of this api-\> [http://localhost:5601/internal/apm/services](http://localhost:5601/internal/apm/services)

without login-\>  
{  
"items": [  
{  
"serviceName": "Template",  
"transactionType": "request",  
"environments": [  
"local"  
],  
"agentName": "nodejs",  
"latency": 341203.06666666665,  
"transactionErrorRate": null,  
"throughput": 0.9766780142182615  
}  
],  
"hasLegacyData": false  
}

with login-\>  
{  
"items": ,  
"hasLegacyData": false  
}  
please help. Thank you in advance.
