# Can't set file as target for log repository

**URL:** <https://discuss.elastic.co/t/cant-set-file-as-target-for-log-repository/95944>\
**Category:** Kibana\
**Created:** [August 4, 2017, 7:00pm UTC](https://discuss.elastic.co/t/cant-set-file-as-target-for-log-repository/95944 "2017-08-04T19:00:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![IvanBiv](https://avatars.discourse-cdn.com/v4/letter/i/34f0e0/32.png) [@IvanBiv](https://discuss.elastic.co/u/IvanBiv)\
**Post date:** [August 4, 2017, 7:00pm UTC](https://discuss.elastic.co/t/cant-set-file-as-target-for-log-repository/95944/1 "2017-08-04T19:00:22Z")

</div>

I use field logging.dest in kibana.yml  
When I set  
logging.dest: stdout  
web UI is work  
If i try to set  
logging.dest: /home/ivan/Documents/kibana.log  
Directory is exist, end user have access.  
I see fail:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/2/a26965a6682917c7886ba6fed90a2120a7cd0991.png)

...  
kibana.service: Main process exited, code=exited, status=1/FAILURE  
kibana.service: Unit entered failed state.  
kibana.service: Failed with result 'exit-code'.  
kibana.service: Service hold-off time over, scheduling restart.  
Stopped Kibana.  
kibana.service: Start request repeated too quickly.  
Failed to start Kibana.  
...

ES+Kibana  
Version: 5.5.1

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [August 4, 2017, 9:14pm UTC](https://discuss.elastic.co/t/cant-set-file-as-target-for-log-repository/95944/2 "2017-08-04T21:14:48Z")

</div>

Hi Ivan,  
The kibana service runs as the `kibana` user. Does that user have the correct permissions to write to `/home/ivan/Documents/` directory?

FYI, The normal location where those logs would go is `/var/log/kibana/`

Regards,  
Lee

---

<div class="post-metadata">

**Author:** ![IvanBiv](https://avatars.discourse-cdn.com/v4/letter/i/34f0e0/32.png) [@IvanBiv](https://discuss.elastic.co/u/IvanBiv)\
**Post date:** [August 5, 2017, 7:18am UTC](https://discuss.elastic.co/t/cant-set-file-as-target-for-log-repository/95944/3 "2017-08-05T07:18:06Z")

</div>

Hi Lee  
I set permissions for "`kibana`" user as owner to "`kibana`" folder in path `/var/log/kibana/` and it is work.  
Thanks Lee!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 2, 2017, 7:18am UTC](https://discuss.elastic.co/t/cant-set-file-as-target-for-log-repository/95944/4 "2017-09-02T07:18:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
