# Cant start elasticsearch after update from 6.6.2 to 7.6.2

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195>\
**Category:** Elasticsearch\
**Created:** [May 5, 2020, 4:29pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195 "2020-05-05T16:29:01Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Deny7](https://avatars.discourse-cdn.com/v4/letter/d/e0b2c6/32.png) [@Deny7](https://discuss.elastic.co/u/Deny7)\
**Post date:** [May 5, 2020, 4:29pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/1 "2020-05-05T16:29:01Z")

</div>

Hi,  
I want to do full elk stack upgrade from 6.6.2 to 7.6.2. Started with elasticsearch. I did snapshot backup. Followed this guide [https://www.elastic.co/guide/en/elasticsearch/reference/7.6/restart-upgrade.html](https://www.elastic.co/guide/en/elasticsearch/reference/7.6/restart-upgrade.html)

Downloaded package using:  
`wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-7.6.2-x86_64.rpm`

Installed using:  
`yum localinstall "package"`

Then when I want to start elastic using: **service elasticsearch start** it gives me error:

```
May 5 18:15:43 prd systemd: Starting Elasticsearch...
May 5 18:15:44 prd elasticsearch: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
May 5 18:15:44 prd elasticsearch: OpenJDK 64-Bit Server VM warning: UseAVX=2 is not supported on this CPU, setting it to UseAVX=1
May 5 18:15:45 prd elasticsearch: ERROR: Temporary file directory [${ES_TMPDIR}] does not exist or is not accessible
May 5 18:15:45 prd systemd: elasticsearch.service: main process exited, code=exited, status=78/n/a
May 5 18:15:45 prd systemd: Failed to start Elasticsearch.
May 5 18:15:45 prd systemd: Unit elasticsearch.service entered failed state.
May 5 18:15:45 prd systemd: elasticsearch.service failed.

```

Please can you help me?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [May 5, 2020, 4:32pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/2 "2020-05-05T16:32:18Z")

</div>

> [@Deny7](#):
>
> May 5 18:15:45 prd elasticsearch: ERROR: Temporary file directory [${ES\_TMPDIR}] does not exist or is not accessible

Looks like you have a config issue?

---

<div class="post-metadata">

**Author:** ![Deny7](https://avatars.discourse-cdn.com/v4/letter/d/e0b2c6/32.png) [@Deny7](https://discuss.elastic.co/u/Deny7)\
**Post date:** [May 5, 2020, 5:41pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/3 "2020-05-05T17:41:11Z")

</div>

Where can I define this variable?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [May 5, 2020, 5:56pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/4 "2020-05-05T17:56:04Z")

</div>

Usually in /etc/defaults/elasticsearch

---

<div class="post-metadata">

**Author:** ![Deny7](https://avatars.discourse-cdn.com/v4/letter/d/e0b2c6/32.png) [@Deny7](https://discuss.elastic.co/u/Deny7)\
**Post date:** [May 5, 2020, 6:13pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/5 "2020-05-05T18:13:13Z")

</div>

I dont have such a file in /etc/default , so I created one and put inside:

`ES_TMPDIR=/tmp/elasticsearch`

Im still getting same error.

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [May 5, 2020, 7:26pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/6 "2020-05-05T19:26:29Z")

</div>

You can give this a try and see if that works..

`sudo mkdir /usr/share/elasticsearch/tmp && sudo chmod 777 -R /usr/share/elasticsearch/tmp`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 2, 2020, 7:41pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-after-update-from-6-6-2-to-7-6-2/231195/7 "2020-06-02T19:41:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
