# Cant start elasticsearch FailedNodeException

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892>\
**Category:** Elasticsearch\
**Created:** [April 1, 2017, 9:32am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892 "2017-04-01T09:32:51Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pranil\_Ambule](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pranil_ambule/32/16208_2.png) [@Pranil\_Ambule](https://discuss.elastic.co/u/Pranil_Ambule)\
**Post date:** [April 1, 2017, 9:32am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892/1 "2017-04-01T09:32:52Z")

</div>

I use elk stack.  
Elasticsearch was working fine till yesterday suddenly i got this error.I havent done any updates or any changes.

 ![](https://us1.discourse-cdn.com/elastic/original/3X/0/7/0770564bde0a4dd292fa62e48b1157053895c9eb.PNG)  
here is the detailed log.  
[logs](https://drive.google.com/open?id=1tu-GYN1bHHjtrVvN8szVVq4d01qbWNzQzssMpL4LS8o)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 1, 2017, 9:47am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892/2 "2017-04-01T09:47:49Z")

</div>

Don't paste pictures please. Not readable.

```auto
Caused by: org.elasticsearch.gateway.CorruptStateException: org.apache.lucene.index.CorruptIndexException: codec footer mismatch (file truncated?): actual footer=1580742256 vs expected footer=-1071082520 (resource=BufferedChecksumIndexInput(SimpleFSIndexInput(path="C:\elasticsearch-5.1.2\data\nodes\0\indices\WweWFGwwQg662yHFYbQQhw\3\_state\state-8.st")))

```

It sounds like you have a disk corruption or something like this?  
May be your system logs will tell you something?

---

<div class="post-metadata">

**Author:** ![Pranil\_Ambule](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pranil_ambule/32/16208_2.png) [@Pranil\_Ambule](https://discuss.elastic.co/u/Pranil_Ambule)\
**Post date:** [April 1, 2017, 10:03am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892/3 "2017-04-01T10:03:12Z")

</div>

Any idea what might have caused it?  
And how can i recover my indices?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 1, 2017, 10:59am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892/4 "2017-04-01T10:59:33Z")

</div>

> [@Pranil\_Ambule](#):
>
> Any idea what might have caused it?

As I said "disk corruption" ?

> [@Pranil\_Ambule](#):
>
> And how can i recover my indices?

If you have a multi nodes cluster with replicas = 1, there are multiple options like switching off the node, fix the hardware problem (like a disk analysis) and restart the node.

What do you have?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 29, 2017, 10:59am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-failednodeexception/80892/5 "2017-04-29T10:59:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
