# Can't start elasticsearch. please help

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720>\
**Category:** Elasticsearch\
**Created:** [September 23, 2020, 11:25pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720 "2020-09-23T23:25:47Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:25pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/1 "2020-09-23T23:25:47Z")

</div>

when I try run "sudo systemctl start elasticsearch" show me  
`Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details.`

and I run systemctl status elasticsearch.service  
show me

> ```
> â— elasticsearch.service - Elasticsearch
> Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
> Active: failed (Result: exit-code) since Wed 2020-09-23 19:21:24 EDT; 49s ago
> Docs: https://www.elastic.co
> Process: 5543 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
> Main PID: 5543 (code=exited, status=1/FAILURE)
> CGroup: /system.slice/elasticsearch.service
> 
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd-entrypoint[5543]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161)
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd-entrypoint[5543]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd-entrypoint[5543]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
> Sep 23 19:21:24 17196-142-42.cprapid.com systemd-entrypoint[5543]: at org.elasticsearch.cli.Command.main(Command.java:90)
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd-entrypoint[5543]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd-entrypoint[5543]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd[1]: Failed to start Elasticsearch.
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd[1]: Unit elasticsearch.service entered failed state.
> Sep 23 19:21:24 171-96-142-42.cprapid.com systemd[1]: elasticsearch.service failed.
> 
> ```

please help . how can fix this ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 23, 2020, 11:28pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/2 "2020-09-23T23:28:01Z")

</div>

Welcome to our community! 😃

Can you check the Elasticsearch logs, or use `journalctl -xe` as it mentions?

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:32pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/3 "2020-09-23T23:32:09Z")

</div>

> [@warkolm](#):
>
> `journalctl -xe`

```
Sep 23 19:29:40 172-96-142-42.cprapid.com pure-ftpd[6601]: (?@106.13.79.113) [INFO] New connection from 106.13.79.113
Sep 23 19:29:44 172-96-142-42.cprapid.com pure-ftpd[6601]: (?@106.13.79.113) [WARNING] Authentication failed for user [chineseunb_com]
Sep 23 19:29:44 172-96-142-42.cprapid.com pure-ftpd[6601]: (?@106.13.79.113) [INFO] Logout.
Sep 23 19:29:45 172-96-142-42.cprapid.com pure-ftpd[6606]: (?@106.13.79.113) [INFO] New connection from 106.13.79.113
Sep 23 19:29:49 172-96-142-42.cprapid.com pure-ftpd[6606]: (?@106.13.79.113) [WARNING] Authentication failed for user [chineseunb]
Sep 23 19:29:49 172-96-142-42.cprapid.com pure-ftpd[6606]: (?@106.13.79.113) [INFO] Logout.
Sep 23 19:29:50 172-96-142-42.cprapid.com pure-ftpd[6611]: (?@106.13.79.113) [INFO] New connection from 106.13.79.113
Sep 23 19:29:55 172-96-142-42.cprapid.com pure-ftpd[6611]: (?@106.13.79.113) [WARNING] Authentication failed for user [admin]
Sep 23 19:29:55 172-96-142-42.cprapid.com pure-ftpd[6611]: (?@106.13.79.113) [INFO] Logout.
Sep 23 19:29:56 172-96-142-42.cprapid.com pure-ftpd[6615]: (?@106.13.79.113) [INFO] New connection from 106.13.79.113
Sep 23 19:29:56 172-96-142-42.cprapid.com unix_chkpwd[6622]: password check failed for user (root)
Sep 23 19:29:56 172-96-142-42.cprapid.com sshd[6617]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=20.51.209.11 user=root
Sep 23 19:29:56 172-96-142-42.cprapid.com sshd[6617]: pam_succeed_if(sshd:auth): requirement "uid >= 1000" not met by user "root"
Sep 23 19:29:58 172-96-142-42.cprapid.com sshd[6617]: Failed password for root from 20.51.209.11 port 64940 ssh2
Sep 23 19:29:58 172-96-142-42.cprapid.com sshd[6617]: Received disconnect from 20.51.209.11 port 64940:11: Client disconnecting normally [preauth]
Sep 23 19:29:58 172-96-142-42.cprapid.com sshd[6617]: Disconnected from 20.51.209.11 port 64940 [preauth]
Sep 23 19:30:01 172-96-142-42.cprapid.com systemd[1]: Started Session 3999 of user root.
-- Subject: Unit session-3999.scope has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-3999.scope has finished starting up.
--
-- The start-up result is done.
Sep 23 19:30:01 172-96-142-42.cprapid.com systemd[1]: Started Session 3997 of user root.
-- Subject: Unit session-3997.scope has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-3997.scope has finished starting up.
--
-- The start-up result is done.
Sep 23 19:30:01 172-96-142-42.cprapid.com systemd[1]: Started Session 3998 of user adian.
-- Subject: Unit session-3998.scope has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-3998.scope has finished starting up.
--
-- The start-up result is done.
Sep 23 19:30:01 172-96-142-42.cprapid.com CROND[6629]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Sep 23 19:30:01 172-96-142-42.cprapid.com CROND[6630]: (root) CMD (/usr/local/cpanel/scripts/dcpumon-wrapper >/dev/null 2>&1)
Sep 23 19:30:01 172-96-142-42.cprapid.com CROND[6631]: (adian) CMD (/opt/cpanel/ea-php74/root/usr/bin/php /home/adian/public_html/bin/magento cron:run 2>&1 | grep -v "Ran jobs by schedule"
Sep 23 19:30:02 172-96-142-42.cprapid.com pure-ftpd[6615]: (?@106.13.79.113) [WARNING] Authentication failed for user [chineseunb123]
Sep 23 19:30:02 172-96-142-42.cprapid.com pure-ftpd[6615]: (?@106.13.79.113) [INFO] Logout.
Sep 23 19:30:02 172-96-142-42.cprapid.com pure-ftpd[6647]: (?@106.13.79.113) [INFO] New connection from 106.13.79.113
Sep 23 19:30:05 172-96-142-42.cprapid.com pure-ftpd[6647]: (?@106.13.79.113) [WARNING] Authentication failed for user [chineseunb888]
Sep 23 19:30:06 172-96-142-42.cprapid.com pure-ftpd[6647]: (?@106.13.79.113) [INFO] Logout.
Sep 23 19:30:06 172-96-142-42.cprapid.com pure-ftpd[6663]: (?@106.13.79.113) [INFO] New connection from 106.13.79.113
lines 1203-1251/1251 (END)

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 23, 2020, 11:33pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/4 "2020-09-23T23:33:39Z")

</div>

Thanks, what about `journalctl -xe elasticsearch.service`?  
Otherwise is there anything in `/var/log/elasticsearch/elasticsearch.log`?

What version are you running?

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:43pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/5 "2020-09-23T23:43:39Z")

</div>

```
[root@172-96-142-42 ~]# journalctl -xe elasticsearch.service
Failed to add match 'elasticsearch.service': Invalid argument
Failed to add filters: Invalid argument

```

7.9.1

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 23, 2020, 11:48pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/6 "2020-09-23T23:48:57Z")

</div>

Ok, did you check the log file?

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:51pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/7 "2020-09-23T23:51:26Z")

</div>

```
[20[2020-09-23T19:00:50,529][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] unable to load JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-13511472907557733579/jna17121400124815601741.tmp: /tmp/elasticsearch-13511472907557733579/jna17121400124815601741.tmp: failed to map segm$
        at java.lang.ClassLoader$NativeLibrary.load0(Native Method) ~[?:?]
        at java.lang.ClassLoader$NativeLibrary.load(ClassLoader.java:2452) ~[?:?]
        at java.lang.ClassLoader$NativeLibrary.loadLibrary(ClassLoader.java:2508) ~[?:?]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:2704) ~[?:?]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:2637) ~[?:?]
        at java.lang.Runtime.load0(Runtime.java:745) ~[?:?]
        at java.lang.System.load(System.java:1871) ~[?:?]
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:1018) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:988) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:195) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:?]
        at java.lang.Class.forName(Class.java:340) ~[?:?]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:45) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:110) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.9.1.jar:7.9.1]
20-09-23T19:07:48,695][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot getrlimit RLIMIT_FSIZE because JNA is not available
[2020-09-23T19:07:48,793][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] version[7.9.1], pid[4002], build[default/rpm/083627f112ba94dffc1232e8b42b73492789ef91/2020-09-01T21:22:21.964974Z], OS[Linux/3.10.0-1127.el7.x86_64/amd64], JVM[AdoptOpenJDK/OpenJDK 64-Bit Server VM/14.0.1/14.0.1+7]
[2020-09-23T19:07:48,794][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] JVM home [/usr/share/elasticsearch/jdk]
[2020-09-23T19:07:48,794][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] JVM arguments [-Xshare:auto, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -XX:+ShowCodeDetailsInExceptionMessages, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dio.netty.allocator.numDirectArenas=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.locale.providers=SPI,COMPAT, -Xms1g, -Xmx1g, -XX:+UseG1GC, -XX:G1ReservePercent=25, -XX:InitiatingHeapOccupancyPercent=30, -Djava.io.tmpdir=/tmp/elasticsearch-9040523989080922930, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -XX:MaxDirectMemorySize=536870912, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch, -Des.distribution.flavor=default, -Des.distribution.type=rpm, -Des.bundled_jdk=true]
[2020-09-23T19:07:50,244][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [aggs-matrix-stats]
[2020-09-23T19:07:50,244][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [analysis-common]
[2020-09-23T19:07:50,244][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [constant-keyword]
[2020-09-23T19:07:50,244][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [flattened]
[2020-09-23T19:07:50,244][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [frozen-indices]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [ingest-common]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [ingest-geoip]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [ingest-user-agent]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [kibana]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [lang-expression]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [lang-mustache]
[2020-09-23T19:07:50,245][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [lang-painless]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [mapper-extras]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [parent-join]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [percolator]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [rank-eval]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [reindex]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [repository-url]
[2020-09-23T19:07:50,246][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [search-business-rules]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [searchable-snapshots]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [spatial]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [systemd]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [tasks]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [transform]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [transport-netty4]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [vectors]
[2020-09-23T19:07:50,247][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [wildcard]
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-analytics]
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-async]
```

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:52pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/8 "2020-09-23T23:52:35Z")

</div>

```
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-async-search]
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-autoscaling]
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ccr]
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-core]
[2020-09-23T19:07:50,248][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-data-streams]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-deprecation]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-enrich]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-eql]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-graph]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-identity-provider]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ilm]
[2020-09-23T19:07:50,249][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-logstash]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ml]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-monitoring]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ql]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-rollup]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-security]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-sql]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-stack]
[2020-09-23T19:07:50,250][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-voting-only-node]
[2020-09-23T19:07:50,251][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-watcher]
[2020-09-23T19:07:50,251][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] no plugins loaded
[2020-09-23T19:07:50,281][INFO][o.e.e.NodeEnvironment] [172-96-142-42.cprapid.com] using [1] data paths, mounts [[/ (rootfs)]], net usable_space [939.4gb], net total_space [972.5gb], types [rootfs]
[2020-09-23T19:07:50,281][INFO][o.e.e.NodeEnvironment] [172-96-142-42.cprapid.com] heap size [1gb], compressed ordinary object pointers [true]
[2020-09-23T19:07:50,337][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] node name [172-96-142-42.cprapid.com], node ID [lwztjSfqRqCkTLvm8hc0xw], cluster name [elasticsearch]
[2020-09-23T19:07:52,767][INFO][o.e.x.m.p.l.CppLogMessageHandler] [172-96-142-42.cprapid.com] [controller/4203] [Main.cc@114] controller (64 bit): Version 7.9.1 (Build 6ed2566ba11bb5) Copyright (c) 2020 Elasticsearch BV
[2020-09-23T19:07:53,283][INFO][o.e.x.s.a.s.FileRolesStore] [172-96-142-42.cprapid.com] parsed [0] roles from file [/etc/elasticsearch/roles.yml]
[2020-09-23T19:07:54,043][INFO][o.e.d.DiscoveryModule] [172-96-142-42.cprapid.com] using discovery type [zen] and seed hosts providers [settings]
[2020-09-23T19:07:54,362][WARN][o.e.g.DanglingIndicesState] [172-96-142-42.cprapid.com] gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually
[2020-09-23T19:07:54,656][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] initialized
[2020-09-23T19:07:54,657][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] starting ...
[2020-09-23T19:07:54,753][INFO][o.e.t.TransportService] [172-96-142-42.cprapid.com] publish_address {localhost/127.0.0.1:9300}, bound_addresses {127.0.0.1:9300}, {[::1]:9300}
[2020-09-23T19:07:54,873][WARN][o.e.b.BootstrapChecks] [172-96-142-42.cprapid.com] system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2020-09-23T19:07:54,873][WARN][o.e.b.BootstrapChecks] [172-96-142-42.cprapid.com] the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
[2020-09-23T19:07:54,874][INFO][o.e.c.c.Coordinator] [172-96-142-42.cprapid.com] cluster UUID [9r0nMWhLQmKCVq1tevBc9A]
[2020-09-23T19:07:54,880][INFO][o.e.c.c.ClusterBootstrapService] [172-96-142-42.cprapid.com] no discovery configuration found, will perform best-effort cluster bootstrapping after [3s] unless existing master is discovered
[2020-09-23T19:07:54,955][INFO][o.e.c.s.MasterService] [172-96-142-42.cprapid.com] elected-as-master ([1] nodes joined)[{172-96-142-42.cprapid.com}{lwztjSfqRqCkTLvm8hc0xw}{4UKLvwsaQYuppN_sV29Urg}{localhost}{127.0.0.1:9300}{dilmrt}{ml.machine_memory=134916481024, xpack.installed=true, transform.node=true, ml.max_open_jobs=20} elect leader, _BECOME_MASTER_TASK_, _FINISH_ELECTION_], term: 20, version: 27, delta: master node changed {previous [], current [{172-96-142-42.cprapid.com}{lwztjSfqRqCkTLvm8hc0xw}{4UKLvwsaQYuppN_sV29Urg}{localhost}{127.0.0.1:9300}{dilmrt}{ml.machine_memory=134916481024, xpack.installed=true, transform.node=true, ml.max_open_jobs=20}]}
[2020-09-23T19:07:55,000][INFO][o.e.c.s.ClusterApplierService] [172-96-142-42.cprapid.com] master node changed {previous [], current [{172-96-142-42.cprapid.com}{lwztjSfqRqCkTLvm8hc0xw}{4UKLvwsaQYuppN_sV29Urg}{localhost}{127.0.0.1:9300}{dilmrt}{ml.machine_memory=134916481024, xpack.installed=true, transform.node=true, ml.max_open_jobs=20}]}, term: 20, version: 27, reason: Publication{term=20, version=27}
[2020-09-23T19:07:55,042][INFO][o.e.h.AbstractHttpServerTransport] [172-96-142-42.cprapid.com] publish_address {localhost/127.0.0.1:9200}, bound_addresses {127.0.0.1:9200}, {[::1]:9200}
[2020-09-23T19:07:55,043][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] started
[2020-09-23T19:07:55,044][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [172-96-142-42.cprapid.com] fatal error in thread [main], exiting
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:34) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:312) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:33) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:126) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(SystemdPlugin.java:137) ~[?:?]
        at java.util.ArrayList.forEach(ArrayList.java:1510) ~[?:?]
        at org.elasticsearch.node.Node.start(Node.java:868) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:317) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:402) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.9.1.jar:7.9.1]
[2020-09-23T19:21:18,121][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] unable to load JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-15937627081331951365/jna897330163417548735.tmp: /tmp/elasticsearch-15937627081331951365/jna897330163417548735.tmp: failed to map segment from shared object: Operation not permitted
        at java.lang.ClassLoader$NativeLibrary.load0(Native Method) ~[?:?]
        at java.lang.ClassLoader$NativeLibrary.load(ClassLoader.java:2452) ~[?:?]
        at java.lang.ClassLoader$NativeLibrary.loadLibrary(ClassLoader.java:2508) ~[?:?]
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:2704) ~[?:?]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:2637) ~[?:?]
        at java.lang.Runtime.load0(Runtime.java:745) ~[?:?]
        at java.lang.System.load(System.java:1871) ~[?:?]
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:1018) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:988) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:195) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:?]
        at java.lang.Class.forName(Class.java:340) ~[?:?]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:45) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:110) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) [elasticsearch-7.9.1.jar:7.9.1]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.9.1.jar:7.9.1]
```

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:53pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/9 "2020-09-23T23:53:31Z")

</div>

```
[2020-09-23T19:21:18,132][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot check if running as root because JNA is not available
[2020-09-23T19:21:18,132][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot install system call filter because JNA is not available
[2020-09-23T19:21:18,133][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot register console handler because JNA is not available
[2020-09-23T19:21:18,134][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot getrlimit RLIMIT_NPROC because JNA is not available
[2020-09-23T19:21:18,135][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot getrlimit RLIMIT_AS because JNA is not available
[2020-09-23T19:21:18,135][WARN][o.e.b.Natives] [172-96-142-42.cprapid.com] cannot getrlimit RLIMIT_FSIZE because JNA is not available
[2020-09-23T19:21:18,264][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] version[7.9.1], pid[5543], build[default/rpm/083627f112ba94dffc1232e8b42b73492789ef91/2020-09-01T21:22:21.964974Z], OS[Linux/3.10.0-1127.el7.x86_64/amd64], JVM[AdoptOpenJDK/OpenJDK 64-Bit Server VM/14.0.1/14.0.1+7]
[2020-09-23T19:21:18,265][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] JVM home [/usr/share/elasticsearch/jdk]
[2020-09-23T19:21:18,265][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] JVM arguments [-Xshare:auto, -Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -XX:+ShowCodeDetailsInExceptionMessages, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dio.netty.allocator.numDirectArenas=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.locale.providers=SPI,COMPAT, -Xms1g, -Xmx1g, -XX:+UseG1GC, -XX:G1ReservePercent=25, -XX:InitiatingHeapOccupancyPercent=30, -Djava.io.tmpdir=/tmp/elasticsearch-15937627081331951365, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -XX:MaxDirectMemorySize=536870912, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch, -Des.distribution.flavor=default, -Des.distribution.type=rpm, -Des.bundled_jdk=true]
[2020-09-23T19:21:19,699][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [aggs-matrix-stats]
[2020-09-23T19:21:19,699][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [analysis-common]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [constant-keyword]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [flattened]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [frozen-indices]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [ingest-common]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [ingest-geoip]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [ingest-user-agent]
[2020-09-23T19:21:19,700][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [kibana]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [lang-expression]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [lang-mustache]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [lang-painless]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [mapper-extras]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [parent-join]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [percolator]
[2020-09-23T19:21:19,701][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [rank-eval]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [reindex]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [repository-url]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [search-business-rules]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [searchable-snapshots]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [spatial]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [systemd]
[2020-09-23T19:21:19,702][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [tasks]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [transform]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [transport-netty4]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [vectors]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [wildcard]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-analytics]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-async]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-async-search]
[2020-09-23T19:21:19,703][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-autoscaling]
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ccr]
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-core]
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-data-streams]
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-deprecation]
```

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:54pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/10 "2020-09-23T23:54:20Z")

</div>

```
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-enrich]
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-eql]
[2020-09-23T19:21:19,704][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-graph]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-identity-provider]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ilm]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-logstash]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ml]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-monitoring]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-ql]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-rollup]
[2020-09-23T19:21:19,705][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-security]
[2020-09-23T19:21:19,706][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-sql]
[2020-09-23T19:21:19,706][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-stack]
[2020-09-23T19:21:19,706][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-voting-only-node]
[2020-09-23T19:21:19,706][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] loaded module [x-pack-watcher]
[2020-09-23T19:21:19,706][INFO][o.e.p.PluginsService] [172-96-142-42.cprapid.com] no plugins loaded
[2020-09-23T19:21:19,736][INFO][o.e.e.NodeEnvironment] [172-96-142-42.cprapid.com] using [1] data paths, mounts [[/ (rootfs)]], net usable_space [939.4gb], net total_space [972.5gb], types [rootfs]
[2020-09-23T19:21:19,736][INFO][o.e.e.NodeEnvironment] [172-96-142-42.cprapid.com] heap size [1gb], compressed ordinary object pointers [true]
[2020-09-23T19:21:19,793][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] node name [172-96-142-42.cprapid.com], node ID [lwztjSfqRqCkTLvm8hc0xw], cluster name [elasticsearch]
[2020-09-23T19:21:22,182][INFO][o.e.x.m.p.l.CppLogMessageHandler] [172-96-142-42.cprapid.com] [controller/5742] [Main.cc@114] controller (64 bit): Version 7.9.1 (Build 6ed2566ba11bb5) Copyright (c) 2020 Elasticsearch BV
[2020-09-23T19:21:22,666][INFO][o.e.x.s.a.s.FileRolesStore] [172-96-142-42.cprapid.com] parsed [0] roles from file [/etc/elasticsearch/roles.yml]
[2020-09-23T19:21:23,525][INFO][o.e.d.DiscoveryModule] [172-96-142-42.cprapid.com] using discovery type [zen] and seed hosts providers [settings]
[2020-09-23T19:21:23,854][WARN][o.e.g.DanglingIndicesState] [172-96-142-42.cprapid.com] gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually
[2020-09-23T19:21:24,149][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] initialized
```

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 23, 2020, 11:54pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/11 "2020-09-23T23:54:56Z")

</div>

```
[2020-09-23T19:21:24,149][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] starting ...
[2020-09-23T19:21:24,245][INFO][o.e.t.TransportService] [172-96-142-42.cprapid.com] publish_address {localhost/127.0.0.1:9300}, bound_addresses {127.0.0.1:9300}, {[::1]:9300}
[2020-09-23T19:21:24,353][WARN][o.e.b.BootstrapChecks] [172-96-142-42.cprapid.com] system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2020-09-23T19:21:24,353][WARN][o.e.b.BootstrapChecks] [172-96-142-42.cprapid.com] the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
[2020-09-23T19:21:24,353][INFO][o.e.c.c.Coordinator] [172-96-142-42.cprapid.com] cluster UUID [9r0nMWhLQmKCVq1tevBc9A]
[2020-09-23T19:21:24,359][INFO][o.e.c.c.ClusterBootstrapService] [172-96-142-42.cprapid.com] no discovery configuration found, will perform best-effort cluster bootstrapping after [3s] unless existing master is discovered
[2020-09-23T19:21:24,518][INFO][o.e.c.s.MasterService] [172-96-142-42.cprapid.com] elected-as-master ([1] nodes joined)[{172-96-142-42.cprapid.com}{lwztjSfqRqCkTLvm8hc0xw}{dxmXJ7wrQiSzOER0RWJzrg}{localhost}{127.0.0.1:9300}{dilmrt}{ml.machine_memory=134916481024, xpack.installed=true, transform.node=true, ml.max_open_jobs=20} elect leader, _BECOME_MASTER_TASK_, _FINISH_ELECTION_], term: 21, version: 28, delta: master node changed {previous [], current [{172-96-142-42.cprapid.com}{lwztjSfqRqCkTLvm8hc0xw}{dxmXJ7wrQiSzOER0RWJzrg}{localhost}{127.0.0.1:9300}{dilmrt}{ml.machine_memory=134916481024, xpack.installed=true, transform.node=true, ml.max_open_jobs=20}]}
[2020-09-23T19:21:24,570][INFO][o.e.c.s.ClusterApplierService] [172-96-142-42.cprapid.com] master node changed {previous [], current [{172-96-142-42.cprapid.com}{lwztjSfqRqCkTLvm8hc0xw}{dxmXJ7wrQiSzOER0RWJzrg}{localhost}{127.0.0.1:9300}{dilmrt}{ml.machine_memory=134916481024, xpack.installed=true, transform.node=true, ml.max_open_jobs=20}]}, term: 21, version: 28, reason: Publication{term=21, version=28}
[2020-09-23T19:21:24,609][INFO][o.e.h.AbstractHttpServerTransport] [172-96-142-42.cprapid.com] publish_address {localhost/127.0.0.1:9200}, bound_addresses {127.0.0.1:9200}, {[::1]:9200}
[2020-09-23T19:21:24,610][INFO][o.e.n.Node] [172-96-142-42.cprapid.com] started
[2020-09-23T19:21:24,611][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [172-96-142-42.cprapid.com] fatal error in thread [main], exiting
java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
    at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:34) ~[?:?]
    at java.security.AccessController.doPrivileged(AccessController.java:312) ~[?:?]
    at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:33) ~[?:?]
    at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:126) ~[?:?]
    at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(SystemdPlugin.java:137) ~[?:?]
    at java.util.ArrayList.forEach(ArrayList.java:1510) ~[?:?]
    at org.elasticsearch.node.Node.start(Node.java:868) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:317) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:402) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
    at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.9.1.jar:7.9.1]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.9.1.jar:7.9.1]
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.9.1.jar:7.9.1]
```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 23, 2020, 11:56pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/12 "2020-09-23T23:56:57Z")

</div>

Can you try the solution here [Unable to start elasticsearch from systemctl in centos 7.7](https://discuss.elastic.co/t/unable-to-start-elasticsearch-from-systemctl-in-centos-7-7/230025)?

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 24, 2020, 12:03am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/13 "2020-09-24T00:03:54Z")

</div>

worked

thank you so much

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 24, 2020, 3:18am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/14 "2020-09-24T03:18:46Z")

</div>

Great to hear.  
What OS, and what version of it, are you on?

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 24, 2020, 3:42am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/15 "2020-09-24T03:42:03Z")

</div>

CentOS 7.4  
elasticsearch 7.9.1

---

<div class="post-metadata">

**Author:** ![Tomz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tomz/32/69343_2.png) [@Tomz](https://discuss.elastic.co/u/Tomz)\
**Post date:** [September 24, 2020, 3:43am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/16 "2020-09-24T03:43:42Z")

</div>

but I try reinstall elasticsearch 7.7.0. It is not work

please help

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 24, 2020, 3:56am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/17 "2020-09-24T03:56:45Z")

</div>

If you upgraded from 7.7 to 7.9, you cannot downgrade that same install.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 22, 2020, 3:56am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-please-help/249720/18 "2020-10-22T03:56:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
