# Can't start Elasticsearch service (code=exited, status=1/FAILURE) affter add x.pack security

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-service-code-exited-status-1-failure-affter-add-x-pack-security/254346>\
**Category:** Elasticsearch\
**Created:** [November 5, 2020, 3:56am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-code-exited-status-1-failure-affter-add-x-pack-security/254346 "2020-11-05T03:56:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![aloalo2242](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aloalo2242/32/78043_2.png) [@aloalo2242](https://discuss.elastic.co/u/aloalo2242)\
**Post date:** [November 5, 2020, 3:56am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-code-exited-status-1-failure-affter-add-x-pack-security/254346/1 "2020-11-05T03:56:57Z")

</div>

Hi, I try to add **Enable Elasticsearch security features** by add this line in elasticsearch.yml: **xpack.security.enabled: true**  
and this is full conf:

```auto
    # ======================== Elasticsearch Configuration =========================
    #
    # NOTE: Elasticsearch comes with reasonable defaults for most settings.
    # Before you set out to tweak and tune the configuration, make sure you
    # understand what are you trying to accomplish and the consequences.
    #
    # The primary way of configuring a node is via this file. This template lists
    # the most important settings you may want to configure for a production cluster.
    #
    # Please consult the documentation for further information on configuration options:
    # https://www.elastic.co/guide/en/elasticsearch/reference/index.html
    #
    # ---------------------------------- Cluster -----------------------------------
    #
    # Use a descriptive name for your cluster:
    #
    #cluster.name: my-application
    #
    # ------------------------------------ Node ------------------------------------
    #
    # Use a descriptive name for the node:
    #
    node.name: node-1
    #
    # Add custom attributes to the node:
    #
    #node.attr.rack: r1
    #
    # ----------------------------------- Paths ------------------------------------
    #
    # Path to directory where to store the data (separate multiple locations by comma):
    #
    path.data: /var/lib/elasticsearch
    #
    # Path to log files:
    #
    path.logs: /var/log/elasticsearch
    #
    # ----------------------------------- Memory -----------------------------------
    #
    # Lock the memory on startup:
    #
    bootstrap.memory_lock: true
    #
    # Make sure that the heap size is set to about half the memory available
    # on the system and that the owner of the process is allowed to use this
    # limit.
    #
    # Elasticsearch performs poorly when the system is swapping the memory.
    #
    # ---------------------------------- Network -----------------------------------
    #
    # Set the bind address to a specific IP (IPv4 or IPv6):
    #
    network.host: 0.0.0.0
    transport.host: 0.0.0.0

    #
    # Set a custom port for HTTP:
    #
    http.port: 9200
    transport.tcp.port: 9300 
    #
    # For more information, consult the network module documentation.
    #
    # --------------------------------- Discovery ----------------------------------
    #
    # Pass an initial list of hosts to perform discovery when this node is started:
    # The default list of hosts is ["127.0.0.1", "[::1]"]
    #
    #discovery.seed_hosts: ["host1", "host2"]
    discovery.seed_hosts: ["node-1",]
    # Bootstrap the cluster using an initial set of master-eligible nodes:
    #
    cluster.initial_master_nodes: node-1
    #
    # For more information, consult the discovery and cluster formation module documentation.
    #
    # ---------------------------------- Gateway -----------------------------------
    #
    # Block initial recovery after a full cluster restart until N nodes are started:
    #
    #gateway.recover_after_nodes: 3
    #
    # For more information, consult the gateway module documentation.
    #
    # ---------------------------------- Various -----------------------------------
    #
    # Require explicit names when deleting indices:
    #
    #action.destructive_requires_name: true
    #
    #------------------------------------X_PACK-------------------------------------

    xpack.security.enabled: true
    xpack.security.transport.ssl.enabled:true

```

After that, I start again service and it fail

```auto
    [root@localhost bin]# systemctl status elasticsearch
    ● elasticsearch.service - Elasticsearch
       Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Thu 2020-11-05 10:40:33 +07; 1s ago
         Docs: https://www.elastic.co
      Process: 14929 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
     Main PID: 14929 (code=exited, status=1/FAILURE)

    Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: xpack.security.transport.ssl.ena ...
    Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: ^
    Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: could not find expected ':'
    Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: in 'reader', line 97, column 1:
    Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: ^
    Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: ];
    Nov 05 10:40:33 localhost.localdomain systemd[1]: elasticsearch.service: main process exited, cod...URE
    Nov 05 10:40:33 localhost.localdomain systemd[1]: Failed to start Elasticsearch.
    Nov 05 10:40:33 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.
    Nov 05 10:40:33 localhost.localdomain systemd[1]: elasticsearch.service failed.
    Hint: Some lines were ellipsized, use -l to show in full.

```

I opened **var/log/elasticsearch/elasticsearch.log** and there's notthing new

Please help me!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 5, 2020, 4:36am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-code-exited-status-1-failure-affter-add-x-pack-security/254346/2 "2020-11-05T04:36:58Z")

</div>

> [@aloalo2242](#):
>
> ```auto
> Nov 05 10:40:33 localhost.localdomain systemd-entrypoint[14929]: in 'reader', line 97, column 1:
> 
> ```

> [@aloalo2242](#):
>
> ```auto
> xpack.security.transport.ssl.enabled:true
> 
> ```

You need a space in there.

---

<div class="post-metadata">

**Author:** ![aloalo2242](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aloalo2242/32/78043_2.png) [@aloalo2242](https://discuss.elastic.co/u/aloalo2242)\
**Post date:** [November 18, 2020, 8:34am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-code-exited-status-1-failure-affter-add-x-pack-security/254346/3 "2020-11-18T08:34:26Z")

</div>

Nice, thank you Warkolm

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 16, 2020, 8:34am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-code-exited-status-1-failure-affter-add-x-pack-security/254346/4 "2020-12-16T08:34:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
