# Can't start Elasticsearch service, Version: 6.3.2.0

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-service-version-6-3-2-0/165783>\
**Category:** Elasticsearch\
**Created:** [January 25, 2019, 1:28pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-version-6-3-2-0/165783 "2019-01-25T13:28:16Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ERD](https://avatars.discourse-cdn.com/v4/letter/e/f07891/32.png) [@ERD](https://discuss.elastic.co/u/ERD)\
**Post date:** [January 25, 2019, 1:28pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-version-6-3-2-0/165783/1 "2019-01-25T13:28:17Z")

</div>

I did a new installation on Windows Server 2012R2 64 Bit and 16GB Ram. And the service don't start. Error: "The process was terminated due to an unhandled exception."

This is the windows event log:

Application: elasticsearch.exe  
Framework Version: v4.0.30319  
Description: The process was terminated due to an unhandled exception.  
Exception Info: Elastic.ProcessHosts.Process.StartupException  
at Elastic.ProcessHosts.Process.ProcessBase.HandleException(System.Exception)  
at System.Reactive.ObserverBase`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception) at System.Reactive.Observer`1[[System.\_\_Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception)  
at System.Reactive.Linq.ObservableImpl.AsObservable`1+_[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception) at System.Reactive.AutoDetachObserver`1[[System.\_\_Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnErrorCore(System.Exception)  
at System.Reactive.ObserverBase`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnError(System.Exception) at Elastic.ProcessHosts.Process.ObservableProcess+<>c__DisplayClass22_0.<CreateProcessExitSubscription>b__0(System.Reactive.EventPattern`1\<System.Object\>)  
at System.Reactive.AnonymousSafeObserver`1[[System.\_\_Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnNext(System.\_\_Canon)  
at System.EventHandler.Invoke(System.Object, System.EventArgs)  
at System.Diagnostics.Process.OnExited()  
at System.Diagnostics.Process.RaiseOnExited()  
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)  
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)  
at System.Threading.\_ThreadPoolWaitOrTimerCallback.PerformWaitOrTimerCallback(System.Object, Boolean)

and second one :

Faulting application name: elasticsearch.exe, version: 6.3.2.0, time stamp: 0x5b518479  
Faulting module name: KERNELBASE.dll, version: 6.3.9600.19178, time stamp: 0x5bc006fd  
Exception code: 0xe0434352  
Fault offset: 0x0000000000008e6c  
Faulting process id: 0x1224  
Faulting application start time: 0x01d4b4ac9cd7f892  
Faulting application path: C:\Program Files\Elastic\Elasticsearch\6.3.2\bin\elasticsearch.exe  
Faulting module path: C:\Windows\system32\KERNELBASE.dll  
Report Id: e742c2ee-209f-11e9-80cd-0050569ba7d6  
Faulting package full name:  
Faulting package-relative application ID:

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [January 26, 2019, 6:49am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-version-6-3-2-0/165783/2 "2019-01-26T06:49:48Z")

</div>

Is there anything in the elasticsearch.log? The default location will be

```auto
%ALLUSERSPROFILE%\Elastic\Elasticsearch\logs

```

which is usually, `C:\ProgramData\Elastic\Elasticsearch\logs`, unless you specified somewhere else during installation.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 23, 2019, 6:49am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service-version-6-3-2-0/165783/3 "2019-02-23T06:49:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
