# Can't start elasticsearch service

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-service/127099>\
**Category:** Elasticsearch\
**Created:** [April 6, 2018, 1:32pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service/127099 "2018-04-06T13:32:40Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Abdesslem\_Jerbi](https://avatars.discourse-cdn.com/v4/letter/a/ad7895/32.png) [@Abdesslem\_Jerbi](https://discuss.elastic.co/u/Abdesslem_Jerbi)\
**Post date:** [April 6, 2018, 1:32pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service/127099/1 "2018-04-06T13:32:40Z")

</div>

Hi all,  
i work on ubuntu VM ,and i cant start service ES;;i followed all the steps for installation  
Synchronizing state of elasticsearch.service with SysV init with /lib/systemd/systemd-sysv-install...  
Executing /lib/systemd/systemd-sysv-install enable elasticsearch  
root@orange-VirtualBox:/home/ELK# sudo /bin/systemctl start elasticsearch.service  
root@orange-VirtualBox:/home/ELK# service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: e  
Active: failed (Result: exit-code) since ven. 2018-04-06 15:20:36 CEST; 5s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2210 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elastics  
Process: 2208 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (c  
Main PID: 2210 (code=exited, status=1/FAILURE)

```
    avril 06 15:20:27 orange-VirtualBox systemd[1]: Started Elasticsearch.
    avril 06 15:20:31 orange-VirtualBox elasticsearch[2210]: Java HotSpot(TM) 64-Bit Server VM 
    avril 06 15:20:31 orange-VirtualBox elasticsearch[2210]: #
    avril 06 15:20:31 orange-VirtualBox elasticsearch[2210]: # There is insufficient memory for
    avril 06 15:20:31 orange-VirtualBox elasticsearch[2210]: # Native memory allocation (mmap) 
    avril 06 15:20:31 orange-VirtualBox elasticsearch[2210]: # An error report file with more i
    avril 06 15:20:31 orange-VirtualBox elasticsearch[2210]: # /tmp/hs_err_pid2210.log
    avril 06 15:20:36 orange-VirtualBox systemd[1]: elasticsearch.service: Main process exited,
    avril 06 15:20:36 orange-VirtualBox systemd[1]: elasticsearch.service: Unit entered failed 
    avril 06 15:20:36 orange-VirtualBox systemd[1]: elasticsearch.service: Failed with result '
```

---

<div class="post-metadata">

**Author:** ![A\_B](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/a_b/32/17104_2.png) [@A\_B](https://discuss.elastic.co/u/A_B)\
**Post date:** [April 6, 2018, 2:06pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service/127099/2 "2018-04-06T14:06:49Z")

</div>

Did you check `/tmp/hs_err_pid2210.log`? How much RAM does your VM have?

`There is insufficient memory for Native memory allocation (mmap)`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 4, 2018, 2:07pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-service/127099/3 "2018-05-04T14:07:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
