# Can't start elasticsearch systemctl

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch-systemctl/256725>\
**Category:** Elasticsearch\
**Created:** [November 26, 2020, 4:29am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-systemctl/256725 "2020-11-26T04:29:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![yowies\_lintar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yowies_lintar/32/79726_2.png) [@yowies\_lintar](https://discuss.elastic.co/u/yowies_lintar)\
**Post date:** [November 26, 2020, 4:29am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-systemctl/256725/1 "2020-11-26T04:29:29Z")

</div>

elasticsearch]# systemctl start elasticsearch  
Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

## elasticsearch]# journalctl -xe Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at java.base/sun.nio.fs.UnixFileSystemProvider.newFileChannel(UnixFileSystemProvider.jav Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at java.base/java.nio.channels.FileChannel.open(FileChannel.java:292) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at java.base/java.nio.channels.FileChannel.open(FileChannel.java:345) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.apache.lucene.store.NativeFSLockFactory.obtainFSLock(NativeFSLockFactory.java:125 Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.apache.lucene.store.FSLockFactory.obtainLock(FSLockFactory.java:41) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.apache.lucene.store.BaseDirectory.obtainLock(BaseDirectory.java:45) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.env.NodeEnvironment$NodeLock.(NodeEnvironment.java:217) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:272) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.node.Node.(Node.java:362) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.node.Node.(Node.java:289) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:227) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:227) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86 Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.cli.Command.main(Command.java:90) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) Nov 26 11:10:26 SOKI systemd-entrypoint[7694]: For complete error details, refer to the log at /var/log/elasticsearch/elasticsearch.log Nov 26 11:10:26 SOKI systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE Nov 26 11:10:26 SOKI systemd[1]: Failed to start Elasticsearch. -- Subject: Unit elasticsearch.service has failed -- Defined-By: systemd -- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

## -- Unit elasticsearch.service has failed.

-- The result is failed.  
Nov 26 11:10:26 SOKI systemd[1]: Unit elasticsearch.service entered failed state.  
Nov 26 11:10:26 SOKI systemd[1]: elasticsearch.service failed.  
Nov 26 11:10:26 SOKI polkitd[613]: Unregistered Authentication Agent for unix-process:7688:548294 (system bus name :1.119, object path

Please help

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 30, 2020, 4:49am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-systemctl/256725/2 "2020-11-30T04:49:33Z")

</div>

> [@yowies\_lintar](#):
>
> For complete error details, refer to the log at /var/log/elasticsearch/elasticsearch.log

Did you look there?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 28, 2020, 4:49am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-systemctl/256725/3 "2020-12-28T04:49:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
