# Can't start elasticsearch

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch/277086>\
**Category:** Elasticsearch\
**Created:** [June 25, 2021, 3:37pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/277086 "2021-06-25T15:37:51Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Fatma\_Alzahraa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fatma_alzahraa/32/78301_2.png) [@Fatma\_Alzahraa](https://discuss.elastic.co/u/Fatma_Alzahraa)\
**Post date:** [June 25, 2021, 3:37pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/277086/1 "2021-06-25T15:37:51Z")

</div>

Hello ,  
I installed elasticsearch but can't start and get errors  
centos 7  
jdk version : jdk 11  
elasticsearch version : 7.13.2

[root@server bin]# systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Fri 2021-06-25 17:35:35 EET; 7s ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 4058 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 4058 (code=exited, status=1/FAILURE)  
CGroup: /system.slice/elasticsearch.service

Jun 25 17:35:33 [server.niledesign.com](http://server.niledesign.com) systemd-entrypoint[4058]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150)  
Jun 25 17:35:33 [server.niledesign.com](http://server.niledesign.com) systemd-entrypoint[4058]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAw...a:75)  
Jun 25 17:35:33 [server.niledesign.com](http://server.niledesign.com) systemd-entrypoint[4058]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:116)  
Jun 25 17:35:33 [server.niledesign.com](http://server.niledesign.com) systemd-entrypoint[4058]: at org.elasticsearch.cli.Command.main(Command.java:79)  
Jun 25 17:35:33 [server.niledesign.com](http://server.niledesign.com) systemd-entrypoint[4058]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)  
Jun 25 17:35:33 [server.niledesign.com](http://server.niledesign.com) systemd-entrypoint[4058]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81)  
Jun 25 17:35:35 [server.niledesign.com](http://server.niledesign.com) systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Jun 25 17:35:35 [server.niledesign.com](http://server.niledesign.com) systemd[1]: Failed to start Elasticsearch.  
Jun 25 17:35:35 [server.niledesign.com](http://server.niledesign.com) systemd[1]: Unit elasticsearch.service entered failed state.  
Jun 25 17:35:35 [server.niledesign.com](http://server.niledesign.com) systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

## [root@server bin]# journalctl -xe -- Support: [systemd-devel Info Page](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

## -- Unit user-0.slice has finished starting up.

## -- The start-up result is done. Jun 25 17:36:07 [server.niledesign.com](http://server.niledesign.com) systemd[1]: Started Session c887 of user root. -- Subject: Unit session-c887.scope has finished start-up -- Defined-By: systemd -- Support: [systemd-devel Info Page](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

## -- Unit session-c887.scope has finished starting up.

## -- The start-up result is done. Jun 25 17:36:07 [server.niledesign.com](http://server.niledesign.com) sudo[4431]: pam\_unix(sudo:session): session opened for user root by (uid=0) Jun 25 17:36:07 [server.niledesign.com](http://server.niledesign.com) sudo[4431]: pam\_unix(sudo:session): session closed for user root Jun 25 17:36:07 [server.niledesign.com](http://server.niledesign.com) systemd[1]: Removed slice User Slice of root. -- Subject: Unit user-0.slice has finished shutting down -- Defined-By: systemd -- Support: [systemd-devel Info Page](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

-- Unit user-0.slice has finished shutting down.  
Jun 25 17:36:20 [server.niledesign.com](http://server.niledesign.com) dovecot[3033]: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=44  
Jun 25 17:36:20 [server.niledesign.com](http://server.niledesign.com) dovecot[3033]: imap(cpanel-ccs)\<4440\>\<fHXF5pjFkOp/AAAB\>: Logged out in=50, out=871, bytes=50/871  
lines 3228-3250/3250 (END)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 28, 2021, 12:20am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/277086/2 "2021-06-28T00:20:36Z")

</div>

Welcome to our community! 😃  
Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

Can you check the actual Elasticsearch log, usually under `/var/log/elasticsearch`.

---

<div class="post-metadata">

**Author:** ![Fatma\_Alzahraa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fatma_alzahraa/32/78301_2.png) [@Fatma\_Alzahraa](https://discuss.elastic.co/u/Fatma_Alzahraa)\
**Post date:** [June 28, 2021, 10:37am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/277086/3 "2021-06-28T10:37:18Z")

</div>

Ok that's it

```auto
[root@server bin]# systemctl status elasticsearch.service
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2021-06-25 17:35:35 EET; 7s ago
Docs: https://www.elastic.co
Process: 4058 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
Main PID: 4058 (code=exited, status=1/FAILURE)
CGroup: /system.slice/elasticsearch.service

Jun 25 17:35:33 server.niledesign.com systemd-entrypoint[4058]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150)
Jun 25 17:35:33 server.niledesign.com systemd-entrypoint[4058]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAw...a:75)
Jun 25 17:35:33 server.niledesign.com systemd-entrypoint[4058]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:116)
Jun 25 17:35:33 server.niledesign.com systemd-entrypoint[4058]: at org.elasticsearch.cli.Command.main(Command.java:79)
Jun 25 17:35:33 server.niledesign.com systemd-entrypoint[4058]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)
Jun 25 17:35:33 server.niledesign.com systemd-entrypoint[4058]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81)
Jun 25 17:35:35 server.niledesign.com systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Jun 25 17:35:35 server.niledesign.com systemd[1]: Failed to start Elasticsearch.
Jun 25 17:35:35 server.niledesign.com systemd[1]: Unit elasticsearch.service entered failed state.
Jun 25 17:35:35 server.niledesign.com systemd[1]: elasticsearch.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

[root@server bin]# journalctl -xe
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Unit user-0.slice has finished starting up.
-- The start-up result is done.
Jun 25 17:36:07 server.niledesign.com systemd[1]: Started Session c887 of user root.
-- Subject: Unit session-c887.scope has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Unit session-c887.scope has finished starting up.
-- The start-up result is done.
Jun 25 17:36:07 server.niledesign.com sudo[4431]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jun 25 17:36:07 server.niledesign.com sudo[4431]: pam_unix(sudo:session): session closed for user root
Jun 25 17:36:07 server.niledesign.com systemd[1]: Removed slice User Slice of root.
-- Subject: Unit user-0.slice has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Unit user-0.slice has finished shutting down.
Jun 25 17:36:20 server.niledesign.com dovecot[3033]: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=44
Jun 25 17:36:20 server.niledesign.com dovecot[3033]: imap(cpanel-ccs)<4440><fHXF5pjFkOp/AAAB>: Logged out in=50, out=871, bytes=50/871
lines 3228-3250/3250 (END)

```

**and it's my elasticserach.log file**

```auto
unable to load JNA native support library, native methods will be disabled.
java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-283666080843830336/jna12813997667187646451.tmp: /tmp/elasticsearch-283666080843830336/jna12813997667187646451.tmp: failed to map segment from shared object: Operation not permitted
        at jdk.internal.loader.NativeLibraries.load(Native Method) ~[?:?]
        at jdk.internal.loader.NativeLibraries$NativeLibraryImpl.open(NativeLibraries.java:383) ~[?:?]
        at jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:227) ~[?:?]
        at jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:169) ~[?:?]
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:2407) ~[?:?]
        at java.lang.Runtime.load0(Runtime.java:747) ~[?:?]
        at java.lang.System.load(System.java:1857) ~[?:?]
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:1018) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:988) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:195) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:?]
        at java.lang.Class.forName(Class.java:377) ~[?:?]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:45) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:110) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.10.0.jar:7.10.0]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127) [elasticsearch-cli-7.10.0.jar:7.10.0]

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 26, 2021, 10:37am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/277086/4 "2021-07-26T10:37:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
