# Can't start Elasticsearch

**URL:** <https://discuss.elastic.co/t/cant-start-elasticsearch/75837>\
**Category:** Elasticsearch\
**Created:** [February 21, 2017, 8:42am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/75837 "2017-02-21T08:42:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Joel-Haeberli](https://avatars.discourse-cdn.com/v4/letter/j/cab0a1/32.png) [@Joel-Haeberli](https://discuss.elastic.co/u/Joel-Haeberli)\
**Post date:** [February 21, 2017, 8:42am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/75837/1 "2017-02-21T08:42:49Z")

</div>

Hey Guys

I'm currently building up a test environment for HPE ALM Octane for my company. This Application uses Elasticsearch. Now I have the problem, that I can't start my elasticsearchserver and I'm a bit at the end of my nerves ;).

Cause Octane works with elasticsearch version 2.4.0, I'm also forced to work with this version.

**I get the following Error:**

_elasticsearch.service - Elasticsearch_  
\_ Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)\_  
\_ Active: failed (Result: exit-code) since Tue 2017-02-21 09:40:50 CET; 1h 9min ago\_  
\_ Docs: http://www.elastic.co\_  
\_ Process: 954 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile=${PID\_DIR}/elasticsearch.pid -Des.default.path.home=${ES\_HOME} -Des.default.path.logs=${LOG\_DIR} -Des.default.path.data=${DATA\_DIR} -Des.default.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)\_  
\_ Process: 949 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)\_  
\_ Main PID: 954 (code=exited, status=1/FAILURE)\_

_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: at java.nio.file.Files.newInputStream(Files.java:152)_  
_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1067)_  
_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:88)_  
_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:218)_  
_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:257)_  
_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)_  
_Feb 21 09:40:50 linux-rfw5 elasticsearch[954]: Refer to the log for complete error details._  
_Feb 21 09:40:50 linux-rfw5 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE_  
_Feb 21 09:40:50 linux-rfw5 systemd[1]: elasticsearch.service: Unit entered failed state._  
_Feb 21 09:40:50 linux-rfw5 systemd[1]: elasticsearch.service: Failed with result 'exit-code'._

I configured the absolute minimum, that is possible. My Configurations:

1. elasticsearch.yml (/etc/elasticsearch/)  
1.1 [cluster.name](http://cluster.name): octane\_test  
1.2 [node.name](http://node.name): elasticNode  
1.3 network.host: 127.0.0.1 (yes localhost, cause I'm running the octane server on the same host)  
1.4 http.port: 9200
2. elasticsearch (/etc/sysconfig/)  
2.1 ES\_HEAP\_SIZE=4g (4 GB is 50% of the maximum memory)

I appreciate your help 😉  
Joel

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 21, 2017, 8:48am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/75837/2 "2017-02-21T08:48:41Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them 🙂

---

<div class="post-metadata">

**Author:** ![Joel-Haeberli](https://avatars.discourse-cdn.com/v4/letter/j/cab0a1/32.png) [@Joel-Haeberli](https://discuss.elastic.co/u/Joel-Haeberli)\
**Post date:** [February 21, 2017, 8:49am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/75837/3 "2017-02-21T08:49:30Z")

</div>

ok sry. I will post plain text

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 21, 2017, 8:49am UTC](https://discuss.elastic.co/t/cant-start-elasticsearch/75837/4 "2017-03-21T08:49:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
