# Cant Start Fresh Install of ES 5.0

**URL:** <https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360>\
**Category:** Elasticsearch\
**Created:** [October 30, 2016, 2:30am UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360 "2016-10-30T02:30:14Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [October 30, 2016, 2:30am UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/1 "2016-10-30T02:30:14Z")

</div>

I spun up a new VirtualBox VM and installed ES 5.0 from yum and when I try to start it I get an error stating:

"OpenJDK Server VM Warning: If the number of processors is expected to increase from one, then you should configure the number of parallel GC threads appropriately using XX:ParallelGCThreads=N

The service then appears to start after the warning but when I enter "service elasticsearch status" to see if it is actually running, I see "elasticsearch dead but subsys locked". I then removed the lock(?) file located at /var/lock/subsys/elasticsearch , stopped the service and restarted it and now see "elasticsearch dead but pid file exists".

After all that, I checked the elasticsearch.log and see an error stating "node validation exception bootstrap checks failed max number of threads [1024] for user [elasticsearch] likely too low, increase to at least [2048]".

How do I fix these issues? I did increase the size of RAM on my VM to 3GB thinking it might be a memory issue but that did not help. Any help that anyone might be able to provide would be appreciated. Thanks.

Kevin

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [October 30, 2016, 2:47am UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/2 "2016-10-30T02:47:05Z")

</div>

> [@krmathieu](#):
>
> OpenJDK Server VM Warning: If the number of processors is expected to increase from one, then you should configure the number of parallel GC threads appropriately using XX:ParallelGCThreads=N

You can read more about this [here](https://github.com/elastic/elasticsearch/pull/21063) and on the linked issues. Short version: it shouldn't hurt anything.

> [@krmathieu](#):
>
> node validation exception bootstrap checks failed max number of threads [1024] for user [elasticsearch] likely too low, increase to at least [2048]

This is the reason it refused to start. [This](https://www.elastic.co/guide/en/elasticsearch/reference/current/max-number-of-threads.html) documents increasing the limit.

---

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [October 30, 2016, 3:12am UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/3 "2016-10-30T03:12:52Z")

</div>

Thanks for the quick response. I will try again tomorrow and post an update.

---

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [October 30, 2016, 4:27pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/4 "2016-10-30T16:27:16Z")

</div>

Still having problems getting ES 5.0 up and running. Here is what I did:

1. Attempted to stop ES even though it probably was not actually running even though my service start returned an OK. I could not hit 9200 on localhost using curl or see it running as a process, that is why I don't think it was even running.

2. Ran ulimit -u 2048 to increase the number or threads.

3. Ran service elasticsearch start to start the service which returned OK.

4. Ran service elasticsearch status to make sure it was actually running and got a response back stating "elasticsearch dead but pid file exists".

5. Checked the elasticsearch.log file and noted that ES was still complaining about the number of threads and therefore failed node validation and closed the node.

6. Also noticed that I am seeing aperiodic errors stating:

" unable to install syscall filter:  
java.lang.UnsupportedOperationException: seccomp unavailable: requires kernel 3.5+ with CONFIG\_SECCOMP and CONFIG\_SECCOMP\_FILTER compiled in  
at org.elasticsearch.bootstrap.Seccomp.linuxImpl(Seccomp.java:349) ~[elasticsearch-5.0.0.jar:5.0.0]"

I am attempting to start the service as root, is that why I am seeing the error in item 6? Any help in getting ES 5.0 running that any one could provide would be appreciated. Thanks.

Kevin

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [October 30, 2016, 4:52pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/5 "2016-10-30T16:52:19Z")

</div>

The seccomp stuff just means you aren't getting as much security as we'd like. Most modern linux installs should have it despite the 3.5+ message. A lot of distros have backported it.

About the ulimit - I expect that is a thing you have to do for the Elasticsearch user rather than for your own user.

---

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [November 2, 2016, 2:06pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/6 "2016-11-02T14:06:52Z")

</div>

I am still in the same boat and not having any luck getting ES 5.0 up and running. I did do a full yum update to update CentOS, etc and that did not change anything so I am going to uninstall and reinstall and see if that helps.

---

<div class="post-metadata">

**Author:** ![nik9000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nik9000/32/44947_2.png) [@nik9000](https://discuss.elastic.co/u/nik9000)\
**Post date:** [November 2, 2016, 2:22pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/7 "2016-11-02T14:22:47Z")

</div>

I believe, the administrator, has to change that ulimit setting. The package doesn't do it for you.

I think [this link](https://www.elastic.co/guide/en/elasticsearch/reference/master/setting-system-settings.html#limits.conf) should help.

---

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [November 2, 2016, 2:36pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/8 "2016-11-02T14:36:20Z")

</div>

Ok, thanks. I will take another look.

---

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [November 3, 2016, 6:01pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/9 "2016-11-03T18:01:32Z")

</div>

Ok, I edited the /etc/security/limits.conf file to add the following entries to address the number of threads issue and set the max number of file handles and that appeared to address some of my previous issues:

elasticsearch - nproc 2048  
elasticsearch - nofile 65336

I then tried to su to the elasticsearch user and got an error stating "This account is currently not available" so I added the bash shell to the user. I then switched to the elasticsearch user and changed dir into /usr/share/elasticsearch /bin and tried to start the service manually and got this bootstrap exception:

NoSuchFileException: /usr/share/elasticsearch/config

I then created a symbolic link between /etc/elasticsearch and /usr/share/elasticsearch/config and now see the following issues when trying to start the service manually:

" Unable to install syscall filter: java.lang.UnsupportedException: seccomp unavailable: CONFIG\_SECCOMP not compiled into kernel, CONFIG\_SECCOMP and CONFIG\_SECCOMP\_FILTER are needed"

The service does appear to start and I can hit it from localhost but not a browser even though I set the network.host to my IP, but that is a separate issue. How do I fix the error above? I updated my CentOS to 6.8 and that did not resolve the issue. Understand earlier in the chain you seemed to indicate that this was more of an info than anything, but does it actually hurt anything??? Please advise. Thanks.

Kevin

---

<div class="post-metadata">

**Author:** ![rjof](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjof/32/13185_2.png) [@rjof](https://discuss.elastic.co/u/rjof)\
**Post date:** [November 15, 2016, 10:39pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/10 "2016-11-15T22:39:40Z")

</div>

Hi Kevin,  
Did you find a solution?. I'm in your painful track

---

<div class="post-metadata">

**Author:** ![krmathieu](https://avatars.discourse-cdn.com/v4/letter/k/b5e925/32.png) [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Post date:** [November 16, 2016, 6:00pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/12 "2016-11-16T18:00:09Z")

</div>

Hi Ricardo,

No, I have not resolved the Unable to Install Syscall Filter issue but it does not appear to be affecting anything. I now have ES 5.0 running as a service and it starts up automatically when I fire up the VM with no issues. Or, are you having problems starting ES 5.0 in general?

Kevin

---

<div class="post-metadata">

**Author:** ![nandan446](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nandan446/32/17464_2.png) [@nandan446](https://discuss.elastic.co/u/nandan446)\
**Post date:** [April 18, 2017, 3:55pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/14 "2017-04-18T15:55:34Z")

</div>

On my machine, it had to do with binding IP address in elasticsearch.yml file. I initially had network.host: 0.0.0.0, when I commented it out, the 'number of threads' error became a warning and Elasticsearch started up.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:01pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360/15 "2017-07-05T22:01:04Z")

</div>


