# Can't start service elasticsearch

**URL:** <https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570>\
**Category:** Elasticsearch\
**Created:** [September 14, 2017, 3:25pm UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570 "2017-09-14T15:25:27Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![TK\_CyberOne](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tk_cyberone/32/22119_2.png) [@TK\_CyberOne](https://discuss.elastic.co/u/TK_CyberOne)\
**Post date:** [September 14, 2017, 3:25pm UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/1 "2017-09-14T15:25:28Z")

</div>

[root@localhost ~]# systemctl status elasticsearch  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Fri 2017-09-15 05:20:41 ICT; 46ms ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 4336 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 4335 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 4336 (code=exited, status=1/FAILURE)

Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114)  
Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67)  
Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: at org.elasticsearch.cli.Command.main(Command.java:88)  
Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
Sep 15 05:20:41 localhost.localdomain elasticsearch[4336]: Refer to the log for complete error details.  
Sep 15 05:20:41 localhost.localdomain systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Sep 15 05:20:41 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 15 05:20:41 localhost.localdomain systemd[1]: elasticsearch.service failed.  
[root@localhost ~]#

---

<div class="post-metadata">

**Author:** ![mujtabahussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mujtabahussain/32/17514_2.png) [@mujtabahussain](https://discuss.elastic.co/u/mujtabahussain)\
**Post date:** [September 14, 2017, 9:56pm UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/2 "2017-09-14T21:56:31Z")

</div>

> [@TK\_CyberOne](#):
>
> ${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR}

Can you confirm that elastic has access to the directories referred to by these env variables:

- ${LOG\_DIR}
- ${DATA\_DIR}
- ${CONF\_DIR}

---

<div class="post-metadata">

**Author:** ![TK\_CyberOne](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tk_cyberone/32/22119_2.png) [@TK\_CyberOne](https://discuss.elastic.co/u/TK_CyberOne)\
**Post date:** [September 15, 2017, 8:08am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/3 "2017-09-15T08:08:35Z")

</div>

# Elasticsearch home directory

ES\_HOME=/usr/share/elasticsearch

# Elasticsearch Java path

JAVA\_HOME=/opt/jdk1.8.0\_141

# Elasticsearch configuration directory

CONF\_DIR=/etc/elasticsearch

# Elasticsearch data directory

DATA\_DIR=/var/lib/elasticsearch

# Elasticsearch logs directory

LOG\_DIR=/var/log/elasticsearch

# Elasticsearch PID directory

PID\_DIR=/var/run/elasticsearch

# Additional Java OPTS

ES\_JAVA\_OPTS="${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR}"

# Configure restart on package upgrade (true, every other setting will lead to not restarting)

#RESTART\_ON\_UPGRADE=true

===========================================================================

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Fri 2017-09-15 22:07:01 ICT; 728ms ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2865 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 2864 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 2865 (code=exited, status=1/FAILURE)  
hi thank you for answer new error below

Sep 15 22:07:00 localhost.localdomain systemd[1]: Starting Elasticsearch...  
Sep 15 22:07:00 localhost.localdomain systemd[1]: Started Elasticsearch.  
Sep 15 22:07:01 localhost.localdomain elasticsearch[2865]: Error: Could not find or load main class ${LOG\_DIR}  
Sep 15 22:07:01 localhost.localdomain systemd[1]: elasticsearch.service: main process exited, code=exited, status=...ILURE  
Sep 15 22:07:01 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 15 22:07:01 localhost.localdomain systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

---

<div class="post-metadata">

**Author:** ![Ravi\_Shanker\_Reddy](https://avatars.discourse-cdn.com/v4/letter/r/a5b964/32.png) [@Ravi\_Shanker\_Reddy](https://discuss.elastic.co/u/Ravi_Shanker_Reddy)\
**Post date:** [September 15, 2017, 8:55am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/4 "2017-09-15T08:55:10Z")

</div>

Try to create all the paths manually. Check your config (elasticsearch.yml) once. Even if it is not able to start try to run it as a process.

---

<div class="post-metadata">

**Author:** ![poojagupta](https://avatars.discourse-cdn.com/v4/letter/p/5daacb/32.png) [@poojagupta](https://discuss.elastic.co/u/poojagupta)\
**Post date:** [September 18, 2017, 9:48am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/5 "2017-09-18T09:48:52Z")

</div>

have you done any configuration changes in elasticsearch.yml file?  
on which version you are working?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 18, 2017, 9:51am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/6 "2017-09-18T09:51:33Z")

</div>

Is there anything in the Elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![poojagupta](https://avatars.discourse-cdn.com/v4/letter/p/5daacb/32.png) [@poojagupta](https://discuss.elastic.co/u/poojagupta)\
**Post date:** [September 20, 2017, 4:30am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/7 "2017-09-20T04:30:04Z")

</div>

@TK_CyberOne  
seems that there is some configuration issue.  
please share your configuration file . is there changes you have done in this file?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 18, 2017, 4:30am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/8 "2017-10-18T04:30:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
