# Can't start service elasticsearch

**URL:** <https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570>\
**Category:** Elasticsearch\
**Created:** [September 14, 2017, 3:25pm UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570 "2017-09-14T15:25:27Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![TK\_CyberOne](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tk_cyberone/32/22119_2.png) [@TK\_CyberOne](https://discuss.elastic.co/u/TK_CyberOne)\
**Post date:** [September 15, 2017, 8:08am UTC](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570/3 "2017-09-15T08:08:35Z")

</div>

# Elasticsearch home directory

ES\_HOME=/usr/share/elasticsearch

# Elasticsearch Java path

JAVA\_HOME=/opt/jdk1.8.0\_141

# Elasticsearch configuration directory

CONF\_DIR=/etc/elasticsearch

# Elasticsearch data directory

DATA\_DIR=/var/lib/elasticsearch

# Elasticsearch logs directory

LOG\_DIR=/var/log/elasticsearch

# Elasticsearch PID directory

PID\_DIR=/var/run/elasticsearch

# Additional Java OPTS

ES\_JAVA\_OPTS="${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR}"

# Configure restart on package upgrade (true, every other setting will lead to not restarting)

#RESTART\_ON\_UPGRADE=true

===========================================================================

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Fri 2017-09-15 22:07:01 ICT; 728ms ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2865 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 2864 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 2865 (code=exited, status=1/FAILURE)  
hi thank you for answer new error below

Sep 15 22:07:00 localhost.localdomain systemd[1]: Starting Elasticsearch...  
Sep 15 22:07:00 localhost.localdomain systemd[1]: Started Elasticsearch.  
Sep 15 22:07:01 localhost.localdomain elasticsearch[2865]: Error: Could not find or load main class ${LOG\_DIR}  
Sep 15 22:07:01 localhost.localdomain systemd[1]: elasticsearch.service: main process exited, code=exited, status=...ILURE  
Sep 15 22:07:01 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 15 22:07:01 localhost.localdomain systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

---

_[View the full topic](https://discuss.elastic.co/t/cant-start-service-elasticsearch/100570)._
