# Cant stream data from client node to ES after upgrade to 2.1

**URL:** <https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391>\
**Category:** Elasticsearch\
**Created:** [January 5, 2016, 10:31am UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391 "2016-01-05T10:31:47Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![andreynikk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andreynikk/32/6873_2.png) [@andreynikk](https://discuss.elastic.co/u/andreynikk)\
**Post date:** [January 5, 2016, 10:31am UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391/1 "2016-01-05T10:31:47Z")

</div>

Hi,

we are testing an upgrade to 2.1 and managed to successfully install ES 2.1 with kibana, all the plugins we use, and created a few mock indexes to store the data we receive from the client nodes (we use the same scripts as in 1.7.2 and the indexes were created successfully).  
we are using ES bulk API for the inserts, but when redirecting the data stream to the new cluster it fails to insert the data.  
the client nodes version is 1.7.2.

we get the following errors from client node log:  
2016-01-05 01:12:33,022 worker #15} WARN org.elasticsearch.transport.netty:messageReceived():140 [XX\_streamer] Message not fully read (response) for [254] handler org.elasticsearch.discovery.zen.ping.unicast.UnicastZenPing$4@60e024ad, error [true], resetting  
2016-01-05 01:12:33,024 worker #16} WARN org.elasticsearch.discovery.zen.ping.unicast:handleException():460 [XX\_streamer] failed to send ping to [[#zen\_unicast\_1#][[XX.com](http://XX.com)][inet[[XX.com/XX:9302](http://XX.com/XX:9302)]]]  
org.elasticsearch.transport.RemoteTransportException: Failed to deserialize exception response from stream  
Caused by: org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream  
at org.elasticsearch.transport.netty.MessageChannelHandler.handlerResponseError(MessageChannelHandler.java:178)

bulk processor log:  
2016-01-05 01:08:13,823 main INFO es\_bulk\_processor:connectClient():91 Trying to setup ES client  
2016-01-05 01:08:47,605 main INFO es\_bulk\_processor:connectClient():105 Client connected  
2016-01-05 01:08:47,606 main INFO es\_bulk\_processor:():63 Creating bulk processor  
2016-01-05 01:09:48,421 tener][T#1] ERROR es\_bulk\_processor:afterBulk():79 Failure after bulk,executionId:1  
org.elasticsearch.cluster.block.ClusterBlockException: blocked by: [SERVICE\_UNAVAILABLE/1/state not recovered / initialized];[SERVICE\_UNAVAILABLE/2/no master];  
at org.elasticsearch.cluster.block.ClusterBlocks.globalBlockedException(ClusterBlocks.java:151)  
at org.elasticsearch.cluster.block.ClusterBlocks.globalBlockedRaiseException(ClusterBlocks.java:141)  
at org.elasticsearch.action.bulk.TransportBulkAction.executeBulk(TransportBulkAction.java:215)  
at org.elasticsearch.action.bulk.TransportBulkAction.access$000(TransportBulkAction.java:67)  
at org.elasticsearch.action.bulk.TransportBulkAction$1.onFailure(TransportBulkAction.java:153)  
at org.elasticsearch.action.support.TransportAction$ThreadedActionListener$2.run(TransportAction.java:137)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
at java.lang.Thread.run(Unknown Source)

no errors in ES logs.

so the first question, is it even possible to stream data from 1.7.2 client node to 2.1 ES cluster?  
regarding the errors, it throws discovery errors event though i updated the unicast.hosts with the host and port of the client node, and the bulk log indicates that it connected to the cluster but cant insert.

any insight on the issues above would be welcome.

Thanks!

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 5, 2016, 10:43am UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391/2 "2016-01-05T10:43:16Z")

</div>

> So the first question, is it even possible to stream data from 1.7.2 client node to 2.1 ES cluster?

No

---

<div class="post-metadata">

**Author:** ![andreynikk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andreynikk/32/6873_2.png) [@andreynikk](https://discuss.elastic.co/u/andreynikk)\
**Post date:** [January 5, 2016, 10:54am UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391/3 "2016-01-05T10:54:04Z")

</div>

OK then, i will upgrade the client nodes as well and test again.

thanks for the fast reply.

---

<div class="post-metadata">

**Author:** ![andreynikk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andreynikk/32/6873_2.png) [@andreynikk](https://discuss.elastic.co/u/andreynikk)\
**Post date:** [January 6, 2016, 12:35pm UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391/4 "2016-01-06T12:35:55Z")

</div>

@dadoonet i have another question.

can 2.1 client node stream data to 1.7.2 cluster?  
or both of them need to be upgraded together?

Thanks.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [January 6, 2016, 1:19pm UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391/5 "2016-01-06T13:19:23Z")

</div>

No it can't. 2.x can't speak with 1.x. And 1.x can't speak with 2.x.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:26pm UTC](https://discuss.elastic.co/t/cant-stream-data-from-client-node-to-es-after-upgrade-to-2-1/38391/6 "2017-07-05T23:26:43Z")

</div>


