# Caught error spawning Chromium - Generate PDF Error

**URL:** <https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390>\
**Category:** Kibana\
**Tags:** elastic-stack-reporting\
**Created:** [December 11, 2018, 1:51pm UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390 "2018-12-11T13:51:29Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![avais](https://avatars.discourse-cdn.com/v4/letter/a/f08c70/32.png) [@avais](https://discuss.elastic.co/u/avais)\
**Post date:** [December 11, 2018, 1:51pm UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/1 "2018-12-11T13:51:29Z")

</div>

Hi Community,  
Kibana version : 6.5.1 hosted in docker container (the whole stack is in docker container)  
When I am trying to 'generate pdf' from 'share' option in dashboard :  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/1/210e26515cf395c5566de702094b14e7c0b958d6.png)

I am getting the following error :  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/c/6c596cd73c468d5e857062ef8729315c54fc410c.png)

Verbose logging on kibana gives this log trace:

```
 log [13:40:03.235] [debug][reporting][worker] PDF: Processing PDF job
  log [13:40:03.282] [debug][reporting][screenshots] Creating browser driver factory
  log [13:40:03.357] [esqueue][reporting][warn][worker] jpjsliv200lw28d97a3mvr5c - Failure occurred on job jpjsmah100lw28d97a02hf4w: Error: Caught error spawning Chromium
    at Observable.Rx.Observable.create [as _subscribe] (/opt/kibana/node_modules/x-pack/plugins/reporting/server/browsers/chromium/driver_factory/index.js:56:24)
    at <anonymous>
    at process._tickDomainCallback (internal/process/next_tick.js:228:7)
  log [13:40:03.359] [debug][reporting][worker] PDF: Worker error: (jpjsmah100lw28d97a02hf4w)
  log [13:40:03.360] [esqueue][reporting][warn][worker] jpjsliv200lw28d97a3mvr5c - Failing job jpjsmah100lw28d97a02hf4w
  log [13:40:04.074] [debug][plugin] Checking Elasticsearch version

```

Permissions on headless\_shell binary (data folder):  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/0/402dcdb9b99a32c71d03df4d6924238c1b53b762.png)

Any ideas?

Thanks

---

<div class="post-metadata">

**Author:** ![dao](https://avatars.discourse-cdn.com/v4/letter/d/a6a055/32.png) [@dao](https://discuss.elastic.co/u/dao)\
**Post date:** [December 12, 2018, 1:30pm UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/2 "2018-12-12T13:30:30Z")

</div>

same issue, interested in the answer !

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [December 12, 2018, 9:16pm UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/3 "2018-12-12T21:16:06Z")

</div>

@tsullivan can you please have a look here? thanks!

---

<div class="post-metadata">

**Author:** ![dao](https://avatars.discourse-cdn.com/v4/letter/d/a6a055/32.png) [@dao](https://discuss.elastic.co/u/dao)\
**Post date:** [December 19, 2018, 10:32am UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/4 "2018-12-19T10:32:19Z")

</div>

Hello, I still have the problem, even if my KIBANA is not in a docker. Here is the whole picture: kibana.yml, kibana.logs. I have recorded the whole logs in the server and the HAR in my browser, but cannot send it in the discuss (body too large). I have just appended `grep -i reportin kibana.log | grep -v debug`

```auto
root@int:~# cat /etc/kibana/kibana.yml | grep -v ^# | grep -v ^$
elasticsearch.url: "https://44ddXXXXXXd3c012baa1dc4.eu-west-1.aws.found.io:9243"
kibana.index: .kibana-int
elasticsearch.username: "XXXXX"
elasticsearch.password: "XXXXXX"
logging.dest: /var/log/kibana/kibana.log
logging.verbose: true
xpack.reporting.encryptionKey: "ZHDFEBHAIJOXXXXXMO682351279"
xpack.reporting.kibanaServer.port: 443
xpack.reporting.kibanaServer.protocol: https
xpack.reporting.kibanaServer.hostname: "int.flightwatching.com"
xpack.reporting.index: ".reporting-int"

```

```auto
{"type":"response","@timestamp":"2018-12-17T08:13:18Z","tags":[],"pid":7072,"method":"post","statusCode":200,"req":{"url":"/api/reporting/generate/printablePdf?jobParams=...
{"type":"log","@timestamp":"2018-12-17T08:13:19Z","tags":["trace","legacy","service"],"pid":7072,"message":"Request will be handled by proxy GET:/api/reporting/jobs/list?page=0&ids=jps1l7oh05ggf4f1af3pnefc."}
{"type":"log","@timestamp":"2018-12-17T08:13:20Z","tags":["reporting","esqueue","worker","warn"],"pid":7072,"message":"jps1iru105ggf4f1af688tyb - Failure occurred on job jps1l7oh05ggf4f1af3pnefc: Error: Caught error spawning Chromium\n at Observable.Rx.Observable.create [as _subscribe] (/usr/share/kibana/node_modules/x-pack/plugins/reporting/server/browsers/chromium/driver_factory/index.js:56:24)\n at <anonymous>\n at process._tickDomainCallback (internal/process/next_tick.js:228:7)"}
{"type":"log","@timestamp":"2018-12-17T08:13:20Z","tags":["reporting","esqueue","worker","warn"],"pid":7072,"message":"jps1iru105ggf4f1af688tyb - Failing job jps1l7oh05ggf4f1af3pnefc"}
{"type":"response","@timestamp":"2018-12-17T08:13:19Z","tags":[],"pid":7072,"method":"get","statusCode":200,"req":{"url":"/api/reporting/jobs/list?page=0&ids=jps1l7oh05ggf4f1af3pnefc","method":"get","headers":{"connection":"upgrade","host":"int.flightwatching.com","kbn-system-api":"true","kbn-version":"6.5.1","user-agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36","content-type":"application/json","accept":"*/*","referer":"https://int.flightwatching.com/app/kibana","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9,fr;q=0.8"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"https://int.flightwatching.com/app/kibana"},"res":{"statusCode":200,"responseTime":240,"contentLength":9},"message":"GET /api/reporting/jobs/list?page=0&ids=jps1l7oh05ggf4f1af3pnefc 200 240ms - 9.0B"}
{"type":"log","@timestamp":"2018-12-17T08:13:30Z","tags":["trace","legacy","service"],"pid":7072,"message":"Request will be handled by proxy GET:/api/reporting/jobs/list?page=0&ids=jps1l7oh05ggf4f1af3pnefc."}
{"type":"response","@timestamp":"2018-12-17T08:13:30Z","tags":[],"pid":7072,"method":"get","statusCode":200,"req":{"url":"/api/reporting/jobs/list?page=0&ids=jps1l7oh05ggf4f1af3pnefc","method":"get","headers":{"connection":"upgrade","host":"int.flightwatching.com","kbn-system-api":"true","kbn-version":"6.5.1","user-agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36","content-type":"application/json","accept":"*/*","referer":"https://int.flightwatching.com/app/kibana","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9,fr;q=0.8"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"https://int.flightwatching.com/app/kibana"},"res":{"statusCode":200,"responseTime":157,"contentLength":9},"message":"GET /api/reporting/jobs/list?page=0&ids=jps1l7oh05ggf4f1af3pnefc 200 157ms - 9.0B"}
{"type":"log","@timestamp":"2018-12-17T08:13:30Z","tags":["trace","legacy","service"],"pid":7072,"message":"Request will be handled by proxy GET:/api/reporting/jobs/output/jps1l7oh05ggf4f1af3pnefc."}
{"type":"response","@timestamp":"2018-12-17T08:13:30Z","tags":[],"pid":7072,"method":"get","statusCode":200,"req":{"url":"/api/reporting/jobs/output/jps1l7oh05ggf4f1af3pnefc","method":"get","headers":{"connection":"upgrade","host":"int.flightwatching.com","kbn-system-api":"true","kbn-version":"6.5.1","user-agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36","content-type":"application/json","accept":"*/*","referer":"https://int.flightwatching.com/app/kibana","accept-encoding":"gzip, deflate, br","accept-language":"en-US,en;q=0.9,fr;q=0.8"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"https://int.flightwatching.com/app/kibana"},"res":{"statusCode":200,"responseTime":206,"contentLength":9},"message":"GET /api/reporting/jobs/output/jps1l7oh05ggf4f1af3pnefc 200 206ms - 9.0B"}

```

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [January 8, 2019, 6:37pm UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/5 "2019-01-08T18:37:44Z")

</div>

Hi, to start, take a look at the troubleshooting guide here: [https://github.com/GoogleChrome/puppeteer/blob/master/docs/troubleshooting.md](https://github.com/GoogleChrome/puppeteer/blob/master/docs/troubleshooting.md). You can try the first step of testing with `ldd` by using the chromium executable that Kibana provides:

```auto
ldd /kibana_directory/data/headless_shell-linux/headless_shell | grep not

```

---

<div class="post-metadata">

**Author:** ![dao](https://avatars.discourse-cdn.com/v4/letter/d/a6a055/32.png) [@dao](https://discuss.elastic.co/u/dao)\
**Post date:** [January 9, 2019, 7:20am UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/6 "2019-01-09T07:20:07Z")

</div>

I found the solution: here is the thread for that: [[kibana 6.5.1] Reporting fails with elasticcloud endpoint (but not elasticsearch selfhosted)](https://discuss.elastic.co/t/kibana-6-5-1-reporting-fails-with-elasticcloud-endpoint-but-not-elasticsearch-selfhosted/162516?u=dao)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 6, 2019, 7:20am UTC](https://discuss.elastic.co/t/caught-error-spawning-chromium-generate-pdf-error/160390/7 "2019-02-06T07:20:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
