# Caused by: org.apache.hadoop.hive.ql.metadata.HiveException: Hive Runtime Error while processing row {

**URL:** <https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [March 22, 2018, 11:14pm UTC](https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281 "2018-03-22T23:14:36Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![naresh523](https://avatars.discourse-cdn.com/v4/letter/n/e480ec/32.png) [@naresh523](https://discuss.elastic.co/u/naresh523)\
**Post date:** [March 22, 2018, 11:14pm UTC](https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281/1 "2018-03-22T23:14:36Z")

</div>

Table B has ~60millions records.  
Elastic Search Hive Insert into table A query from Table B;  
failed with below error.

Caused by: org.elasticsearch.hadoop.rest.EsHadoopNoNodesLeftException: Connection error (check network and/or proxy settings)- all nodes failed;  
at org.elasticsearch.hadoop.rest.NetworkClient.execute(NetworkClient.java:149)  
at org.elasticsearch.hadoop.rest.RestClient.execute(RestClient.java:466)  
at org.elasticsearch.hadoop.rest.RestClient.execute(RestClient.java:450)  
at org.elasticsearch.hadoop.rest.RestClient.bulk(RestClient.java:186)  
at org.elasticsearch.hadoop.rest.RestRepository.tryFlush(RestRepository.java:248)  
at org.elasticsearch.hadoop.rest.RestRepository.flush(RestRepository.java:270)  
at org.elasticsearch.hadoop.rest.RestRepository.doWriteToIndex(RestRepository.java:224)  
at org.elasticsearch.hadoop.rest.RestRepository.writeProcessedToIndex(RestRepository.java:202)  
at org.elasticsearch.hadoop.hive.EsHiveOutputFormat$EsHiveRecordWriter.write(EsHiveOutputFormat.java:63)  
at org.apache.hadoop.hive.ql.exec.FileSinkOperator.process(FileSinkOperator.java:763)  
at org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:841)  
at org.apache.hadoop.hive.ql.exec.SelectOperator.process(SelectOperator.java:88)  
at org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:841)  
at org.apache.hadoop.hive.ql.exec.TableScanOperator.process(TableScanOperator.java:133)  
at org.apache.hadoop.hive.ql.exec.MapOperator$MapOpCtx.forward(MapOperator.java:170)  
at org.apache.hadoop.hive.ql.exec.MapOperator.process(MapOperator.java:555)

Elastic Search Version:  
6.1.2

---

<div class="post-metadata">

**Author:** ![james.baiera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james.baiera/32/10209_2.png) [@james.baiera](https://discuss.elastic.co/u/james.baiera)\
**Post date:** [March 22, 2018, 11:36pm UTC](https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281/2 "2018-03-22T23:36:51Z")

</div>

The error should be self describing here: `Connection error (check network and/or proxy settings)- all nodes failed;` means that you had a connection error to Elasticsearch and had no more nodes to fallback to. If you increase the logging level, there should be more information about why the connection failed.

---

<div class="post-metadata">

**Author:** ![naresh523](https://avatars.discourse-cdn.com/v4/letter/n/e480ec/32.png) [@naresh523](https://discuss.elastic.co/u/naresh523)\
**Post date:** [March 23, 2018, 5:18pm UTC](https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281/3 "2018-03-23T17:18:50Z")

</div>

Yes, it is true..  
What would be efficient way to insert new rows from hive\_table to elasticsearch table?  
The Hive table is getting bigger & bigger with insert into elasticsearch table it is erroring out with above exception.

---

<div class="post-metadata">

**Author:** ![james.baiera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james.baiera/32/10209_2.png) [@james.baiera](https://discuss.elastic.co/u/james.baiera)\
**Post date:** [March 23, 2018, 8:25pm UTC](https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281/4 "2018-03-23T20:25:30Z")

</div>

The first course of action that I would advise is getting to the root of why the connector is failing out. If it's a pretty straightforward problem to fix, then you've got a good path forward. If it's more complex, then it might be worth examining changing your usage patterns. I would suggest running the job with logging bumped up to `DEBUG` to see what falls out in the logs.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 20, 2018, 8:25pm UTC](https://discuss.elastic.co/t/caused-by-org-apache-hadoop-hive-ql-metadata-hiveexception-hive-runtime-error-while-processing-row/125281/5 "2018-04-20T20:25:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
