# Caused by: org.elasticsearch.action.search.SearchPhaseExecutionException

**URL:** https://discuss.elastic.co/t/caused-by-org-elasticsearch-action-search-searchphaseexecutionexception/282914
**Category:** Kibana
**Created:** [August 31, 2021, 12:08pm UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-action-search-searchphaseexecutionexception/282914 "2021-08-31T12:08:13Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Pradeep\_Patil](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pradeep_patil/32/78648_2.png) [@Pradeep\_Patil](https://discuss.elastic.co/u/Pradeep_Patil)
#### Post date: [August 31, 2021, 12:08pm UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-action-search-searchphaseexecutionexception/282914/1 "2021-08-31T12:08:13Z")

</div>

**Caused by: org.elasticsearch.action.search.SearchPhaseExecutionException: Search rejected due to missing shards [[.kibana\_task\_manager\_7.14.0\_001][0]]. Consider using `allow_partial_search_results` setting to bypass this error**.",

Hi All,

Above error we are getting.  
Envrionment details:  
ElasticSearch deployed as standalone pod in Kubernetes  
Kibana deployed as standalone pod in Kubernetes

We have tried with both 7.14 and 7.12 version.

The data gets ingestion in ElasticSearch and we are able to also view in Kibana but after few hours above mentioned error we get and then Kibana goes down.

We have also tried 'allow\_partial\_search\_results', setting to True and False both the ways as by default its True, but still its not working.

We also have tried restarting pods/redeployments but everytime it works for few hours and then in logs we get the above mentioned error.  
Any suggestion would be of great help.

Regards,  
Pradeep

---

<div class="post-metadata">

### Author: ![lukas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas/32/6812_2.png) [@lukas](https://discuss.elastic.co/u/lukas)
#### Post date: [August 31, 2021, 7:12pm UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-action-search-searchphaseexecutionexception/282914/2 "2021-08-31T19:12:09Z")

</div>

Is that an error you're seeing in the logs or in the Kibana UI?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 28, 2021, 7:12pm UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-action-search-searchphaseexecutionexception/282914/3 "2021-09-28T19:12:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
