# Caused by: org.elasticsearch.ElasticsearchSecurityException: missing authentication token for action \[internal:transport/handshake\]

**URL:** <https://discuss.elastic.co/t/caused-by-org-elasticsearch-elasticsearchsecurityexception-missing-authentication-token-for-action-internal-transport-handshake/148758>\
**Category:** Elasticsearch\
**Created:** [September 17, 2018, 4:52am UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-elasticsearchsecurityexception-missing-authentication-token-for-action-internal-transport-handshake/148758 "2018-09-17T04:52:42Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![vschakka](https://avatars.discourse-cdn.com/v4/letter/v/d07c76/32.png) [@vschakka](https://discuss.elastic.co/u/vschakka)\
**Post date:** [September 17, 2018, 4:52am UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-elasticsearchsecurityexception-missing-authentication-token-for-action-internal-transport-handshake/148758/1 "2018-09-17T04:52:43Z")

</div>

Hi ,  
Recently I upgraded elastic, logstash and kibana to 6.4.0 from 6.2.x. After restarting es nodes and tribe, getting below exception. Due to which sync is not happening resulting to stopping indexing. I disabled xpack.security.enabled : false in all nodes. Before installing 6.4.0 i deleted old elasticsearch.keystore and new one got generated automatically while starting up the server. Please someone help here what security/authentication configurations are required.

Exception stack trace

```
[2018-09-14T10:42:34,581][WARN][o.e.c.NodeConnectionsService] [prod_90_01] failed to connect to node {prod_tribe_02_01/t1}{uWwnGOoPTxGVnvXYLMxOVA}{gi6CELwVRyS6z2GsYk66pQ}{xxxx90.corp.xxxx.com}{10.192.169.92:9300}{xpack.installed=true} (tried [1] times)
org.elasticsearch.transport.ConnectTransportException: [prod_tribe___02_01/t1][10.192.169.92:9300] general node connection failure
    at org.elasticsearch.transport.TcpTransport.connectToNode(TcpTransport.java:571) ~[elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:329) ~[elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:316) ~[elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.cluster.NodeConnectionsService.validateAndConnectIfNeeded(NodeConnectionsService.java:153) [elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.cluster.NodeConnectionsService$1.doRun(NodeConnectionsService.java:106) [elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:723) [elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.4.0.jar:6.4.0]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_171]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_171]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_171]
Caused by: java.lang.IllegalStateException: handshake failed with {prod_tribe___02_01/t1}{uWwnGOoPTxGVnvXYLMxOVA}{gi6CELwVRyS6z2GsYk66pQ}{xxxx90.corp.xxxx.com}{10.192.169.92:9300}{xpack.installed=true}
    at org.elasticsearch.transport.TransportService.handshake(TransportService.java:400) ~[elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.transport.TransportService.lambda$connectToNode$4(TransportService.java:331) ~[elasticsearch-6.4.0.jar:6.4.0]
    at org.elasticsearch.transport.TcpTransport.connectToNode(TcpTransport.java:543) ~[elasticsearch-6.4.0.jar:6.4.0]
    ... 9 more
Caused by: org.elasticsearch.transport.RemoteTransportException: [prod_tribe___02_01/t1][10.192.169.92:9300][internal:transport/handshake]
Caused by: org.elasticsearch.ElasticsearchSecurityException: missing authentication token for action [internal:transport/handshake]
    at org.elasticsearch.xpack.core.security.support.Exceptions.authenticationError(Exceptions.java:18) ~[?:?]
    at org.elasticsearch.xpack.core.security.authc.DefaultAuthenticationFailureHandler.createAuthenticationError(DefaultAuthenticationFailureHandler.java:129) ~[?:?]
    at org.elasticsearch.xpack.core.security.authc.DefaultAuthenticationFailureHandler.missingToken(DefaultAuthenticationFailureHandler.java:84) ~[?:?]
    at org.elasticsearch.xpack.security.authc.AuthenticationService$AuditableTransportRequest.anonymousAccessDenied(AuthenticationService.java:526) ~[?:?]
    at org.elasticsearch.xpack.security.authc.AuthenticationService$Authenticator.lambda$handleNullToken$17(AuthenticationService.java:337) ~[?:?]
    at org.elasticsearch.xpack.security.authc.AuthenticationService$Authenticator.handleNullToken(AuthenticationService.java:342) ~[?:?]
    at org.elasticsearch.xpack.security.authc.AuthenticationService$Authenticator.consumeToken(AuthenticationService.java:255) ~[?:?]
```

---

<div class="post-metadata">

**Author:** ![vschakka](https://avatars.discourse-cdn.com/v4/letter/v/d07c76/32.png) [@vschakka](https://discuss.elastic.co/u/vschakka)\
**Post date:** [September 17, 2018, 9:59am UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-elasticsearchsecurityexception-missing-authentication-token-for-action-internal-transport-handshake/148758/2 "2018-09-17T09:59:04Z")

</div>

I got the solution for this. Thanks.

Here is what i did:  
In tribe node , earlier I kept only xpack.security.enabled, but I need to give two settings like below. I don't know the reason, if not given both settings, then again getting exception as xpack.security.enabled is madatory.

`tribe.t1.xpack.security.enabled: false`  
`xpack.security.enabled: false`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 15, 2018, 9:59am UTC](https://discuss.elastic.co/t/caused-by-org-elasticsearch-elasticsearchsecurityexception-missing-authentication-token-for-action-internal-transport-handshake/148758/3 "2018-10-15T09:59:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
