# Ccs\_minimize\_roundtrips error when using 7.X high level REST API to access 6.x index

**URL:** <https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095>\
**Category:** Elasticsearch\
**Created:** [August 6, 2019, 8:06pm UTC](https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095 "2019-08-06T20:06:11Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![iti](https://avatars.discourse-cdn.com/v4/letter/i/b19c9b/32.png) [@iti](https://discuss.elastic.co/u/iti)\
**Post date:** [August 6, 2019, 8:06pm UTC](https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095/1 "2019-08-06T20:06:11Z")

</div>

I am using Elastic Search High Level REST API 7.x and try to access ES 6.7 index and go the following error:  
ElasticsearchStatusException[Elasticsearch exception [type=illegal\_argument\_exception, reason=request [xxxxxxxx] contains unrecognized parameter: [ccs\_minimize\_roundtrips]]]  
If I downgrade the API to 6.x, then the error disappears. The problem is that I have to access both 7.x and 6.x index using the REST API. So, ideally, using 7.x API should be backward compatible with 6.x. But this is not the case. Is there any concern using 6.8.1 API to access 7.x ES index?

Any advise is appreciated.

---

<div class="post-metadata">

**Author:** ![javanna](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/javanna/32/4698_2.png) [@javanna](https://discuss.elastic.co/u/javanna)\
**Post date:** [August 9, 2019, 11:39am UTC](https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095/2 "2019-08-09T11:39:12Z")

</div>

Hello,  
our high-level REST client is forward compatible, meaning that you can use a 6.x client against 7.x nodes. But once you use the 7.x client, is will use the options that are known to be supported on 7.x nodes. If you want to talk both to 6.x and 7.x using the same client, you should use the 6.x high-level client. The downside of this is that you are giving up on any new feature that 7.x may support (like minimizing roundtrips in CCS for instance).

Also, we recommend when upgrading to upgrade the client last.

This is all mentioned in our docs here: [https://www.elastic.co/guide/en/elasticsearch/client/java-rest/master/java-rest-high-compatibility.html](https://www.elastic.co/guide/en/elasticsearch/client/java-rest/master/java-rest-high-compatibility.html) .

---

<div class="post-metadata">

**Author:** ![iti](https://avatars.discourse-cdn.com/v4/letter/i/b19c9b/32.png) [@iti](https://discuss.elastic.co/u/iti)\
**Post date:** [August 9, 2019, 6:18pm UTC](https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095/3 "2019-08-09T18:18:50Z")

</div>

Thanks Luca.  
I am using 6.8 REST API with 7.2 ES lib now. But got another error which reported on

> [@java.lang.ClassNotFoundException: org.elasticsearch.search.aggregations.metrics.cardinality.ParsedCardinality](https://discuss.elastic.co/t/java-lang-classnotfoundexception-org-elasticsearch-search-aggregations-metrics-cardinality-parsedcardinality/194304):
>
> My environment: two ES clusters: one ES 6.7 and one ES 7.1 My app need to use High Level REST Client to access both cluster at the same time. When I am using 7.x REST CLIENT with 7.X ES library. When accessing 6.x ES, I got [Ccs\_minimize\_roundtrips error when using 7.X high level REST API to access 6.x index](https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095) When I am using 6.x REST CLient with 7.X ES, when accessing 7.x ES,I got java.lang.ClassNotFoundException: org.elasticsearch.search.aggregations.metrics.cardinality.ParsedCardinality sinc…

Any advice? Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 6, 2019, 6:18pm UTC](https://discuss.elastic.co/t/ccs-minimize-roundtrips-error-when-using-7-x-high-level-rest-api-to-access-6-x-index/194095/4 "2019-09-06T18:18:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
