# CDI injected/managed TransportClient fails in ElasticSearch 5.3

**URL:** <https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666>\
**Category:** Elasticsearch\
**Created:** [April 7, 2017, 9:05pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666 "2017-04-07T21:05:50Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![etay2000](https://avatars.discourse-cdn.com/v4/letter/e/439d5e/32.png) [@etay2000](https://discuss.elastic.co/u/etay2000)\
**Post date:** [April 7, 2017, 9:05pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/1 "2017-04-07T21:05:50Z")

</div>

Is using CDI to inject and manage the creation of TransportClient instances supported in 5.3? In 5.2.2 I was able to use a CDI producer method to @Inject a PreBuiltTransportClient instance with no issues. As of 5.3 this blows up with:

> Caused by: java.lang.ExceptionInInitializerError  
> at org.elasticsearch.common.logging.DeprecationLogger.(DeprecationLogger.java:138)  
> at org.elasticsearch.common.xcontent.support.AbstractXContentParser.(AbstractXContentParser.java:57)  
> at org.elasticsearch.common.xcontent.json.JsonXContentParser.(JsonXContentParser.java:44)  
> at org.elasticsearch.common.xcontent.json.JsonXContent.createParser(JsonXContent.java:103)  
> at org.elasticsearch.common.settings.Setting.parseableStringToList(Setting.java:832)  
> at org.elasticsearch.common.settings.Setting.lambda$listSetting$27(Setting.java:786)  
> at org.elasticsearch.common.settings.Setting$$Lambda$168/105203394.apply(Unknown Source)  
> at org.elasticsearch.common.settings.Setting.listSetting(Setting.java:791)  
> at org.elasticsearch.common.settings.Setting.listSetting(Setting.java:786)  
> at org.elasticsearch.common.network.NetworkService.(NetworkService.java:50)  
> at org.elasticsearch.client.transport.TransportClient.newPluginService(TransportClient.java:98)  
> at org.elasticsearch.client.transport.TransportClient.buildTemplate(TransportClient.java:126)  
> at org.elasticsearch.client.transport.TransportClient.(TransportClient.java:268)  
> at org.elasticsearch.transport.client.PreBuiltTransportClient.(PreBuiltTransportClient.java:125)  
> at org.elasticsearch.transport.client.PreBuiltTransportClient.(PreBuiltTransportClient.java:111)  
> at org.elasticsearch.transport.client.PreBuiltTransportClient.(PreBuiltTransportClient.java:101)  
> at com.pixelslanger.px.strains.search.elasticsearch.TransportClientFactory.getTransportClient(TransportClientFactory.java:43)  
> Caused by: java.lang.NullPointerException  
> at org.elasticsearch.Build.(Build.java:49)  
> ... 99 more

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [April 7, 2017, 11:33pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/2 "2017-04-07T23:33:17Z")

</div>

This is a known issue: [ES 5.3 and Java-API 5.3.0 \> java.lang.NullPointerException?](https://discuss.elastic.co/t/es-5-3-and-java-api-5-3-0-java-lang-nullpointerexception/81287)

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [April 7, 2017, 11:49pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/3 "2017-04-07T23:49:29Z")

</div>

Also, as I said on the other issue, and I'll say the same to you: I'm really sorry that you ran into this issue.

---

<div class="post-metadata">

**Author:** ![etay2000](https://avatars.discourse-cdn.com/v4/letter/e/439d5e/32.png) [@etay2000](https://discuss.elastic.co/u/etay2000)\
**Post date:** [April 8, 2017, 12:12am UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/4 "2017-04-08T00:12:44Z")

</div>

No worries, and thanks for the quick response.

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [April 11, 2017, 6:41pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/5 "2017-04-11T18:41:05Z")

</div>

Have you repackaged the transport client jar? It looks here like the manifest is missing?

---

<div class="post-metadata">

**Author:** ![etay2000](https://avatars.discourse-cdn.com/v4/letter/e/439d5e/32.png) [@etay2000](https://discuss.elastic.co/u/etay2000)\
**Post date:** [April 11, 2017, 8:06pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/6 "2017-04-11T20:06:22Z")

</div>

No I didn't do any repackaging of any JARs I simply upgraded from 5.2.2 to 5.3.0 via Maven. I just double checked and the manifest file is present in the 5.3.0 JAR.

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [April 11, 2017, 8:21pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/7 "2017-04-11T20:21:27Z")

</div>

Okay, so I think is indeed a case of how Wildfly handles class loading. Thanks for confirming.

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [April 13, 2017, 10:57am UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/8 "2017-04-13T10:57:40Z")

</div>

This will be fixed in Elasticsearch 5.3.1.

---

<div class="post-metadata">

**Author:** ![etay2000](https://avatars.discourse-cdn.com/v4/letter/e/439d5e/32.png) [@etay2000](https://discuss.elastic.co/u/etay2000)\
**Post date:** [April 13, 2017, 6:38pm UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/9 "2017-04-13T18:38:58Z")

</div>

Nice! Thanks

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [April 18, 2017, 2:50am UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/10 "2017-04-18T02:50:09Z")

</div>

We added tests for this in [https://github.com/elastic/elasticsearch/pull/24147](https://github.com/elastic/elasticsearch/pull/24147) so hopefully we never break it again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 16, 2017, 3:00am UTC](https://discuss.elastic.co/t/cdi-injected-managed-transportclient-fails-in-elasticsearch-5-3/81666/11 "2017-05-16T03:00:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
