# CentOS Stream8 Elastic Agent not sending streams

**URL:** <https://discuss.elastic.co/t/centos-stream8-elastic-agent-not-sending-streams/283859>\
**Category:** Elastic Security\
**Tags:** fleet\
**Created:** [September 10, 2021, 9:56am UTC](https://discuss.elastic.co/t/centos-stream8-elastic-agent-not-sending-streams/283859 "2021-09-10T09:56:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![uf0](https://avatars.discourse-cdn.com/v4/letter/u/f9ae1b/32.png) [@uf0](https://discuss.elastic.co/u/uf0)\
**Post date:** [September 10, 2021, 9:56am UTC](https://discuss.elastic.co/t/centos-stream8-elastic-agent-not-sending-streams/283859/1 "2021-09-10T09:56:16Z")

</div>

Hello

I have just setup a fresh install of ELK + a few agents running on Ubuntu and everything works as expected.

However, as soon as I add the same agent version, 7.14.1 on a CentOS Strem 8, it fails with the following error under filebeat logs:

/opt/Elastic/Agent/data/elastic-agent-703d58/logs/default/filebeat-json.log

```auto
{"log.level":"error","@timestamp":"2021-09-10T05:54:22.825-0400","log.logger":"esclientleg","log.origin":{"file.name":"transport/logging.go","file.line":37},"message":"Error dialing x509: certificate signed by unknown authority (possibly because of \"crypto/rsa: verification error\" while trying to verify candidate authority certificate \"Elastic Certificate Tool Autogenerated CA\")","service.name":"filebeat","network":"tcp","address":"siem03.clear.com:9200","ecs.version":"1.6.0"}

```

I have already imported the .crt in the local trust store and also enrolled the agent with the '--insecure' keyword and also --fleet-server-es-ca=[path to cert]

Why the same configuration works on Ubuntu and not on CentOS?

Thanks in advance

---

<div class="post-metadata">

**Author:** ![blaker](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blaker/32/65621_2.png) [@blaker](https://discuss.elastic.co/u/blaker)\
**Post date:** [September 13, 2021, 3:45pm UTC](https://discuss.elastic.co/t/centos-stream8-elastic-agent-not-sending-streams/283859/2 "2021-09-13T15:45:09Z")

</div>

Did you import the CA into the local store? If you imported the CA why the usage of `--insecure`? If the CA is imported it will be able to successfully validate the certificate, as long as the CA is for the correct domain or IP address.

---

<div class="post-metadata">

**Author:** ![uf0](https://avatars.discourse-cdn.com/v4/letter/u/f9ae1b/32.png) [@uf0](https://discuss.elastic.co/u/uf0)\
**Post date:** [September 15, 2021, 9:04am UTC](https://discuss.elastic.co/t/centos-stream8-elastic-agent-not-sending-streams/283859/3 "2021-09-15T09:04:09Z")

</div>

thank you, I actually fixed it shortly after, when verifying that the CentOS had the correct cert installed in the trust store.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2021, 9:04am UTC](https://discuss.elastic.co/t/centos-stream8-elastic-agent-not-sending-streams/283859/4 "2021-10-13T09:04:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
