# Certificate error on database update

**URL:** <https://discuss.elastic.co/t/certificate-error-on-database-update/286550>\
**Category:** Logstash\
**Created:** [October 12, 2021, 10:16pm UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550 "2021-10-12T22:16:44Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [October 12, 2021, 10:16pm UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/1 "2021-10-12T22:16:45Z")

</div>

After upgrading to logstash 7.14.1, I'm getting this error daily in the logstash-plain.log:

```auto
[ERROR][logstash.filters.geoip.databasemanager] certificate verify failed {:cause=>#<OpenSSL::SSL::SSLError: certificate verify failed>}

```

It doesn't appear to prevent the database update check, I get this error on both hosts where the database check succeeds and fails.

Thanks

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 12, 2021, 11:08pm UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/2 "2021-10-12T23:08:19Z")

</div>

I would be rather surprised, or indeed horrified, if it continued the download after a cert check failure.

In case you are not aware, if the download does not occur logstash will stop doing geoip lookups after 30 days, you will have to switch to a manual download. After 25 days I believe it starts warning that this deadline is upcoming.

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [October 13, 2021, 1:37am UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/3 "2021-10-13T01:37:47Z")

</div>

Yea, I read where it will fail, but there is little info on debugging why it fails. I've turned up logging to "trace" for the next day's errors. BUT, other parts of ELK have options to skip cert verification, can't find any options or defaults for this plugin however.

Thanks

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 13, 2021, 1:52am UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/4 "2021-10-13T01:52:49Z")

</div>

I have not checked the code, but I think it is the MaxMind client library that does the download.

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [October 13, 2021, 2:01pm UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/5 "2021-10-13T14:01:33Z")

</div>

I misread the database stats, you're correct, it is NOT updating after the certificate failure.

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [October 15, 2021, 5:51pm UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/6 "2021-10-15T17:51:04Z")

</div>

Well, with no changes on my end, it started working yesterday and still worked today.

It's almost like they changed the certificate on their end, but since I never found their URL, I don't know.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 12, 2021, 5:51pm UTC](https://discuss.elastic.co/t/certificate-error-on-database-update/286550/7 "2021-11-12T17:51:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
