# Certificate has expired

**URL:** https://discuss.elastic.co/t/certificate-has-expired/356370
**Category:** Elasticsearch
**Created:** [March 28, 2024, 8:56am UTC](https://discuss.elastic.co/t/certificate-has-expired/356370 "2024-03-28T08:56:17Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![cyberzlo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cyberzlo/32/65490_2.png) [@cyberzlo](https://discuss.elastic.co/u/cyberzlo)
#### Post date: [March 28, 2024, 8:56am UTC](https://discuss.elastic.co/t/certificate-has-expired/356370/1 "2024-03-28T08:56:17Z")

</div>

Hi, I hit error from logstash that was unable to connect to ES:

`Unable to retrieve version information from Elasticsearch nodes. certificate has expired`

My clusters are installed from Debian packages. Please give me most easy way that can I handle this problem. My clusters are ELK 8.5+. Yesterday I had to reinstall whole cluster because following some tutorials I break everything... Thank you in advance.

Best would be to make 10-15y certificate / extend it. This is LAN communication, however I don't want disable certificates in case of MiTM. Currently certificates are only for 2y, so my problem will back few times in following year ☹

I am not sure if I just hit this bug? [Public HTTP Secret may hold expired CA · Issue #5621 · elastic/cloud-on-k8s · GitHub](https://github.com/elastic/cloud-on-k8s/issues/5621) - my ELK version was 8.5.2

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 25, 2024, 8:56am UTC](https://discuss.elastic.co/t/certificate-has-expired/356370/2 "2024-04-25T08:56:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
