# Change default data path in Elastic 5.5

**URL:** https://discuss.elastic.co/t/change-default-data-path-in-elastic-5-5/98054
**Category:** Elasticsearch
**Created:** [August 23, 2017, 10:56am UTC](https://discuss.elastic.co/t/change-default-data-path-in-elastic-5-5/98054 "2017-08-23T10:56:52Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Kumar\_Narottam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kumar_narottam/32/18959_2.png) [@Kumar\_Narottam](https://discuss.elastic.co/u/Kumar_Narottam)
#### Post date: [August 23, 2017, 10:56am UTC](https://discuss.elastic.co/t/change-default-data-path-in-elastic-5-5/98054/1 "2017-08-23T10:56:52Z")

</div>

I have installed elastic search 5.5 via debian package. I wanted to change the default data and log path to some other customized folders. I have edited the yml file and restarted. The elastic service fails to start. Can some one suggest how to resolve this issue. It is bugging me since last evening.

---

<div class="post-metadata">

### Author: ![Kumar\_Narottam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kumar_narottam/32/18959_2.png) [@Kumar\_Narottam](https://discuss.elastic.co/u/Kumar_Narottam)
#### Post date: [August 26, 2017, 5:22am UTC](https://discuss.elastic.co/t/change-default-data-path-in-elastic-5-5/98054/2 "2017-08-26T05:22:40Z")

</div>

Can some one help out me.. I do not want to go in prod with elastic default path.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 26, 2017, 9:18am UTC](https://discuss.elastic.co/t/change-default-data-path-in-elastic-5-5/98054/3 "2017-08-26T09:18:39Z")

</div>

> [@Kumar\_Narottam](#):
>
> The elastic service fails to start.

Why? What is the error?

> [@Kumar\_Narottam](#):
>
> I do not want to go in prod with elastic default path.

Why not?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 23, 2017, 9:18am UTC](https://discuss.elastic.co/t/change-default-data-path-in-elastic-5-5/98054/4 "2017-09-23T09:18:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
