# Change in elasticsearch.yml for network.host , the service will not restart

**URL:** <https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432>\
**Category:** Elasticsearch\
**Created:** [October 28, 2019, 9:17am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432 "2019-10-28T09:17:34Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Joseph\_John](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joseph_john/32/53907_2.png) [@Joseph\_John](https://discuss.elastic.co/u/Joseph_John)\
**Post date:** [October 28, 2019, 9:17am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/1 "2019-10-28T09:17:34Z")

</div>

Hi All,  
Good afternoon  
I am installing elasticsearch (7.4.1) , with the default “/etc/elasticsearch/elasticsearch.yml” , when I restart the service it starts and “systemctl status elasticsearch” shows it as running.

Now when I edit “ **/etc/elasticsearch/elasticsearch.yml** ” and change _“network.host: 192.168.3.191”_ and restarting the elasticsearch the service fails, **when I comment “network.host” it works**

> diff elasticsearch.yml elasticsearch.yml-ORG  
> network.host: 192.168.3.191

192.168.3.191 is the IP address of the elasticsearch server, where I had installed elasticsearch

I am trying to bind the elasticsearch to the ipaddress of the elasticsearch server, why is this is failing  
I have tried it in different setups, each setup the same steps followed and failes.  
Guidance and advice requested to find the reason and solve it

Thanks  
Joseph John

**Elasticsearch version** :  
7.4.1  
**Browser version** :  
NA  
**Original install method (e.g. download page, yum, deb, from source, etc.) and version**:  
apt  
**Fresh install or upgraded from other version?**  
Fresh , I have tried it in different machines different installation,  
**Is there anything special in your setup?** For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.  
No  
**Description of the problem including expected versus actual behavior. Please include screenshots (if relevant)**:

**Steps to reproduce** :

1. install elasticsearch on ubuntu 18.04, do service restart and check you will see it is working, now what you do
2. comment out network.host and give the IP of the machine
3. restart the service the service will fail

* * *

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 28, 2019, 10:19am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/2 "2019-10-28T10:19:57Z")

</div>

Have a look at the logs. Pretty sure you have a bootstrap check error. If so,  
please read [https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![Joseph\_John](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joseph_john/32/53907_2.png) [@Joseph\_John](https://discuss.elastic.co/u/Joseph_John)\
**Post date:** [October 28, 2019, 10:43am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/3 "2019-10-28T10:43:47Z")

</div>

Thanks David for the URL,  
I will check and try to solve it and will update  
thanks

---

<div class="post-metadata">

**Author:** ![Joseph\_John](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joseph_john/32/53907_2.png) [@Joseph\_John](https://discuss.elastic.co/u/Joseph_John)\
**Post date:** [October 28, 2019, 10:54am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/4 "2019-10-28T10:54:45Z")

</div>

Hi All,  
Got some idea from the url and the logs  
Once you change the “network.host” the statrup procedure recognize it as a production system than development system and it do some pre-requistive check for the production environment such as  
**“discovery.seed\_hosts, discovery.seed\_providers, cluster.initial\_master\_nodes] “**

```
from the log
“[ERROR][o.e.b.Bootstrap] [apmserver] node validation exception
[1] bootstrap checks failed
[1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured”

```

Now trying to see how I can override this check  
Will update  
thanks  
Joseph John

---

<div class="post-metadata">

**Author:** ![Joseph\_John](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joseph_john/32/53907_2.png) [@Joseph\_John](https://discuss.elastic.co/u/Joseph_John)\
**Post date:** [October 28, 2019, 11:26am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/5 "2019-10-28T11:26:27Z")

</div>

Thanks a lot , David  
It worked, I was able to over ride the production setting check  
commented out

\*\*

> discovery.seed\_hosts: ["host1", "host2"]

\*\*

And it worked

---

<div class="post-metadata">

**Author:** ![Joseph\_John](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joseph_john/32/53907_2.png) [@Joseph\_John](https://discuss.elastic.co/u/Joseph_John)\
**Post date:** [October 29, 2019, 10:43am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/6 "2019-10-29T10:43:44Z")

</div>

Like to update, later on I had to rever back because my kibana was showing the message "Kibana server is not ready yet"  
Reverted back to the default elayticsearh.yml (ie back to the development mode ) and now my clients cannot communicate to the elastisearch IPaddress:9200

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 26, 2019, 10:43am UTC](https://discuss.elastic.co/t/change-in-elasticsearch-yml-for-network-host-the-service-will-not-restart/205432/7 "2019-11-26T10:43:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
