# Changing to Service type of LoadBalancer from ClusterIP on ECK Operator Breaks

**URL:** https://discuss.elastic.co/t/changing-to-service-type-of-loadbalancer-from-clusterip-on-eck-operator-breaks/341276
**Category:** Elastic Cloud on Kubernetes (ECK)
**Created:** [August 21, 2023, 3:50pm UTC](https://discuss.elastic.co/t/changing-to-service-type-of-loadbalancer-from-clusterip-on-eck-operator-breaks/341276 "2023-08-21T15:50:04Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![bigjoe21](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bigjoe21/32/109550_2.png) [@bigjoe21](https://discuss.elastic.co/u/bigjoe21)
#### Post date: [August 21, 2023, 3:50pm UTC](https://discuss.elastic.co/t/changing-to-service-type-of-loadbalancer-from-clusterip-on-eck-operator-breaks/341276/1 "2023-08-21T15:50:04Z")

</div>

I went through the quickstart and successfully deployed elasticsearch and kibana on EKS using the ECK operator. I then followed the directions in the docs to [allow public access](https://www.elastic.co/guide/en/cloud-on-k8s/2.9/k8s-services.html#k8s-allow-public-access).

However, the ECK Operator keeps throwing the error below. Why is it doing this?

```auto
{
  "log.level": "error",
  "@timestamp": "2023-08-21T15:11:07.415Z",
  "log.logger": "manager.eck-operator",
  "message": "Reconciler error",
  "service.version": "2.9.0+f24ccc37",
  "service.type": "eck",
  "ecs.version": "1.4.0",
  "controller": "elasticsearch-controller",
  "object": {
    "name": "quickstart",
    "namespace": "default"
  },
  "namespace": "default",
  "name": "quickstart",
  "reconcileID": "f830060f-bbcb-409d-b6b6-b288a60c4cc1",
  "error": "Service \"quickstart-es-http\" is invalid: spec.loadBalancerClass: Invalid value: \"null\": may not change once set",
  "errorCauses": [
    {
      "error": "Service \"quickstart-es-http\" is invalid: spec.loadBalancerClass: Invalid value: \"null\": may not change once set"
    }
  ],
  "error.stack_trace": "sigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).reconcileHandler\n\t/go/pkg/mod/sigs.k8s.io/controller-runtime@v0.15.0/pkg/internal/controller/controller.go:324\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).processNextWorkItem\n\t/go/pkg/mod/sigs.k8s.io/controller-runtime@v0.15.0/pkg/internal/controller/controller.go:265\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).Start.func2.2\n\t/go/pkg/mod/sigs.k8s.io/controller-runtime@v0.15.0/pkg/internal/controller/controller.go:226"
}

```

---

<div class="post-metadata">

### Author: ![bigjoe21](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bigjoe21/32/109550_2.png) [@bigjoe21](https://discuss.elastic.co/u/bigjoe21)
#### Post date: [August 21, 2023, 6:04pm UTC](https://discuss.elastic.co/t/changing-to-service-type-of-loadbalancer-from-clusterip-on-eck-operator-breaks/341276/2 "2023-08-21T18:04:29Z")

</div>

Turns out I could not have the aws-load-balancer-controller operator installed - once I uninstalled that, it worked.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 18, 2023, 6:05pm UTC](https://discuss.elastic.co/t/changing-to-service-type-of-loadbalancer-from-clusterip-on-eck-operator-breaks/341276/3 "2023-09-18T18:05:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
