# CircuitBreakingException: \[parent\] Data too large

**URL:** <https://discuss.elastic.co/t/circuitbreakingexception-parent-data-too-large/260792>\
**Category:** Elasticsearch\
**Created:** [January 12, 2021, 7:46am UTC](https://discuss.elastic.co/t/circuitbreakingexception-parent-data-too-large/260792 "2021-01-12T07:46:41Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![HenningAndersen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/henningandersen/32/48188_2.png) [@HenningAndersen](https://discuss.elastic.co/u/HenningAndersen)\
**Post date:** [January 18, 2021, 3:00pm UTC](https://discuss.elastic.co/t/circuitbreakingexception-parent-data-too-large/260792/5 "2021-01-18T15:00:34Z")

</div>

Hi @chaitra_hegde,

`marking and sending shard failed due to [failed recovery]` is really two parts:

`marking and sending shard failed`: this happens when a shard fails for some reason. Elasticsearch tells the master node that the shard failed and the master node takes appropriate action (allocating it somewhere else).

`[failed recovery]`: this indicates that the failure of the shard happened while recovering (initializing) the shard. The recovery is when a replica shard is initialized by copying data over from the primary shard.

The particular trigger here was the circuit breaker exception. This happens when ES thinks that too much memory is in use, either for a specific subsystem or overall. In this case, it was the `parent` breaker that triggered this, which is overall memory use. The mentioned fix could help here or it could be a legitimate memory overuse. See also [this comment](https://discuss.elastic.co/t/what-does-this-error-mean-data-too-large-data-for-transport-request/209345/6) for a deeper breakdown of the circuit breaker message.

---

_[View the full topic](https://discuss.elastic.co/t/circuitbreakingexception-parent-data-too-large/260792)._
