# Clean uninstall of elasticsearch

**URL:** <https://discuss.elastic.co/t/clean-uninstall-of-elasticsearch/12993>\
**Category:** Elasticsearch\
**Created:** [July 29, 2013, 11:02pm UTC](https://discuss.elastic.co/t/clean-uninstall-of-elasticsearch/12993 "2013-07-29T23:02:51Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akshay\_Iyengar](https://avatars.discourse-cdn.com/v4/letter/a/d6d6ee/32.png) [@Akshay\_Iyengar](https://discuss.elastic.co/u/Akshay_Iyengar)\
**Post date:** [July 29, 2013, 11:02pm UTC](https://discuss.elastic.co/t/clean-uninstall-of-elasticsearch/12993/1 "2013-07-29T23:02:51Z")

</div>

I was using logstash v.1.1.13 with the latest version of elasticsearch, ie,  
v.0.90.2. But, it wasn't working well and I then read on logstash's site[http://logstash.net/docs/1.1.13/outputs/elasticsearch](http://logstash.net/docs/1.1.13/outputs/elasticsearch) that  
I had to install elasticsearch v.0.20.6. So, I did an rm -rf on the  
existing elasticsearch and installed v.0.20.6. The problem is that somehow,  
it still has retained the old files in the data folder and is unable to  
function properly as it looks for files that do not exist (from the old  
installation). I am surprised as I had done an rm -rf and it still was  
looking for the old files instead of silently looking at the supposedly  
empty cluster due to the fresh installation. After breaking my head over a  
few things I tried, I finally did a curl -XDELETE, and after this,  
elasticsearch starts normally with no errors, but when I go to  
localhost:9200, this is what it says:

{  
"ok" : true,  
"status" : 200,  
"name" : "Blob",  
"version" : {  
"number" : "0.90.2",  
"snapshot\_build" : false,  
"lucene\_version" : "4.3.1"  
},  
"tagline" : "You Know, for Search"  
}

Any idea why? And also, how to avoid this error? Please see this question of mine on stackoverflow for the error [http://stackoverflow.com/questions/17934525/how-to-remove-elasticsearch](http://stackoverflow.com/questions/17934525/how-to-remove-elasticsearch) that was occurring before I did the curl -XDELETE.

Thank you!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:23am UTC](https://discuss.elastic.co/t/clean-uninstall-of-elasticsearch/12993/2 "2017-07-06T02:23:54Z")

</div>


