# Cloudwatch input plugin- No Metrics to Query Error in 6.3.0

**URL:** <https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032>\
**Category:** Logstash\
**Created:** [June 22, 2018, 1:50pm UTC](https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032 "2018-06-22T13:50:31Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![rahulsaini](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rahulsaini](https://discuss.elastic.co/u/rahulsaini)\
**Post date:** [June 22, 2018, 1:50pm UTC](https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032/1 "2018-06-22T13:50:32Z")

</div>

I'm new to ELK working on new version 6.3.0 I get this error but everything work fine on 6.2.1

Stack: C:/Elastic/logstash-6.3.0/vendor/bundle/jruby/2.3.0/gems/logstash-input-cloudwatch-2.1.1/lib/logstash/inputs/cloudwatch.rb:144:in `block in run' C:/Elastic/logstash-6.3.0/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/interval.rb:20:in`interval'  
C:/Elastic/logstash-6.3.0/vendor/bundle/jruby/2.3.0/gems/logstash-input-cloudwatch-2.1.1/lib/logstash/inputs/cloudwatch.rb:141:in `run' C:/Elastic/logstash-6.3.0/logstash-core/lib/logstash/pipeline.rb:512:in`inputworker'  
C:/Elastic/logstash-6.3.0/logstash-core/lib/logstash/pipeline.rb:505:in `block in start\_input'  
[2018-06-22T09:49:02,442][INFO][logstash.inputs.cloudwatch] Polling CloudWatch API  
[2018-06-22T09:49:02,443][ERROR][logstash.pipeline] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::CloudWatch namespace=\>"AWS/EC2", metrics=\>["CPUUtilization"], filters=\>{"tag:AppID"=\>"APP-691"}, interval=\>300, period=\>300, region=\>"us-east-1", access\_key\_id=\>"AKIAJ4NJJ2HUBWBTLS2Q", secret\_access\_key=\>, add\_field=\>{"ApplicationId"=\>"AWSEC2"}, tags=\>["awsec2"], id=\>"a5de607fe116e73ef149d651916526bb6a28112496dbd1c5938750a0b84acb54", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_e5ba9f1f-6d64-4923-b237-0178afe20054", enable\_metric=\>true, charset=\>"UTF-8"\>, role\_session\_name=\>"logstash", use\_ssl=\>true, statistics=\>["SampleCount", "Average", "Minimum", "Maximum", "Sum"], combined=\>false\>  
Error: No metrics to query  
Exception: RuntimeError

input {  
cloudwatch {  
namespace =\> "AWS/EC2"  
metrics =\> ["CPUUtilization"]  
filters =\> { "xxx" }  
interval =\> 300  
period =\> 300  
region =\> "us-east-1"  
access\_key\_id =\> "xxxx"  
secret\_access\_key =\> "xxxxx"  
add\_field =\> { "ApplicationId" =\> "xxx" }  
tags =\> "xxx"  
}  
}

output {  
elasticsearch { hosts =\> ["localhost:9200"]  
index =\> "awscloud"}  
stdout {codec =\> rubydebug}  
}

---

<div class="post-metadata">

**Author:** ![MrThecrackerx](https://avatars.discourse-cdn.com/v4/letter/m/c57346/32.png) [@MrThecrackerx](https://discuss.elastic.co/u/MrThecrackerx)\
**Post date:** [July 11, 2018, 6:19am UTC](https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032/2 "2018-07-11T06:19:46Z")

</div>

i have the same issue. Could somebody help ?

---

<div class="post-metadata">

**Author:** ![zarera](https://avatars.discourse-cdn.com/v4/letter/z/82dd89/32.png) [@zarera](https://discuss.elastic.co/u/zarera)\
**Post date:** [July 25, 2018, 1:06pm UTC](https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032/3 "2018-07-25T13:06:40Z")

</div>

I have the same issue as well . please help.

---

<div class="post-metadata">

**Author:** ![zarera](https://avatars.discourse-cdn.com/v4/letter/z/82dd89/32.png) [@zarera](https://discuss.elastic.co/u/zarera)\
**Post date:** [July 25, 2018, 1:25pm UTC](https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032/4 "2018-07-25T13:25:34Z")

</div>

@rahulsaini did you solved this problem ??

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 22, 2018, 1:25pm UTC](https://discuss.elastic.co/t/cloudwatch-input-plugin-no-metrics-to-query-error-in-6-3-0/137032/5 "2018-08-22T13:25:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
