# Cluster Checkup errors

**URL:** https://discuss.elastic.co/t/cluster-checkup-errors/101159
**Category:** Elasticsearch
**Created:** [September 20, 2017, 11:55am UTC](https://discuss.elastic.co/t/cluster-checkup-errors/101159 "2017-09-20T11:55:13Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![cutch69](https://avatars.discourse-cdn.com/v4/letter/c/977dab/32.png) [@cutch69](https://discuss.elastic.co/u/cutch69)
#### Post date: [September 20, 2017, 11:55am UTC](https://discuss.elastic.co/t/cluster-checkup-errors/101159/1 "2017-09-20T11:55:13Z")

</div>

I just upgraded to 5.6.1 and ran the cluster update. i ran into this error but when checking my nodes they are using the the new path method as described. Another thing i notice when my master node changes to a new node the error move to that node.

path.data: /somepath/somedir/data  
path.logs: /somepath/somedir/log

Error  
Default path settings are removed  
This issue must be resolved to upgrade. Read Documentation  
Details: nodes with settings: [servername]

Warning  
one or more templates use deprecated mapping settings  
Resolving this issue is advised but not required to upgrade. Read Documentation  
Details: {.monitoring-es=[Coercion of boolean fields], watch\_history\_3=[Coercion of boolean fields], security-index-template-v6=[Coercion of boolean fields], .monitoring-kibana-2=[Coercion of boolean fields], .monitoring-logstash-2=[Coercion of boolean fields], .watch-history-6=[Coercion of boolean fields], watch\_history\_2=[Coercion of boolean fields], .monitoring-kibana=[Coercion of boolean fields], security-index-template=[Coercion of boolean fields], .monitoring-logstash=[Coercion of boolean fields], logstash=[The \_all meta field is disabled by default on indices created in 6.0, The [include\_in\_all] mapping parameter is now disallowed], .monitoring-es-2=[Coercion of boolean fields], .ml-anomalies-=[Coercion of boolean fields]}

and i have a 132 of these warn

logstash-2017.08.04  
1 warning  
The [include\_in\_all] mapping parameter is now disallowed  
Resolving this issue is advised but not required to upgrade. Read Documentation  
Details: [[type: syslog, field: @timestamp], [type: syslog, field: @version], [type: _default_, field: @timestamp], [type: _default_, field: @version], [type: cisco, field: @timestamp], [type: cisco, field: @version]]

---

<div class="post-metadata">

### Author: ![revolucio](https://avatars.discourse-cdn.com/v4/letter/r/b77776/32.png) [@revolucio](https://discuss.elastic.co/u/revolucio)
#### Post date: [September 29, 2017, 2:16pm UTC](https://discuss.elastic.co/t/cluster-checkup-errors/101159/2 "2017-09-29T14:16:53Z")

</div>

Hi James,

Just to say that I'm in the same situation as you with 5.6.2

I added

```
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

```

to my _elasticsearch.yml_ but always I have

```
Default path settings are removed
This issue must be resolved to upgrade. Read Documentation
Details: nodes with settings: [NODENAME]

```

Also I confirm that the NODENAME is always the master.

Any help in order to fix this issues will be appreciate.

the more I [Read Documentation](https://www.elastic.co/guide/en/elasticsearch/reference/6.0/breaking_60_packaging_changes.html#_default_path_settings_are_removed) the less I understand how to fix it, as it seems I did what is suggested.

Bests

---

<div class="post-metadata">

### Author: ![rrandaxhe](https://avatars.discourse-cdn.com/v4/letter/r/ebca7d/32.png) [@rrandaxhe](https://discuss.elastic.co/u/rrandaxhe)
#### Post date: [October 4, 2017, 1:22pm UTC](https://discuss.elastic.co/t/cluster-checkup-errors/101159/3 "2017-10-04T13:22:04Z")

</div>

Same issue here in 5.6.2

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 1, 2017, 1:22pm UTC](https://discuss.elastic.co/t/cluster-checkup-errors/101159/4 "2017-11-01T13:22:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
