# Cluster health turns into yellow from Green

**URL:** https://discuss.elastic.co/t/cluster-health-turns-into-yellow-from-green/43824
**Category:** Elasticsearch
**Created:** [March 8, 2016, 7:34pm UTC](https://discuss.elastic.co/t/cluster-health-turns-into-yellow-from-green/43824 "2016-03-08T19:34:22Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![vikas\_gopal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikas_gopal/32/47661_2.png) [@vikas\_gopal](https://discuss.elastic.co/u/vikas_gopal)
#### Post date: [March 8, 2016, 7:34pm UTC](https://discuss.elastic.co/t/cluster-health-turns-into-yellow-from-green/43824/1 "2016-03-08T19:34:22Z")

</div>

Hi Experts ,

My cluster health has been turned to yellow from Green . I have 2 nodes in a cluster and this is what I see with health API

{  
"cluster\_name": "e-3",  
"status": "yellow",  
"timed\_out": false,  
"number\_of\_nodes": 2,  
"number\_of\_data\_nodes": 2,  
"active\_primary\_shards": 32,  
"active\_shards": 59,  
"relocating\_shards": 0,  
"initializing\_shards": 1,  
"unassigned\_shards": 4,  
"delayed\_unassigned\_shards": 0,  
"number\_of\_pending\_tasks": 4,  
"number\_of\_in\_flight\_fetch": 0  
}

Please help me to understand the issue, as I checked it is not an Disk issue as 49 % is available .My ES log says

[2016-03-08 14:15:41,893][WARN][indices.cluster] [Thunderclap] [[cef-2016-03-08][0]] marking and sending shard failed due to [failed to create shard]  
org.elasticsearch.index.shard.IndexShardCreationException: [cef-2016-03-08][0] failed to create shard  
at org.elasticsearch.index.IndexService.createShard(IndexService.java:357)  
at org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:704)  
at org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:605)  
at org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:185)  
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:480)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:196)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:162)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.apache.lucene.store.LockObtainFailedException: Can't lock shard [cef-2016-03-08][0], timed out after 5000ms  
at org.elasticsearch.env.NodeEnvironment$InternalShardLock.acquire(NodeEnvironment.java:582)  
at org.elasticsearch.env.NodeEnvironment.shardLock(NodeEnvironment.java:510)  
at org.elasticsearch.index.IndexService.createShard(IndexService.java:310)

---

<div class="post-metadata">

### Author: ![vikas\_gopal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikas_gopal/32/47661_2.png) [@vikas\_gopal](https://discuss.elastic.co/u/vikas_gopal)
#### Post date: [March 8, 2016, 8:17pm UTC](https://discuss.elastic.co/t/cluster-health-turns-into-yellow-from-green/43824/2 "2016-03-08T20:17:29Z")

</div>

Even adding more nodes to the cluster does not work for me . Status is still yellow.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 11:10pm UTC](https://discuss.elastic.co/t/cluster-health-turns-into-yellow-from-green/43824/3 "2017-07-05T23:10:08Z")

</div>


